summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-07-22 16:28:56 +0000
committerSamuli Suominen <drac@gentoo.org>2007-07-22 16:28:56 +0000
commit2b2d27437977a0a9d45ae7362f399eb7ffcfb4d4 (patch)
tree58264b0af03fac3a995d8934efe7aa19e8d98422 /net-p2p/linkage
parentstable ppc, bug #185078 (diff)
downloadgentoo-2-2b2d27437977a0a9d45ae7362f399eb7ffcfb4d4.tar.gz
gentoo-2-2b2d27437977a0a9d45ae7362f399eb7ffcfb4d4.tar.bz2
gentoo-2-2b2d27437977a0a9d45ae7362f399eb7ffcfb4d4.zip
Attempt to fix automagic dep on libupnp for bug 186102.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-p2p/linkage')
-rw-r--r--net-p2p/linkage/ChangeLog6
-rw-r--r--net-p2p/linkage/files/linkage-0.1.2-enable-disable-upnp.patch28
-rw-r--r--net-p2p/linkage/linkage-0.1.2.ebuild16
3 files changed, 47 insertions, 3 deletions
diff --git a/net-p2p/linkage/ChangeLog b/net-p2p/linkage/ChangeLog
index b55df5cba2e6..2d892b92d363 100644
--- a/net-p2p/linkage/ChangeLog
+++ b/net-p2p/linkage/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/linkage
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/ChangeLog,v 1.2 2007/07/22 14:43:26 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/ChangeLog,v 1.3 2007/07/22 16:28:56 drac Exp $
+
+ 22 Jul 2007; Samuli Suominen <drac@gentoo.org>
+ +files/linkage-0.1.2-enable-disable-upnp.patch, linkage-0.1.2.ebuild:
+ Attempt to fix automagic dep on libupnp for bug 186102.
22 Jul 2007; Samuli Suominen <drac@gentoo.org> linkage-0.1.2.ebuild:
Use fdo-mime.eclass to update mime and desktop databases.
diff --git a/net-p2p/linkage/files/linkage-0.1.2-enable-disable-upnp.patch b/net-p2p/linkage/files/linkage-0.1.2-enable-disable-upnp.patch
new file mode 100644
index 000000000000..540bd88ff6e2
--- /dev/null
+++ b/net-p2p/linkage/files/linkage-0.1.2-enable-disable-upnp.patch
@@ -0,0 +1,28 @@
+diff -ur linkage-0.1.2.orig/configure.ac linkage-0.1.2/configure.ac
+--- linkage-0.1.2.orig/configure.ac 2007-05-04 18:44:57.000000000 +0300
++++ linkage-0.1.2/configure.ac 2007-07-22 18:28:14.000000000 +0300
+@@ -37,8 +37,22 @@
+ AC_SUBST(DBUSGLIB_CFLAGS)
+ AC_SUBST(DBUSGLIB_LIBS)
+
+-PKG_CHECK_MODULES(LIBUPNP, libupnp >= 1.4.1, USE_UPNP="yes", USE_UPNP="no")
+-AM_CONDITIONAL(BUILDUPNP, test x$USE_UPNP = xyes)
++AC_ARG_ENABLE([upnp],
++ [AS_HELP_STRING([--enable-upnp], [Enable libupnp (default=disabled)])],
++ [enable_upnp="$enableval"],
++ [enable_upnp="no"]
++)
++
++if test "$enable_upnp" = "yes"; then
++ PKG_CHECK_MODULES([LIBUPNP], [libupnp >= 1.4.1])
++ AC_DEFINE([BUILDUPNP], [], [Define when building with libupnp])
++ BUILDUPNP="true"
++else
++ BUILDUPNP="false"
++fi
++
++AC_SUBST([ENABLE_LIBUPNP])
++AM_CONDITIONAL([BUILDUPNP], [test "$enable_upnp" = "yes"])
+
+ AC_SUBST(LIBUPNP_CFLAGS)
+ AC_SUBST(LIBUPNP_LIBS)
diff --git a/net-p2p/linkage/linkage-0.1.2.ebuild b/net-p2p/linkage/linkage-0.1.2.ebuild
index aeea6f0da31e..2d388e012d47 100644
--- a/net-p2p/linkage/linkage-0.1.2.ebuild
+++ b/net-p2p/linkage/linkage-0.1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/linkage-0.1.2.ebuild,v 1.2 2007/07/22 14:43:26 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/linkage/linkage-0.1.2.ebuild,v 1.3 2007/07/22 16:28:56 drac Exp $
-inherit fdo-mime
+inherit autotools fdo-mime
DESCRIPTION="BitTorrent client written in C++ using gtkmm and libtorrent."
HOMEPAGE="http://code.google.com/p/linkage"
@@ -22,6 +22,18 @@ RDEPEND=">=net-libs/rb_libtorrent-0.12
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-enable-disable-upnp.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable upnp)
+ emake || die "emake failed."
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed."
dodoc AUTHORS ChangeLog NEWS README TODO