summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2008-03-26 20:49:04 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2008-03-26 20:49:04 +0000
commite2eebae0baf8f11f362382ebd4540c64cecd0914 (patch)
treeacfe86ad1cfa0b1dde7e62a81e495eb46bbca482 /net-p2p/ktorrent
parentDon't run `use opengl` when OPENGL_REQUIRED is set to always (bug #214960). (diff)
downloadgentoo-2-e2eebae0baf8f11f362382ebd4540c64cecd0914.tar.gz
gentoo-2-e2eebae0baf8f11f362382ebd4540c64cecd0914.tar.bz2
gentoo-2-e2eebae0baf8f11f362382ebd4540c64cecd0914.zip
Version bump. Added KDE 4 fixes.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog10
-rw-r--r--net-p2p/ktorrent/ktorrent-3.0.1.ebuild65
2 files changed, 74 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 81ccb1a12694..288493e07a47 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.79 2008/02/22 16:54:54 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.80 2008/03/26 20:49:04 deathwing00 Exp $
+
+*ktorrent-3.0.1 (26 Mar 2008)
+
+ 26 Mar 2008; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +ktorrent-3.0.1.ebuild:
+ Version bump. Fixes bug #214844. Thanks to Kalidarn <dcecchin@gmail.com> for
+ reporting it. Changed NEED_KDE to :kde-4. Thanks to zlin@gentoo.org for his
+ help with KDE 4 changes.
*ktorrent-3.0.0 (22 Feb 2008)
diff --git a/net-p2p/ktorrent/ktorrent-3.0.1.ebuild b/net-p2p/ktorrent/ktorrent-3.0.1.ebuild
new file mode 100644
index 000000000000..d3fcd510f334
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.0.1.ebuild,v 1.1 2008/03/26 20:49:04 deathwing00 Exp $
+
+EAPI="1"
+NEED_KDE=":kde-4"
+inherit versionator kde4-base
+
+# Install to KDEDIR rather than /usr, to slot properly.
+PREFIX="${KDEDIR}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://${PN}.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="kde-4"
+IUSE="+bwscheduler +infowidget +ipfilter +logviewer +scanfolder +search +stats +upnp +webinterface +zeroconf"
+
+DEPEND="dev-libs/gmp
+ app-crypt/qca:2"
+RDEPEND="${DEPEND}
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ || ( >=kde-base/kdebase-kioslaves-4.0.0:${SLOT}
+ >=kde-base/kdebase-4.0.0:${SLOT} ) )
+ zeroconf? (
+ || ( >=kde-base/kdnssd-4.0.0:${SLOT}
+ >=kde-base/kdenetwork-4.0.0:${SLOT} ) )"
+
+LANGS="ar be bg ca da de el en_GB eo es et eu fi fr ga gl hu it ja km lt nb nds nl nn
+oc pl pt pt_BR ru se sk sr sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_compile() {
+ comment_all_add_subdirectory po/ || die "sed to remove all linguas failed."
+
+ local X
+ for X in ${LANGS}; do
+ if use linguas_${X}; then
+ sed -i -e "/add_subdirectory(\s*${X}\s*)\s*$/ s/^#DONOTCOMPILE //" \
+ po/CMakeLists.txt || die "sed to uncomment ${lang} failed."
+ fi
+ done
+
+ mycmakeargs="${mycmakeargs}
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+ -DENABLE_DHT_SUPPORT=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)"
+ kde4-base_src_compile
+}