summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-02-15 19:33:47 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-02-15 19:33:47 +0000
commit1602439aab804ca5ab35b1a4ac62c44fd4c7bb5c (patch)
treee8dfc352f2460bd8b18c5060f84992791826fba8 /net-p2p/ktorrent
parentstable x86, bug 183498 (diff)
downloadgentoo-2-1602439aab804ca5ab35b1a4ac62c44fd4c7bb5c.tar.gz
gentoo-2-1602439aab804ca5ab35b1a4ac62c44fd4c7bb5c.tar.bz2
gentoo-2-1602439aab804ca5ab35b1a4ac62c44fd4c7bb5c.zip
Add ktorrent-2.2.5-r1.ebuild, revision bump fixing bug #206957.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog7
-rw-r--r--net-p2p/ktorrent/ktorrent-2.2.5-r1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 355773629ca0..75d9566da257 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.75 2008/01/29 02:19:23 tgurr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.76 2008/02/15 19:33:47 tgurr Exp $
+
+*ktorrent-2.2.5-r1 (15 Feb 2008)
+
+ 15 Feb 2008; Timo Gurr <tgurr@gentoo.org> +ktorrent-2.2.5-r1.ebuild:
+ Add ktorrent-2.2.5-r1.ebuild, revision bump fixing bug #206957.
*ktorrent-2.2.5 (29 Jan 2008)
diff --git a/net-p2p/ktorrent/ktorrent-2.2.5-r1.ebuild b/net-p2p/ktorrent/ktorrent-2.2.5-r1.ebuild
new file mode 100644
index 000000000000..c3b8d28b1f73
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.2.5-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.2.5-r1.ebuild,v 1.1 2008/02/15 19:33:47 tgurr Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi kdeenablefinal"
+
+DEPEND="dev-libs/gmp
+ >=dev-libs/geoip-1.4.0-r1
+ avahi? ( >=net-dns/avahi-0.6.16-r1 )"
+RDEPEND="${DEPEND}
+ || ( kde-base/kdebase-kioslaves kde-base/kdebase )"
+
+S="${WORKDIR}/${MY_P}"
+
+need-kde 3.5
+
+LANGS="ar bg br ca cs cy da de el en_GB es et fa fr gl hu it ja ka lt
+ms nb nds nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+pkg_setup() {
+ if use avahi && ! built_with_use net-dns/avahi qt3 ; then
+ echo
+ eerror "In order to use ktorrents zeroconf plugin you need to have"
+ eerror "net-dns/avahi emerged with \"qt3\" in your USE flag. Please add"
+ eerror "that flag, re-emerge avahi, and then emerge ktorrent again."
+ echo
+ die "net-dns/avahi not built with \"qt3\" support."
+ fi
+
+ kde_pkg_setup
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+
+ cd "${S}"
+ # Fix automagic dependencies on avahi
+ epatch "${FILESDIR}/${PN}-2.2.5-avahi-check.patch"
+
+ rm -f "${S}/configure"
+}
+
+src_compile(){
+ local myconf="${myconf}
+ $(use_with avahi)
+ --enable-builtin-country-flags
+ --enable-knetwork
+ --enable-system-geoip
+ --enable-torrent-mimetype
+ --disable-geoip"
+
+ kde_src_compile
+}