summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-12 18:20:51 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-12 18:20:51 +0000
commitaafd1d4a491a0532d47b5bf758f3e19dd6105708 (patch)
tree54a1563ac7bcc5959e46c2905b039797a0bb9cba /net-p2p/gtk-gnutella
parentx86 stable per bug 307437 (diff)
downloadgentoo-2-aafd1d4a491a0532d47b5bf758f3e19dd6105708.tar.gz
gentoo-2-aafd1d4a491a0532d47b5bf758f3e19dd6105708.tar.bz2
gentoo-2-aafd1d4a491a0532d47b5bf758f3e19dd6105708.zip
Respect Gentoo's C compiler choice and don't force specific optimizations, thanks to Agostino Sarubbo in bug 382595.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/gtk-gnutella')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog6
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild12
2 files changed, 15 insertions, 3 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index 7ca54f952111..fb00e27075ae 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.115 2011/09/11 19:21:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.116 2011/09/12 18:20:51 graaff Exp $
+
+ 12 Sep 2011; Hans de Graaff <graaff@gentoo.org> gtk-gnutella-0.97.1.ebuild:
+ Respect Gentoo's C compiler choice and don't force specific optimizations,
+ thanks to Agostino Sarubbo in bug 382595.
*gtk-gnutella-0.97.1 (11 Sep 2011)
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild
index ba1c0dd41421..d96f3549a841 100644
--- a/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild,v 1.1 2011/09/11 19:21:26 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.97.1.ebuild,v 1.2 2011/09/12 18:20:51 graaff Exp $
EAPI="2"
@@ -25,6 +25,10 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig"
src_configure() {
+ # There is no option to turn off optimization through the build.sh
+ # script.
+ sed -i -e "s/optimize=''/optimize=' '/" Configure || die
+
# The build script does not support the equivalent --enable
# options so we must construct the configuration by hand.
@@ -48,7 +52,11 @@ src_configure() {
myconf="${myconf} --topless"
fi
- ./build.sh --configure-only --prefix="/usr" ${myconf}
+ ./build.sh \
+ --configure-only \
+ --prefix="/usr" \
+ --cc=$(tc-getCC) \
+ ${myconf}
}
src_install() {