summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-05-15 04:04:32 +0000
committerJon Hood <squinky86@gentoo.org>2006-05-15 04:04:32 +0000
commite2972934d94c81ce0cfe67fa597802d9fe1832f8 (patch)
treedb2a4126632d65ac8f6f317d786f89497b2db8ee /net-p2p/gnunet
parentNew release: 1.5.0. Pruning old ebuilds. (diff)
downloadgentoo-2-e2972934d94c81ce0cfe67fa597802d9fe1832f8.tar.gz
gentoo-2-e2972934d94c81ce0cfe67fa597802d9fe1832f8.tar.bz2
gentoo-2-e2972934d94c81ce0cfe67fa597802d9fe1832f8.zip
Fix init script, #133240.
(Portage version: 2.1_rc1)
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog8
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.7.0d-r13
-rw-r--r--net-p2p/gnunet/files/gnunet-22
-rw-r--r--net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild119
4 files changed, 130 insertions, 2 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index 09c44d5f8558..2ce52fe7b37a 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.44 2006/05/14 04:52:06 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.45 2006/05/15 04:04:32 squinky86 Exp $
+
+*gnunet-0.7.0d-r1 (15 May 2006)
+
+ 15 May 2006; Jon Hood <squinky86@gentoo.org> files/gnunet-2,
+ -gnunet-0.7.0d.ebuild, +gnunet-0.7.0d-r1.ebuild:
+ Fix init script, #133240.
*gnunet-0.7.0d (14 May 2006)
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.7.0d-r1 b/net-p2p/gnunet/files/digest-gnunet-0.7.0d-r1
new file mode 100644
index 000000000000..8d4042c25a97
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.7.0d-r1
@@ -0,0 +1,3 @@
+MD5 c910ceb8acf02e8ef100951bf72ec71a GNUnet-0.7.0d.tar.bz2 1371958
+RMD160 b00d19a326ca0ae92641b89d3039f02782b286d6 GNUnet-0.7.0d.tar.bz2 1371958
+SHA256 990c00d41cb31b52ca30e54ad833327e73f22eca602fdb374bbf1e3eebe0ee33 GNUnet-0.7.0d.tar.bz2 1371958
diff --git a/net-p2p/gnunet/files/gnunet-2 b/net-p2p/gnunet/files/gnunet-2
index 4d2da5e7c2f9..24b3a77afbeb 100644
--- a/net-p2p/gnunet/files/gnunet-2
+++ b/net-p2p/gnunet/files/gnunet-2
@@ -14,7 +14,7 @@ start() {
ebegin "Starting GNUnet"
# -u username, -c path to gnunet.conf file
start-stop-daemon --start --quiet --background --exec /usr/bin/gnunetd \
- -- -u gnunet -c /etc/gnunet.conf
+ -- -u gnunet -c /etc/gnunetd.conf
eend $? "Failed to start GNUnet"
}
diff --git a/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild b/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
new file mode 100644
index 000000000000..4f18ba694c1d
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.0d-r1.ebuild,v 1.1 2006/05/15 04:04:32 squinky86 Exp $
+
+inherit eutils libtool
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.gnu.org/software/GNUnet/"
+SRC_URI="mirror://gnu//${PN}/GNUnet-${PV}.tar.bz2"
+#tests don't work
+RESTRICT="test"
+
+IUSE="ipv6 mysql sqlite guile nls gtk"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=dev-libs/libgcrypt-1.2.0
+ >=media-libs/libextractor-0.5.13
+ >=dev-libs/gmp-4.0.0
+ sys-libs/zlib
+ gtk? ( >=x11-libs/gtk+-2.6.10 )
+ sys-apps/sed
+ ncurses? ( sys-libs/ncurses )
+ mysql? ( >=dev-db/mysql-4.0.24 )
+ sqlite? ( >=dev-db/sqlite-3.0.8 )
+ guile? ( >=dev-util/guile-1.6.0 )
+ nls? ( sys-devel/gettext )"
+
+
+pkg_setup() {
+ if ! use mysql && ! use sqlite; then
+ einfo
+ einfo "You need to specify at least one of 'mysql' or 'sqlite'"
+ einfo "USE flag in order to have properly installed gnunet"
+ einfo
+ die "Invalid USE flag set"
+ fi
+}
+
+pkg_preinst() {
+ enewgroup gnunet || die "Problem adding gnunet group"
+ enewuser gnunet -1 -1 /dev/null gnunet || die "Problem adding gnunet user"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-nulludp.patch
+
+ # make mysql default sqstore if we do not compile sql support
+ # (bug #107330)
+ ! use sqlite && \
+ sed -i 's:default "sqstore_sqlite":default "sqstore_mysql":' \
+ contrib/config-daemon.in
+
+ # we do not want to built gtk support with USE=-gtk
+ if ! use gtk ; then
+ sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
+ autoconf || die "autoconf failed"
+ libtoolize --copy --force
+ fi
+}
+
+src_compile() {
+
+ local myconf
+
+ if use ipv6; then
+ if use amd64; then
+ ewarn "ipv6 in GNUnet does not currently work with amd64 and has been disabled"
+ else
+ myconf="${myconf} --enable-ipv6"
+ fi
+ fi
+
+ use mysql || myconf="${myconf} --without-mysql"
+
+ econf \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ $(use_enable ncurses) \
+ $(use_enable guile) \
+ ${myconf} || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS PLATFORMS README README.fr UPDATING
+ insinto /etc
+ newins contrib/gnunet.root gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PN}-2 gnunet
+ dodir /var/lib/GNUnet
+ chown gnunet:gnunet ${D}/var/lib/GNUnet
+}
+
+pkg_postinst() {
+ # make sure permissions are ok
+ chown -R gnunet:gnunet /var/lib/GNUnet
+
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bugs"
+ einfo
+ einfo "To configure"
+ einfo " 1) Add user(s) to the gnunet group"
+ einfo " 2) Run 'gnunet-setup' to generate your client config file"
+ einfo " 3) Run gnunet-setup -d to generate a server config file"
+ einfo " 4) Optionally copy the .gnunet/gnunetd.conf into /etc and"
+ einfo "\tuse as a global server config file:"
+ einfo "$ gnunet-setup -d"
+ einfo "# cp ~/.gnunet/gnunetd.conf /etc/"
+ einfo
+}
+