summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-05-12 17:43:20 +0000
committerJon Hood <squinky86@gentoo.org>2004-05-12 17:43:20 +0000
commit8df91722a50d31eb0dd7646e9448516a676ea514 (patch)
tree78747ff2ce82d4e2eb26003de08726b540cb5191 /net-p2p/gnunet
parentManifest recommit (Manifest recommit) (diff)
downloadgentoo-2-8df91722a50d31eb0dd7646e9448516a676ea514.tar.gz
gentoo-2-8df91722a50d31eb0dd7646e9448516a676ea514.tar.bz2
gentoo-2-8df91722a50d31eb0dd7646e9448516a676ea514.zip
ebuild had +x permissions, changing
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/Manifest2
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.6.21
-rw-r--r--net-p2p/gnunet/gnunet-0.6.2.ebuild64
3 files changed, 67 insertions, 0 deletions
diff --git a/net-p2p/gnunet/Manifest b/net-p2p/gnunet/Manifest
index ddb6c9cf386f..ea12e6f67c73 100644
--- a/net-p2p/gnunet/Manifest
+++ b/net-p2p/gnunet/Manifest
@@ -3,11 +3,13 @@ MD5 ea51e97cb7566ab77de309b5ebce68a3 gnunet-0.6.1c.ebuild 1470
MD5 28fd4f448ca69666fe9a2b546885f5c7 gnunet-0.5.4-r1.ebuild 1269
MD5 430bf048a7eeec666adf0df79d08fff0 gnunet-0.6.2a.ebuild 1475
MD5 8842bc0976ada205d4da386fff3f966b gnunet-0.6.1b.ebuild 1199
+MD5 a1d972c91fe347b69a8f6071e3b93b2a gnunet-0.6.2.ebuild 1470
MD5 c7cad28a69e17d56a1948f013f900901 ChangeLog 3951
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 7497a53319c18a07e6f673a925b1bf8c files/digest-gnunet-0.6.1b 67
MD5 99094e50a9e664c0f98757ec36e1b5fe files/digest-gnunet-0.6.1c 67
MD5 974a5b99dd02348e2111e88749e1e580 files/digest-gnunet-0.6.2a 67
MD5 c9f162707edf3372ba994a5d274c1280 files/digest-gnunet-0.5.5 65
+MD5 0e1a9b825d565da6bcddd0167198bcb2 files/digest-gnunet-0.6.2 66
MD5 d628356df7b12ee797cbd14ac6918610 files/gnunet 947
MD5 12b0bdd38d4a838fcc6d4e8b970870f5 files/digest-gnunet-0.5.4-r1 65
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.6.2 b/net-p2p/gnunet/files/digest-gnunet-0.6.2
new file mode 100644
index 000000000000..d8e37f9c36d8
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.6.2
@@ -0,0 +1 @@
+MD5 f53c9e17fcece9781f1e81eb5fb816a5 GNUnet-0.6.2.tar.bz2 1057957
diff --git a/net-p2p/gnunet/gnunet-0.6.2.ebuild b/net-p2p/gnunet/gnunet-0.6.2.ebuild
new file mode 100644
index 000000000000..a0790e30eb94
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.6.2.ebuild,v 1.4 2004/05/12 17:43:20 squinky86 Exp $
+
+inherit libtool
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://www.gnu.org/software/GNUnet/"
+SRC_URI="mirror://gnu/${PN}/GNUnet-${PV}.tar.bz2"
+RESTRICT="nomirror"
+
+IUSE="ipv6 gtk crypt mysql"
+
+KEYWORDS="~x86 ~ppc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=dev-libs/openssl-0.9.6d
+ >=sys-libs/gdbm-1.8.0
+ crypt? ( dev-libs/libgcrypt )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ mysql? ( dev-db/mysql )
+ >=media-libs/libextractor-0.3.1"
+
+src_compile() {
+ elibtoolize
+
+ local myconf
+
+ if ! use gtk; then
+ myconf="${myconf} --without-gtk"
+ fi
+
+ if ! use crypt; then
+ myconf="${myconf} --without-gcrypt"
+ fi
+
+ if ! use mysql; then
+ myconf="${myconf} --without-mysql"
+ fi
+
+ econf ${myconf} `use_enable ipv6` || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog PLATFORMS README UPDATING
+ insinto /etc
+ newins contrib/gnunet.root gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+}
+
+pkg_postinst() {
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bug"
+ einfo
+ einfo "now copy an appropriate config file from"
+ einfo "/usr/share/doc/${P}/contrib"
+ einfo "to ~/.gnunet/gnunet.conf"
+ einfo
+}