summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-20 14:20:04 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-20 14:20:04 +0000
commit4719eadf45d4405fd900769f9680c4bf3d2d3452 (patch)
treea2227afd7244cd60e0f95dd2d37ff1660d33f085 /net-p2p/gift
parentia64 stable (diff)
downloadgentoo-2-4719eadf45d4405fd900769f9680c4bf3d2d3452.tar.gz
gentoo-2-4719eadf45d4405fd900769f9680c4bf3d2d3452.tar.bz2
gentoo-2-4719eadf45d4405fd900769f9680c4bf3d2d3452.zip
Revision bump to add the 4 plugins as USE-flags, bug 174858
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-p2p/gift')
-rw-r--r--net-p2p/gift/ChangeLog9
-rw-r--r--net-p2p/gift/files/digest-gift-0.11.8.1-r13
-rw-r--r--net-p2p/gift/gift-0.11.8.1-r1.ebuild67
3 files changed, 77 insertions, 2 deletions
diff --git a/net-p2p/gift/ChangeLog b/net-p2p/gift/ChangeLog
index f8d4513a2bcb..f09e3ee2227f 100644
--- a/net-p2p/gift/ChangeLog
+++ b/net-p2p/gift/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gift
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/ChangeLog,v 1.66 2006/09/11 20:51:40 tcort Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/ChangeLog,v 1.67 2007/04/20 14:20:04 armin76 Exp $
+
+*gift-0.11.8.1-r1 (20 Apr 2007)
+
+ 20 Apr 2007; Raúl Porcel <armin76@gentoo.org> +gift-0.11.8.1-r1.ebuild:
+ Revision bump to add the 4 plugins as USE-flags, bug 174858
11 Sep 2006; Thomas Cort <tcort@gentoo.org> gift-0.11.8.1.ebuild:
Stable on alpha.
diff --git a/net-p2p/gift/files/digest-gift-0.11.8.1-r1 b/net-p2p/gift/files/digest-gift-0.11.8.1-r1
new file mode 100644
index 000000000000..c2bab6747504
--- /dev/null
+++ b/net-p2p/gift/files/digest-gift-0.11.8.1-r1
@@ -0,0 +1,3 @@
+MD5 1c70477af403af142359d07ee4a03348 gift-0.11.8.1.tar.bz2 541446
+RMD160 cef5fe571eff21a61219ce40501652c7b1997a02 gift-0.11.8.1.tar.bz2 541446
+SHA256 7b22e6d36482119a0d2dfd3e911a208439be32f554919536629b4c7c22ea5882 gift-0.11.8.1.tar.bz2 541446
diff --git a/net-p2p/gift/gift-0.11.8.1-r1.ebuild b/net-p2p/gift/gift-0.11.8.1-r1.ebuild
new file mode 100644
index 000000000000..0555734eaf84
--- /dev/null
+++ b/net-p2p/gift/gift-0.11.8.1-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gift/gift-0.11.8.1-r1.ebuild,v 1.1 2007/04/20 14:20:04 armin76 Exp $
+
+inherit eutils libtool
+
+DESCRIPTION="A OpenFT, Gnutella and FastTrack p2p network daemon"
+HOMEPAGE="http://gift.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+IUSE="ares fasttrack gnutella imagemagick openft vorbis"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ia64 x86 ~x86-fbsd"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ sys-apps/file
+ imagemagick? ( >=media-gfx/imagemagick-5.5.7.15 )
+ vorbis? ( >=media-libs/libvorbis-1 )"
+PDEPEND="ares? ( net-p2p/gift-ares )
+ fasttrack? ( net-p2p/gift-fasttrack )
+ gnutella? ( net-p2p/gift-gnutella )
+ openft? ( net-p2p/gift-openft )"
+
+GIFTUSER="p2p"
+
+pkg_preinst() {
+ # Add a new user
+ enewuser ${GIFTUSER} -1 /bin/bash /home/p2p users
+}
+
+src_compile() {
+ econf --enable-libmagic \
+ `use_enable imagemagick` \
+ `use_enable vorbis libvorbis` || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Install failed"
+
+ # init scripts for users who want a central server
+ insinto /etc/conf.d; newins ${FILESDIR}/gift.confd gift
+ exeinto /etc/init.d; newexe ${FILESDIR}/gift.initd gift
+
+ touch ${D}/usr/share/giFT/giftd.log
+ chown ${GIFTUSER}:root ${D}/usr/share/giFT/giftd.log
+}
+
+pkg_postinst() {
+ einfo "Configure gift in /usr/share/giFT/ or run gift-setup"
+ einfo "as normal user and make:"
+ einfo 'cp -R $HOME/.giFT/* /usr/share/giFT/'
+ einfo "chown -R p2p:root /usr/share/giFT/*"
+ einfo "(be carefull while specyfing directories in gift-setup;"
+ einfo "keep in mind that giFT will run as process of user "
+ einfo 'specified in /etc/conf.d/gift with his $HOME directory)'
+ echo
+ einfo "Also, if you will be using the giFT init script, you"
+ einfo "will need to create /usr/share/giFT/giftd.conf"
+ einfo "This method is only recommended for users with a"
+ einfo "central giFT server."
+ echo
+ einfo "This package no longer contains any protocol plugins,"
+ einfo "please try gift-fasttrack, gift-openft, gift-gnutella"
+ einfo "for protocol support."
+}