summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2009-03-19 18:46:15 +0000
committerThomas Sachau <tommy@gentoo.org>2009-03-19 18:46:15 +0000
commit94faa769dad2df13c42aae47bcb4b12b5f6589b9 (patch)
treea2dad23571a2cc66a2f4b656da56232be3a58b5f /net-p2p/fms
parentAdd patch to Generate javadoc for org.freedesktop.bindings.Internationalization. (diff)
downloadgentoo-2-94faa769dad2df13c42aae47bcb4b12b5f6589b9.tar.gz
gentoo-2-94faa769dad2df13c42aae47bcb4b12b5f6589b9.tar.bz2
gentoo-2-94faa769dad2df13c42aae47bcb4b12b5f6589b9.zip
Version bump, remove old
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/fms')
-rw-r--r--net-p2p/fms/ChangeLog9
-rw-r--r--net-p2p/fms/files/utf8.patch20
-rw-r--r--net-p2p/fms/fms-0.3.29.ebuild59
-rw-r--r--net-p2p/fms/fms-0.3.34.ebuild (renamed from net-p2p/fms/fms-0.3.31-r1.ebuild)35
-rw-r--r--net-p2p/fms/metadata.xml3
5 files changed, 56 insertions, 70 deletions
diff --git a/net-p2p/fms/ChangeLog b/net-p2p/fms/ChangeLog
index ef6d33ebef28..151809061604 100644
--- a/net-p2p/fms/ChangeLog
+++ b/net-p2p/fms/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/fms
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.6 2009/03/01 03:10:43 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/ChangeLog,v 1.7 2009/03/19 18:46:14 tommy Exp $
+
+*fms-0.3.34 (19 Mar 2009)
+
+ 19 Mar 2009; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ +files/utf8.patch, metadata.xml, -fms-0.3.29.ebuild,
+ -fms-0.3.31-r1.ebuild, +fms-0.3.34.ebuild:
+ Version bump, remove old
*fms-0.3.32 (01 Mar 2009)
diff --git a/net-p2p/fms/files/utf8.patch b/net-p2p/fms/files/utf8.patch
new file mode 100644
index 000000000000..1a6c6b8659bd
--- /dev/null
+++ b/net-p2p/fms/files/utf8.patch
@@ -0,0 +1,20 @@
+--- src/unicode/utfconversion.cpp 2009-03-01 12:11:56.000000000 +0100
++++ src/unicode/utfconversion.cpp.new 2009-03-18 22:56:09.000000000 +0100
+@@ -52,7 +52,7 @@
+ }
+ else
+ {
+- std::vector<uint32_t> dest2(utf8string.size(),0);
++ std::vector<UTF32> dest2(utf8string.size(),0);
+ UTF32 *deststart=reinterpret_cast<UTF32 *>(&dest2[0]);
+ UTF32 *destend=deststart+dest2.size();
+
+@@ -137,7 +137,7 @@
+ }
+ else
+ {
+- std::vector<uint32_t> source2(wcstring.begin(),wcstring.end());
++ std::vector<UTF32> source2(wcstring.begin(),wcstring.end());
+ std::vector<std::string::value_type> dest(wcstring.size()*sizeof(std::wstring::value_type),0);
+
+ const UTF32 *sourcestart=reinterpret_cast<const UTF32 *>(&source2[0]);
diff --git a/net-p2p/fms/fms-0.3.29.ebuild b/net-p2p/fms/fms-0.3.29.ebuild
deleted file mode 100644
index dc1060a1b0eb..000000000000
--- a/net-p2p/fms/fms-0.3.29.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.29.ebuild,v 1.1 2009/02/05 18:36:43 tommy Exp $
-
-inherit eutils cmake-utils
-
-DESCRIPTION="A spam-resistant message board application for Freenet"
-HOMEPAGE="http://freenetproject.org/tools.html"
-SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="virtual/libiconv
- >=dev-libs/poco-1.2.9
- =dev-db/sqlite-3.6.6.2*"
-RDEPEND="${DEPEND}"
-
-S=${WORKDIR}
-
-pkg_setup() {
- enewgroup freenet
- enewuser freenet -1 -1 /var/freenet freenet
-}
-
-src_compile() {
- local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
- -DUSE_BUNDLED_SQLITE=OFF \
- -DDO_CHARSET_CONVERSION=ON"
- cmake-utils_src_compile
-}
-
-src_install() {
- insinto /var/freenet/fms
- doins ${PN}_build/fms {forum-,}template.htm || die "doinstall failed"
- insinto /var/freenet/fms/fonts
- doins fonts/*.bmp || die "doinstall of fonts failed"
- insinto /var/freenet/fms/images
- doins images/*png || die "doinstall of images failed"
- fperms +x /var/freenet/fms/fms
- fperms -R o-rwx /var/freenet/fms/
- fowners -R freenet:freenet /var/freenet/fms/
- doinitd "${FILESDIR}/fms" || die "installing init.d file failed"
- dodoc readme.txt || die "installing doc failed"
-}
-
-pkg_postinst() {
- if ! has_version 'net-p2p/freenet' ; then
- ewarn "FMS needs a freenet node to up-/download messages."
- ewarn "Please make sure to have a node you can connect to"
- ewarn "or install net-p2p/freenet to get FMS working."
- fi
- elog "By default, the FMS NNTP server will listen on port 1119,"
- elog "and the web configuration interface will be running at"
- elog "http://localhost:8080. For more information, read"
- elog "${DOCDIR}/readme.txt."
-}
diff --git a/net-p2p/fms/fms-0.3.31-r1.ebuild b/net-p2p/fms/fms-0.3.34.ebuild
index cc4d4d3fadfb..d67a5bde5a5b 100644
--- a/net-p2p/fms/fms-0.3.31-r1.ebuild
+++ b/net-p2p/fms/fms-0.3.34.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.31-r1.ebuild,v 1.1 2009/02/12 18:07:16 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/fms/fms-0.3.34.ebuild,v 1.1 2009/03/19 18:46:14 tommy Exp $
+
+EAPI="2"
inherit eutils cmake-utils
-DESCRIPTION="A spam-resistant message board application for Freenet"
+DESCRIPTION="A spam-resistant #ssage board application for Freenet"
HOMEPAGE="http://freenetproject.org/tools.html"
SRC_URI="mirror://gentoo/${PN}-src-${PV}.zip"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="frost"
DEPEND="virtual/libiconv
+ frost? ( >=dev-libs/libtomcrypt-1.17-r3[libtommath] )
>=dev-libs/poco-1.2.9
- =dev-db/sqlite-3.6.6.2*"
+ || ( =dev-db/sqlite-3.6.6.2* >=dev-db/sqlite-3.6.11 )"
RDEPEND="${DEPEND}"
S=${WORKDIR}
@@ -25,16 +28,23 @@ pkg_setup() {
enewuser freenet -1 -1 /var/freenet freenet
}
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/utf8.patch
+ sed -i "s:LTC_PKCS:LTC_LTC_PKCS:g" src/freenet/frostidentity.cpp
+}
+
+src_configure() {
local mycmakeargs="-DI_HAVE_READ_THE_README=ON \
-DUSE_BUNDLED_SQLITE=OFF \
- -DDO_CHARSET_CONVERSION=ON"
- cmake-utils_src_compile
+ -DDO_CHARSET_CONVERSION=ON \
+ $(cmake-utils_use frost FROST_SUPPORT)"
+ use frost && append-flags -DLTM_DESC
+ cmake-utils_src_configure
}
src_install() {
- dobin ${PN}_build/fms || die
insinto /var/freenet/fms
+ dobin ${PN}_build/fms || die
doins {forum-,}template.htm || die "doinstall failed"
insinto /var/freenet/fms/fonts
doins fonts/*.bmp || die "doinstall of fonts failed"
@@ -48,12 +58,17 @@ src_install() {
pkg_postinst() {
if ! has_version 'net-p2p/freenet' ; then
- ewarn "FMS needs a freenet node to up-/download messages."
+ ewarn "FMS needs a freenet node to up-/download #ssages."
ewarn "Please make sure to have a node you can connect to"
ewarn "or install net-p2p/freenet to get FMS working."
fi
elog "By default, the FMS NNTP server will listen on port 1119,"
elog "and the web configuration interface will be running at"
elog "http://localhost:8080. For more information, read"
- elog "${ROOT}/usr/share/doc/${PF}/readme.txt."
+ elog "${ROOT}usr/share/doc/${PF}/readme.txt.bz2"
+ if use frost; then
+ elog " "
+ elog "You need to enable frost on the config page"
+ elog "and restart fms for frost support."
+ fi
}
diff --git a/net-p2p/fms/metadata.xml b/net-p2p/fms/metadata.xml
index fead1cc4d517..6c6e72a6d9fb 100644
--- a/net-p2p/fms/metadata.xml
+++ b/net-p2p/fms/metadata.xml
@@ -6,5 +6,8 @@
<name>Thomas Sachau (Tommy[D])</name>
</maintainer>
<herd>net-p2p</herd>
+ <use>
+ <flag name='frost'>Add support for frost boards</flag>
+ </use>
</pkgmetadata>