summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-03-12 20:10:12 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-03-12 20:10:12 +0000
commit8a5e4d227568dd9b5a673893c776395b033fa784 (patch)
tree29d851b8ad278dd8a0a8e3e4dbce958e6035273d /net-p2p/deluge
parentStable on x86 (diff)
downloadgentoo-2-8a5e4d227568dd9b5a673893c776395b033fa784.tar.gz
gentoo-2-8a5e4d227568dd9b5a673893c776395b033fa784.tar.bz2
gentoo-2-8a5e4d227568dd9b5a673893c776395b033fa784.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/ChangeLog8
-rw-r--r--net-p2p/deluge/deluge-0.5.8.6.ebuild47
-rw-r--r--net-p2p/deluge/deluge-9999.ebuild7
3 files changed, 57 insertions, 5 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index 6b41eae24390..0462ed8083cd 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.58 2008/02/29 16:02:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.59 2008/03/12 20:10:12 armin76 Exp $
+
+*deluge-0.5.8.6 (12 Mar 2008)
+
+ 12 Mar 2008; Raúl Porcel <armin76@gentoo.org> +deluge-0.5.8.6.ebuild,
+ deluge-9999.ebuild:
+ Version bump
*deluge-0.5.8.5 (29 Feb 2008)
diff --git a/net-p2p/deluge/deluge-0.5.8.6.ebuild b/net-p2p/deluge/deluge-0.5.8.6.ebuild
new file mode 100644
index 000000000000..4938c8a98ed5
--- /dev/null
+++ b/net-p2p/deluge/deluge-0.5.8.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-0.5.8.6.ebuild,v 1.1 2008/03/12 20:10:12 armin76 Exp $
+
+inherit eutils distutils flag-o-matic
+
+DESCRIPTION="BitTorrent client in Python and PyGTK."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="libnotify"
+
+S="${WORKDIR}"/${PN}-torrent-${PV}
+
+DEPEND=">=dev-lang/python-2.3
+ dev-libs/boost"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2
+ dev-python/pyxdg
+ dev-python/dbus-python
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )"
+
+pkg_setup() {
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
+ eerror "dev-libs/boost has to be built with threads USE-flag."
+ die "Missing threads USE-flag for dev-libs/boost"
+ fi
+
+ filter-ldflags -Wl,--as-needed
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "Please note that Deluge is still in it's early stages"
+ elog "of development. Use it carefully and feel free to submit bugs"
+ elog "in upstream page."
+ elog
+}
diff --git a/net-p2p/deluge/deluge-9999.ebuild b/net-p2p/deluge/deluge-9999.ebuild
index ff19ce123f58..9ac71a7cc1ad 100644
--- a/net-p2p/deluge/deluge-9999.ebuild
+++ b/net-p2p/deluge/deluge-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.9 2008/02/25 14:13:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-9999.ebuild,v 1.10 2008/03/12 20:10:12 armin76 Exp $
inherit eutils distutils subversion flag-o-matic
@@ -14,7 +14,7 @@ SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="libnotify browser"
+IUSE="libnotify"
DEPEND=">=dev-lang/python-2.3
dev-libs/boost"
@@ -23,8 +23,7 @@ RDEPEND="${DEPEND}
dev-python/pyxdg
dev-python/dbus-python
gnome-base/librsvg
- libnotify? ( dev-python/notify-python )
- browser? ( dev-python/gnome-python-extras )"
+ libnotify? ( dev-python/notify-python )"
pkg_setup() {
if has_version "<dev-libs/boost-1.34" && \