summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2010-03-01 20:56:59 +0000
committerRaúl Porcel <armin76@gentoo.org>2010-03-01 20:56:59 +0000
commit70ab650dbe0a2e380e15e667a145ef94f2de5ae6 (patch)
treedab133119b2e6e67fab1ca071ee7fe719cf71735 /net-p2p/deluge
parentVersion bump dev-python/pygments to 1.3, yay 0-day. (diff)
downloadgentoo-2-70ab650dbe0a2e380e15e667a145ef94f2de5ae6.tar.gz
gentoo-2-70ab650dbe0a2e380e15e667a145ef94f2de5ae6.tar.bz2
gentoo-2-70ab650dbe0a2e380e15e667a145ef94f2de5ae6.zip
Version bump
(Portage version: 2.1.7.17/cvs/Linux ia64)
Diffstat (limited to 'net-p2p/deluge')
-rw-r--r--net-p2p/deluge/ChangeLog7
-rw-r--r--net-p2p/deluge/deluge-1.2.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/net-p2p/deluge/ChangeLog b/net-p2p/deluge/ChangeLog
index f60dc91fc3c0..ffa497f3b721 100644
--- a/net-p2p/deluge/ChangeLog
+++ b/net-p2p/deluge/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/deluge
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.140 2010/01/12 21:01:06 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/ChangeLog,v 1.141 2010/03/01 20:56:59 armin76 Exp $
+
+*deluge-1.2.1 (01 Mar 2010)
+
+ 01 Mar 2010; Raúl Porcel <armin76@gentoo.org> +deluge-1.2.1.ebuild:
+ Version bump
*deluge-1.2.0 (12 Jan 2010)
diff --git a/net-p2p/deluge/deluge-1.2.1.ebuild b/net-p2p/deluge/deluge-1.2.1.ebuild
new file mode 100644
index 000000000000..2a23a3c54a7d
--- /dev/null
+++ b/net-p2p/deluge/deluge-1.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.2.1.ebuild,v 1.1 2010/03/01 20:56:59 armin76 Exp $
+
+EAPI="2"
+
+inherit eutils distutils flag-o-matic python
+
+DESCRIPTION="BitTorrent client with a client/server model."
+HOMEPAGE="http://deluge-torrent.org/"
+SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="gtk libnotify webinterface"
+
+DEPEND=">=virtual/python-2.5
+ || ( app-arch/xz-utils app-arch/lzma-utils )
+ >=net-libs/rb_libtorrent-0.14.9[python]
+ dev-python/setuptools"
+RDEPEND="${DEPEND}
+ dev-python/chardet
+ dev-python/pyopenssl
+ dev-python/pyxdg
+ || ( >=virtual/python-2.6 dev-python/simplejson )
+ >=dev-python/twisted-8.1
+ >=dev-python/twisted-web-8.1
+ gtk? (
+ dev-python/pygame
+ dev-python/pygobject
+ >=dev-python/pygtk-2.12
+ gnome-base/librsvg
+ libnotify? ( dev-python/notify-python )
+ )
+ webinterface? ( dev-python/mako )"
+
+pkg_setup() {
+ append-ldflags $(no-as-needed)
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}"/deluged.init deluged
+ newconfd "${FILESDIR}"/deluged.conf deluged
+}
+
+pkg_postinst() {
+ elog
+ elog "If after upgrading it doesn't work, please remove the"
+ elog "'~/.config/deluge' directory and try again, but make a backup"
+ elog "first!"
+ elog
+ elog "To start the daemon either run 'deluged' as user"
+ elog "or modify /etc/conf.d/deluged and run"
+ elog "/etc/init.d/deluged start as root"
+ elog "You can still use deluge the old way"
+ elog
+ elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
+ elog
+}