summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-01-31 23:15:11 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-01-31 23:15:11 +0000
commit097d9ceecd3cbf672155495bae3f4cf088067c00 (patch)
treeb56b55b45bcc2a1a1410b193f8cad0b77e770185 /net-p2p/dctc/dctc-0.85.9.ebuild
parentVersion bumped. Closes 40005 (diff)
downloadgentoo-2-097d9ceecd3cbf672155495bae3f4cf088067c00.tar.gz
gentoo-2-097d9ceecd3cbf672155495bae3f4cf088067c00.tar.bz2
gentoo-2-097d9ceecd3cbf672155495bae3f4cf088067c00.zip
Version bumped. Closes 40005
Diffstat (limited to 'net-p2p/dctc/dctc-0.85.9.ebuild')
-rw-r--r--net-p2p/dctc/dctc-0.85.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/dctc/dctc-0.85.9.ebuild b/net-p2p/dctc/dctc-0.85.9.ebuild
new file mode 100644
index 000000000000..b518d12a5aa1
--- /dev/null
+++ b/net-p2p/dctc/dctc-0.85.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dctc/dctc-0.85.9.ebuild,v 1.1 2004/01/31 23:14:44 mholzer Exp $
+
+DESCRIPTION="Direct Connect Text Client, almost famous file share program"
+HOMEPAGE="http://ac2i.homelinux.com/dctc/"
+SRC_URI="http://ac2i.homelinux.com/dctc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=dev-libs/glib-2*
+ >=sys-libs/db-3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # fix for #26708 (db4 support)
+ local dbfunc="`nm /usr/lib/libdb.so | grep \ db_env_create | awk '{print $3}'`"
+ if [ "${dbfunc}" != "db_env_create" ] ; then
+ sed -i "s:db_env_create:${dbfunc}:g" configure
+ fi
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die
+ dodoc Documentation/* Documentation/DCextensions/*
+ dodoc AUTHORS COPYING ChangeLog INSTALL KNOWN_BUGS NEWS README TODO
+}