summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-04-19 17:20:50 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-04-19 17:20:50 +0000
commite1eed16a07a292ff5d3d98da7724b2124fa58280 (patch)
treee196e10fb105074271ffdf7c42d48b9d268619cd /net-p2p/ctorrent
parentSome tweaks (diff)
downloadgentoo-2-e1eed16a07a292ff5d3d98da7724b2124fa58280.tar.gz
gentoo-2-e1eed16a07a292ff5d3d98da7724b2124fa58280.tar.bz2
gentoo-2-e1eed16a07a292ff5d3d98da7724b2124fa58280.zip
Version bump
(Portage version: 2.1.5_rc5)
Diffstat (limited to 'net-p2p/ctorrent')
-rw-r--r--net-p2p/ctorrent/ChangeLog10
-rw-r--r--net-p2p/ctorrent/ctorrent-3.3.ebuild25
-rw-r--r--net-p2p/ctorrent/files/as-needed.patch28
3 files changed, 33 insertions, 30 deletions
diff --git a/net-p2p/ctorrent/ChangeLog b/net-p2p/ctorrent/ChangeLog
index 7ae68e332322..c9cfc6811be3 100644
--- a/net-p2p/ctorrent/ChangeLog
+++ b/net-p2p/ctorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ctorrent
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ChangeLog,v 1.35 2007/12/17 20:04:43 armin76 Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ChangeLog,v 1.36 2008/04/19 17:20:49 armin76 Exp $
+
+*ctorrent-3.3 (19 Apr 2008)
+
+ 19 Apr 2008; Raúl Porcel <armin76@gentoo.org> -files/as-needed.patch,
+ +ctorrent-3.3.ebuild:
+ Version bump
*ctorrent-3.2-r1 (17 Dec 2007)
diff --git a/net-p2p/ctorrent/ctorrent-3.3.ebuild b/net-p2p/ctorrent/ctorrent-3.3.ebuild
new file mode 100644
index 000000000000..2fd430d544d4
--- /dev/null
+++ b/net-p2p/ctorrent/ctorrent-3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ctorrent/ctorrent-3.3.ebuild,v 1.1 2008/04/19 17:20:49 armin76 Exp $
+
+inherit eutils
+
+MY_P="${PN}-dnh${PV}"
+
+DESCRIPTION="Enhanced CTorrent is a BitTorrent console client written in C and C++."
+HOMEPAGE="http://www.rahul.net/dholmes/ctorrent/"
+SRC_URI="mirror://sourceforge/dtorrent/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="dev-libs/openssl"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog README-DNH.TXT README NEWS
+}
diff --git a/net-p2p/ctorrent/files/as-needed.patch b/net-p2p/ctorrent/files/as-needed.patch
deleted file mode 100644
index cc43be0b68b5..000000000000
--- a/net-p2p/ctorrent/files/as-needed.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- btcontent.cpp.orig 2007-01-19 00:12:24.000000000 +0100
-+++ btcontent.cpp 2007-01-19 00:12:35.000000000 +0100
-@@ -9,9 +9,9 @@
- #else
- #include <unistd.h>
- #include <sys/param.h>
--#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD) || defined(HAVE_LIBCRYPTO)
-+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
- #include <sha.h>
--#elif defined(HAVE_LIBSSL)
-+#elif defined(HAVE_LIBSSL) || defined(HAVE_LIBCRYPTO)
- #include <openssl/sha.h>
- #endif
- #endif
---- btfiles.cpp.orig 2007-01-19 00:17:04.000000000 +0100
-+++ btfiles.cpp 2007-01-19 00:17:18.000000000 +0100
-@@ -8,9 +8,9 @@
- #include <unistd.h>
- #include <dirent.h>
- #include <sys/param.h>
--#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD) || defined(HAVE_LIBCRYPTO)
-+#if defined(HAVE_LIBCRYPT) || defined(HAVE_LIBMD)
- #include <sha.h>
--#elif defined(HAVE_LIBSSL)
-+#elif defined(HAVE_LIBSSL) || defined(HAVE_LIBCRYPTO)
- #include <openssl/sha.h>
- #endif
- #endif