summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-09-10 16:09:11 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-09-10 16:09:11 +0000
commit641bfcb45e8ea1a865d2df27c890d57587067f97 (patch)
tree230369f6c51f4c90fb416225faeeb12ad001b0b4 /net-p2p/bittorrent
parentVersion bump, thanks too Josh Nichols in 101844 (diff)
downloadgentoo-2-641bfcb45e8ea1a865d2df27c890d57587067f97.tar.gz
gentoo-2-641bfcb45e8ea1a865d2df27c890d57587067f97.tar.bz2
gentoo-2-641bfcb45e8ea1a865d2df27c890d57587067f97.zip
Fixed init script and mime entry to match new naming scheme, bug #105143
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog6
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.4.ebuild12
-rw-r--r--net-p2p/bittorrent/files/bttrack.rc-4.123
3 files changed, 34 insertions, 7 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index ffde54f2fff5..6d37e35d54b4 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.59 2005/09/02 20:25:32 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.60 2005/09/10 16:09:11 sekretarz Exp $
+
+ 10 Sep 2005; Karol Wojtaszek <sekretarz@gentoo.org> +files/bttrack.rc-4.1,
+ bittorrent-4.1.4.ebuild:
+ Fixed init script and mime entry to match new naming scheme, bug #105143
02 Sep 2005; Michael Hanselmann <hansmi@gentoo.org>
bittorrent-4.0.2.ebuild:
diff --git a/net-p2p/bittorrent/bittorrent-4.1.4.ebuild b/net-p2p/bittorrent/bittorrent-4.1.4.ebuild
index 46430ff76a52..9b2c493484ec 100644
--- a/net-p2p/bittorrent/bittorrent-4.1.4.ebuild
+++ b/net-p2p/bittorrent/bittorrent-4.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.4.ebuild,v 1.4 2005/08/27 20:04:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.4.ebuild,v 1.5 2005/09/10 16:09:11 sekretarz Exp $
inherit distutils fdo-mime eutils
@@ -36,7 +36,7 @@ PYTHON_MODNAME="BitTorrent"
src_install() {
distutils_src_install
if ! use X; then
- rm ${D}/usr/bin/*gui.py
+ rm ${D}/usr/bin/bittorrent
fi
dohtml redirdonate.html
dodir etc
@@ -45,7 +45,7 @@ src_install() {
mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${P}/
rm -fr ${D}/usr/share/doc/${MY_P}
- MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/bittorrent '%s'; test=test -n \"\$DISPLAY\""
if use X; then
if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
@@ -72,12 +72,12 @@ src_install() {
newins ${FILESDIR}/bttrack.conf bttrack
exeinto /etc/init.d
- newexe ${FILESDIR}/bttrack.rc bttrack
+ newexe ${FILESDIR}/bttrack.rc-4.1 bttrack
}
pkg_postinst() {
- einfo "BitTorrent has changed to the BitTorrent Open Source License"
- einfo ">> http://www.bittorrent.com/license/"
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
distutils_pkg_postinst
fdo-mime_desktop_database_update
}
diff --git a/net-p2p/bittorrent/files/bttrack.rc-4.1 b/net-p2p/bittorrent/files/bttrack.rc-4.1
new file mode 100644
index 000000000000..6f17d701201b
--- /dev/null
+++ b/net-p2p/bittorrent/files/bttrack.rc-4.1
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/files/bttrack.rc-4.1,v 1.1 2005/09/10 16:09:11 sekretarz Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting bttrack"
+ start-stop-daemon --start --quiet --background --make-pidfile \
+ --pidfile /var/run/bttrack.pid \
+ --exec /usr/bin/bittorrent-tracker -- --port ${PORT} \
+ --dfile ${DFILE} --favicon ${FAVICON} --logfile ${LOGFILE}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bttrack"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bttrack.pid
+ eend $?
+}