summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr@gentoo.org>2003-08-10 21:38:25 +0000
committerLuke Dashjr <luke-jr@gentoo.org>2003-08-10 21:38:25 +0000
commit2a142cfdd53a35ae5d5b6437d63669cbf2e9e4ba (patch)
tree9abc4ed311f442f278b84a519371c877fd66c805 /net-p2p/bittorrent
parentNow uses virtual/bittorrent; revision bump since it's not compiling anything ... (diff)
downloadgentoo-2-2a142cfdd53a35ae5d5b6437d63669cbf2e9e4ba.tar.gz
gentoo-2-2a142cfdd53a35ae5d5b6437d63669cbf2e9e4ba.tar.bz2
gentoo-2-2a142cfdd53a35ae5d5b6437d63669cbf2e9e4ba.zip
Now uses virtual/bittorrent; revision bump since it's not compiling anything anyway
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/Manifest4
-rw-r--r--net-p2p/bittorrent/bittorrent-3.2.1b-r4.ebuild60
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r41
4 files changed, 70 insertions, 3 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index ea1ea2598b5e..ab2304e104a4 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.14 2003/08/01 22:25:43 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.15 2003/08/10 21:38:18 luke-jr Exp $
+
+*bittorrent-3.2.1b-r4 (10 Aug 2003)
+
+ 10 Aug 2003; Luke-Jr <luke-jr@gentoo.org> bittorrent-3.2.1b-r4.ebuild:
+ Now uses virtual/bittorrent; revision bump since it's not compiling anything
+ anyway
01 Aug 2003; Tavis Ormandy <taviso@gentoo.org> bittorrent-3.2.1b-r3.ebuild:
stable on alpha
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 60d22d77b54f..8e48064e42bd 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -1,10 +1,10 @@
-MD5 857862c3123c213da470b6139628fe78 ChangeLog 2391
+MD5 8950bda8f310b6f634ee56549f78b260 ChangeLog 2392
MD5 41a014fa295e307a91a3d3560e05f896 bittorrent-3.2.1.ebuild 1207
MD5 6099d936c15b910885298da61f1f76b2 bittorrent-3.2.1b-r1.ebuild 1287
MD5 78ff5f95fa1fc16340582e6793a77f62 bittorrent-3.2.1b-r2.ebuild 1441
MD5 407711b13084d7c3b015522966b9ec5e bittorrent-3.2.1b-r3.ebuild 1598
MD5 e6bcaed5c1bb4770c0d01b90456a7837 bittorrent-3.2.1b.ebuild 1208
-MD5 8ac5576985941acd84f1c52eda1fd9ab bittorrent-3.2.1b-r4.ebuild 1648
+MD5 6b4dd8a0972596ff8edca38823c3fdc2 bittorrent-3.2.1b-r4.ebuild 1649
MD5 e7e7d0aa3c6c5d57b54db37b53ac066a files/digest-bittorrent-3.2.1 68
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b 69
MD5 7bc9832711abd6cc2e334adca1335f74 files/bittorrent-3.2.1b.patch 6500
diff --git a/net-p2p/bittorrent/bittorrent-3.2.1b-r4.ebuild b/net-p2p/bittorrent/bittorrent-3.2.1b-r4.ebuild
new file mode 100644
index 000000000000..63df7ced7dfb
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.2.1b-r4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.2.1b-r4.ebuild,v 1.1 2003/08/10 21:38:18 luke-jr Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://bitconjurer.org/BitTorrent/${MY_P}.tar.gz"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="x86 ~ppc alpha ~sparc"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/bittorrent-stats-${PV}.patch || die "patch failed"
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r4 b/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r4
new file mode 100644
index 000000000000..cfa354976ae9
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.2.1b-r4
@@ -0,0 +1 @@
+MD5 9e0cc346a4bfa3904380ed119d8bac90 BitTorrent-3.2.1b.tar.gz 144420