summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-24 19:32:15 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-24 19:32:15 +0000
commit7ecc12ae3cedffe6441f38aed4c6f6c38f79cd92 (patch)
treeff35787b40b7f2ebf8ca3247d14102c2101a571d /net-p2p/bitflu
parentx86 stable, bug #380175 (diff)
downloadgentoo-2-7ecc12ae3cedffe6441f38aed4c6f6c38f79cd92.tar.gz
gentoo-2-7ecc12ae3cedffe6441f38aed4c6f6c38f79cd92.tar.bz2
gentoo-2-7ecc12ae3cedffe6441f38aed4c6f6c38f79cd92.zip
Version bump
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/bitflu')
-rw-r--r--net-p2p/bitflu/ChangeLog5
-rw-r--r--net-p2p/bitflu/bitflu-1.38.ebuild79
2 files changed, 84 insertions, 0 deletions
diff --git a/net-p2p/bitflu/ChangeLog b/net-p2p/bitflu/ChangeLog
index 8851a6a9cf14..46811e60b1df 100644
--- a/net-p2p/bitflu/ChangeLog
+++ b/net-p2p/bitflu/ChangeLog
@@ -1,5 +1,10 @@
+*bitflu-1.38 (24 Aug 2011)
+
+ 24 Aug 2011; Anthony G. Basile <blueness@gentoo.org> +bitflu-1.38.ebuild:
+ Version bump
+
21 Aug 2011; Anthony G. Basile <blueness@gentoo.org> bitflu-1.37.ebuild:
Added depend on dev-perl/Sys-Syscall, bug #380079
diff --git a/net-p2p/bitflu/bitflu-1.38.ebuild b/net-p2p/bitflu/bitflu-1.38.ebuild
new file mode 100644
index 000000000000..cfb4bb72498b
--- /dev/null
+++ b/net-p2p/bitflu/bitflu-1.38.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitflu/bitflu-1.38.ebuild,v 1.1 2011/08/24 19:32:15 blueness Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="Bitflu is a BitTorrent client, written in Perl and is designed to run as a daemon"
+HOMEPAGE="http://bitflu.workaround.ch"
+SRC_URI="http://bitflu.workaround.ch/bitflu/${P}.tgz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-perl/Danga-Socket
+ dev-perl/Sys-Syscall"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup bitflu
+ enewuser bitflu -1 -1 /var/lib/bitflu bitflu
+}
+
+src_compile() {
+:
+}
+
+PLUGINS="/usr/lib/bitflu"
+HOMEDIR="/var/lib/bitflu"
+CONFDIR="/etc/bitflu"
+LOGDIR="/var/log/bitflu"
+
+src_install() {
+ # executable daemon
+ exeinto /usr/sbin
+ doexe bitflu.pl
+
+ # plugins
+ dodir "${PLUGINS}"
+ insinto "${PLUGINS}"
+ doins -r plugins
+
+ # working dir
+ dodir "${HOMEDIR}"
+ fowners bitflu:bitflu "${HOMEDIR}"
+ fperms 775 "${HOMEDIR}"
+
+ # config file
+ dodir "${CONFDIR}"
+ fowners bitflu:bitflu "${CONFDIR}"
+ fperms 775 "${CONFDIR}"
+ insinto "${CONFDIR}"
+ doins "${FILESDIR}"/bitflu.config
+ fowners bitflu:bitflu "${CONFDIR}"/bitflu.config
+ fperms 664 "${CONFDIR}"/bitflu.config
+
+ # log file
+ dodir "${LOGDIR}"
+ fowners bitflu:bitflu "${LOGDIR}"
+ fperms 775 "${LOGDIR}"
+
+ # docs
+ dodoc bitflu.config.example ChangeLog.txt CONTRIBUTING README_IPv6.txt \
+ README.txt Documentation/bitflu-internals.txt
+
+ newinitd "${FILESDIR}"/bitflu.initd bitflu
+}
+
+pkg_postinst() {
+ ewarn "Note: At startup, or at the user's request, ${PN} (re)reads its"
+ ewarn "configuration file and overwrites it with its own sanitized"
+ ewarn "version. A backup is created in the configuration directory,"
+ ewarn "/etc/${PN}, but that file will subseqently be overwritten if"
+ ewarn "a further backup is made. You may want to keep your own backup."
+ ewarn "A prestine example with comments may be found in /usr/share/doc/${P}."
+}