summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2006-09-10 14:36:04 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2006-09-10 14:36:04 +0000
commit0bb7670cb42c4089ea2742639c5094c7cc08979e (patch)
tree7ec58f72bc56a3e1e94567c247e3bacce0321bac /net-p2p/azureus
parentKeyworded ~ia64 (diff)
downloadgentoo-2-0bb7670cb42c4089ea2742639c5094c7cc08979e.tar.gz
gentoo-2-0bb7670cb42c4089ea2742639c5094c7cc08979e.tar.bz2
gentoo-2-0bb7670cb42c4089ea2742639c5094c7cc08979e.zip
With 2.5.0.0-r1 it could happen that UI was not set leading to Azureus not starting. Now the startup script sets that to swt if the variable is empty. Fixes bug #147059.
(Portage version: 2.1.1)
Diffstat (limited to 'net-p2p/azureus')
-rw-r--r--net-p2p/azureus/ChangeLog10
-rw-r--r--net-p2p/azureus/azureus-2.5.0.0-r2.ebuild120
-rw-r--r--net-p2p/azureus/files/azureus-2.5.0.0-pre1
-rw-r--r--net-p2p/azureus/files/digest-azureus-2.5.0.0-r23
4 files changed, 133 insertions, 1 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index f769c7fe6a42..9c651a550941 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.29 2006/09/09 16:50:10 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.30 2006/09/10 14:36:04 betelgeuse Exp $
+
+*azureus-2.5.0.0-r2 (10 Sep 2006)
+
+ 10 Sep 2006; Petteri Räty <betelgeuse@gentoo.org>
+ files/azureus-2.5.0.0-pre, +azureus-2.5.0.0-r2.ebuild:
+ With 2.5.0.0-r1 it could happen that UI was not set leading to Azureus
+ not starting. Now the startup script sets that to swt if the variable
+ is empty. Fixes bug #147059.
*azureus-2.5.0.0-r1 (09 Sep 2006)
diff --git a/net-p2p/azureus/azureus-2.5.0.0-r2.ebuild b/net-p2p/azureus/azureus-2.5.0.0-r2.ebuild
new file mode 100644
index 000000000000..65b2ac5926b2
--- /dev/null
+++ b/net-p2p/azureus/azureus-2.5.0.0-r2.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.5.0.0-r2.ebuild,v 1.1 2006/09/10 14:36:04 betelgeuse Exp $
+
+inherit eutils fdo-mime java-pkg-2 java-ant-2
+
+DESCRIPTION="Azureus - Java BitTorrent Client"
+HOMEPAGE="http://azureus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/azureus/Azureus_${PV}_source.zip"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="source"
+
+# >=swt-3.2 for bug
+# https://bugs.gentoo.org/show_bug.cgi?id=135835
+
+RDEPEND="
+ >=virtual/jre-1.4
+ >=dev-java/swt-3.2-r1
+ >=dev-java/log4j-1.2.8
+ >=dev-java/commons-cli-1.0
+ >=dev-java/bcprov-1.31
+ !net-p2p/azureus-bin"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.4
+ dev-util/desktop-file-utils
+ >=dev-java/ant-core-1.6.2
+ || ( =dev-java/eclipse-ecj-3.2* =dev-java/eclipse-ecj-3.1* )
+ source? ( app-arch/zip )
+ >=app-arch/unzip-5.0"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch ${FILESDIR}/fedora-${PV}/
+
+ #removing osx files and entries
+ rm -fr org/gudy/azureus2/ui/swt/osx org/gudy/azureus2/platform/macosx
+ #removing windows files
+ rm -fr org/gudy/azureus2/platform/win32
+ #removing test files
+ rm -fr org/gudy/azureus2/ui/swt/test
+ rm -f org/gudy/azureus2/ui/console/multiuser/TestUserManager.java
+ #removing bouncycastle
+ rm -fr org/bouncycastle
+
+ mkdir -p build/libs
+ cd build/libs
+ java-pkg_jar-from log4j
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from swt-3
+ java-pkg_jar-from bcprov
+}
+
+src_compile() {
+ # javac likes to run out of memory during build... use ecj instead
+ java-pkg_force-compiler ecj-3.2 ecj-3.1
+
+ eant ${ant_extra_opts} jar
+}
+
+src_install() {
+ java-pkg_dojar dist/Azureus2.jar || die "dojar failed"
+
+
+ java-pkg_dolauncher ${PN} \
+ --main org.gudy.azureus2.ui.common.Main \
+ -pre ${FILESDIR}/${P}-pre \
+ --pkg_args '--ui=${UI}' \
+ --java_args '${JAVA_OPTIONS}'
+
+ doicon "${FILESDIR}/azureus.png"
+ domenu "${FILESDIR}/azureus.desktop"
+ use source && java-pkg_dosrc ${S}/{com,org}
+}
+
+pkg_postinst() {
+ echo
+ elog "Due to the nature of the portage system, we recommend"
+ elog "that users check portage for new versions of Azureus"
+ elog "instead of attempting to use the auto-update feature."
+ elog "You can disable auto-update in"
+ elog "Tools->Options...->Interface->Start"
+ echo
+ elog "After running azureus for the first time, configuration"
+ elog "options will be placed in ~/.azureus/gentoo.config"
+ elog "It is recommended that you modify this file rather than"
+ elog "the azureus startup script directly."
+ echo
+ elog "As of this version, the new ui type 'console' is supported,"
+ elog "and this may be set in ~/.azureus/gentoo.config."
+ echo
+ elog "If you have problems starting azureus, try starting it"
+ elog "from the command line to look at debugging output."
+ echo
+ ewarn "If you are upgrading, and the menu in azureus has entries like"
+ ewarn "\"!MainWindow.menu.transfers!\" then you have a stray"
+ ewarn "MessageBundle.properties file,"
+ ewarn "and you may safely delete ~/.azureus/MessagesBundle.properties"
+ echo
+ elog "It's recommended to use Sun's Java version 1.5 or later."
+ elog "If you're experiencing problems running azureus and you've"
+ elog "using an older version of Java, try to upgrading to a new version. "
+ echo
+ ewarn "Please, do not run azureus as root!"
+ ewarn "Azureus has not been developed for multi-user environments!"
+
+ fdo-mime_desktop_database_update
+}
+
+pkg_prerm() {
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/azureus/files/azureus-2.5.0.0-pre b/net-p2p/azureus/files/azureus-2.5.0.0-pre
index 5278c094f80c..40a21949643f 100644
--- a/net-p2p/azureus/files/azureus-2.5.0.0-pre
+++ b/net-p2p/azureus/files/azureus-2.5.0.0-pre
@@ -61,5 +61,6 @@ fi
if [[ -z "${UI}" ]]; then
echo '$UI not set adding UI="swt" to your ' ${gentoocfg}
echo 'UI="swt"' >> ${gentoocfg}
+ UI="swt"
fi
diff --git a/net-p2p/azureus/files/digest-azureus-2.5.0.0-r2 b/net-p2p/azureus/files/digest-azureus-2.5.0.0-r2
new file mode 100644
index 000000000000..9e923fb8c6d3
--- /dev/null
+++ b/net-p2p/azureus/files/digest-azureus-2.5.0.0-r2
@@ -0,0 +1,3 @@
+MD5 f487f75f37674820bd3b2cc6af97ce57 Azureus_2.5.0.0_source.zip 5856328
+RMD160 7ec7e6ccb570651a655f6077d4b323a4d3b8fcb0 Azureus_2.5.0.0_source.zip 5856328
+SHA256 64aa4150bb8036f11e5207a602253431d46578ce9cd3b62732b0ae0f555a08c4 Azureus_2.5.0.0_source.zip 5856328