summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-04 16:51:51 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-04 16:51:51 +0000
commita703f1464d64c34557eaebd81e55b12476c5da28 (patch)
tree50818d5172970c6168fd2db109f56c4c4b2ebd16 /net-p2p/amule
parentcleaned out old ebuilds. (diff)
downloadgentoo-2-a703f1464d64c34557eaebd81e55b12476c5da28.tar.gz
gentoo-2-a703f1464d64c34557eaebd81e55b12476c5da28.tar.bz2
gentoo-2-a703f1464d64c34557eaebd81e55b12476c5da28.zip
Add -r1, builds against wx-2.8 bug #208714, uses webserver template, bug #199108, new snapshot
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog12
-rw-r--r--net-p2p/amule/amule-2.1.3-r1.ebuild (renamed from net-p2p/amule/amule-2.2.0_pre20070422.ebuild)46
-rw-r--r--net-p2p/amule/amule-2.2.0_pre20080204.ebuild (renamed from net-p2p/amule/amule-2.2.0_pre20080130.ebuild)3
-rw-r--r--net-p2p/amule/files/2.1.3-wx-2.8.patch156
-rw-r--r--net-p2p/amule/files/amuleweb.confd6
-rw-r--r--net-p2p/amule/files/amuleweb.initd4
6 files changed, 201 insertions, 26 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 275c2bf25476..6d91321eaabf 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.98 2008/01/30 15:05:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.99 2008/02/04 16:51:50 armin76 Exp $
+
+*amule-2.2.0_pre20080204 (04 Feb 2008)
+*amule-2.1.3-r1 (04 Feb 2008)
+
+ 04 Feb 2008; Raúl Porcel <armin76@gentoo.org> +files/2.1.3-wx-2.8.patch,
+ files/amuleweb.confd, files/amuleweb.initd, +amule-2.1.3-r1.ebuild,
+ -amule-2.2.0_pre20070422.ebuild, -amule-2.2.0_pre20080130.ebuild,
+ +amule-2.2.0_pre20080204.ebuild:
+ Add -r1, builds against wx-2.8 bug #208714, uses webserver template, bug
+ #199108, new snapshot
*amule-2.2.0_pre20080130 (30 Jan 2008)
diff --git a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild b/net-p2p/amule/amule-2.1.3-r1.ebuild
index 265a14c50478..eb6b04ae5190 100644
--- a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
+++ b/net-p2p/amule/amule-2.1.3-r1.ebuild
@@ -1,26 +1,27 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.4 2008/01/15 13:43:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.1.3-r1.ebuild,v 1.1 2008/02/04 16:51:50 armin76 Exp $
inherit eutils flag-o-matic wxwidgets
-MY_P=${PN/m/M}-CVS-${PV/2.2.0_pre/}
-S="${WORKDIR}/${PN}-cvs"
+MY_P=${PN/m/M}-${PV}
+S="${WORKDIR}"/${MY_P}
DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://www.amule.org/"
-SRC_URI="http://www.hirnriss.net/files/cvs/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="daemon debug gtk nls remote stats unicode"
+IUSE="daemon debug geoip gtk nls remote stats unicode"
-DEPEND="=x11-libs/wxGTK-2.6*
+DEPEND="=x11-libs/wxGTK-2.8*
>=sys-libs/zlib-1.2.1
stats? ( >=media-libs/gd-2.0.26 )
+ geoip? ( dev-libs/geoip )
remote? ( >=media-libs/libpng-1.2.0
- unicode? ( >=media-libs/gd-2.0.26 ) )"
+ unicode? ( >=media-libs/gd-2.0.26 ) )"
pkg_setup() {
if ! use gtk && ! use remote && ! use daemon; then
@@ -49,17 +50,22 @@ pkg_preinst() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Make it compile against wx-2.8 since upstream won't support 2.6
+ epatch "${FILESDIR}"/${PV}-wx-2.8.patch
+}
+
src_compile() {
local myconf
- WX_GTK_VER="2.6"
+ WX_GTK_VER="2.8"
if use gtk; then
- einfo "wxGTK with gtk2 and unicode support will be used"
+ einfo "wxGTK with gtk support will be used"
need-wxwidgets unicode
- elif use unicode; then
- einfo "wxGTK with unicode and without X support will be used"
- need-wxwidgets base-unicode
else
einfo "wxGTK without X support will be used"
need-wxwidgets base
@@ -83,13 +89,14 @@ src_compile() {
--with-wx-config=${WX_CONFIG} \
--with-wxbase-config=${WX_CONFIG} \
--enable-amulecmd \
- `use_enable debug` \
- `use_enable !debug optimize` \
- `use_enable daemon amule-daemon` \
- `use_enable nls` \
- `use_enable remote webserver` \
- `use_enable stats cas` \
- `use_enable stats alcc` \
+ $(use_enable debug) \
+ $(use_enable !debug optimize) \
+ $(use_enable daemon amule-daemon) \
+ $(use_enable geoip) \
+ $(use_enable nls) \
+ $(use_enable remote webserver) \
+ $(use_enable stats cas) \
+ $(use_enable stats alcc) \
${myconf} || die
# we filter ssp until bug #74457 is closed to build on hardened
@@ -109,5 +116,6 @@ src_install() {
if use remote; then
newconfd "${FILESDIR}"/amuleweb.confd amuleweb
newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ make_desktop_entry amulegui "aMule Remote" amule "Network;P2P"
fi
}
diff --git a/net-p2p/amule/amule-2.2.0_pre20080130.ebuild b/net-p2p/amule/amule-2.2.0_pre20080204.ebuild
index 094bc96c8058..0c3e58ceb1e3 100644
--- a/net-p2p/amule/amule-2.2.0_pre20080130.ebuild
+++ b/net-p2p/amule/amule-2.2.0_pre20080204.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20080130.ebuild,v 1.1 2008/01/30 15:05:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20080204.ebuild,v 1.1 2008/02/04 16:51:50 armin76 Exp $
inherit eutils flag-o-matic wxwidgets
@@ -109,5 +109,6 @@ src_install() {
if use remote; then
newconfd "${FILESDIR}"/amuleweb.confd amuleweb
newinitd "${FILESDIR}"/amuleweb.initd amuleweb
+ make_desktop_entry amulegui "aMule Remote" amule "Network;P2P"
fi
}
diff --git a/net-p2p/amule/files/2.1.3-wx-2.8.patch b/net-p2p/amule/files/2.1.3-wx-2.8.patch
new file mode 100644
index 000000000000..8148d35dd726
--- /dev/null
+++ b/net-p2p/amule/files/2.1.3-wx-2.8.patch
@@ -0,0 +1,156 @@
+diff -urN aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp
+--- aMule-2.1.3.org/src/utils/wxCas/src/wxcasprefs.cpp 2005-12-16 13:09:29.000000000 +0100
++++ aMule-2.1.3/src/utils/wxCas/src/wxcasprefs.cpp 2006-12-17 20:20:47.151203000 +0100
+@@ -297,7 +297,7 @@
+ m_validateButton =
+ new wxButton ( this, ID_VALIDATE_BUTTON, wxString ( _( "Validate" ) ) );
+ m_cancelButton =
+- new wxButton ( this, ID_CANCEL_BUTTON, wxString ( _( "Cancel" ) ) );
++ new wxButton ( this, wxID_CANCEL, wxString ( _( "Cancel" ) ) );
+
+ m_buttonHBox->Add ( m_validateButton, 0, wxALIGN_CENTER | wxALL, 5 );
+ m_buttonHBox->Add ( m_cancelButton, 0, wxALIGN_CENTER | wxALL, 5 );
+@@ -321,7 +321,6 @@
+ EVT_BUTTON ( ID_OSPATH_BROWSE_BUTTON, WxCasPrefs::OnOSPathBrowseButton )
+ EVT_BUTTON ( ID_AUTOSTATIMG_BROWSE_BUTTON, WxCasPrefs::OnAutoStatImgBrowseButton )
+ EVT_BUTTON ( ID_VALIDATE_BUTTON, WxCasPrefs::OnValidateButton )
+-EVT_BUTTON ( ID_CANCEL_BUTTON, WxCasPrefs::OnCancel ) // Defined in wxDialog
+ EVT_CHECKBOX ( ID_AUTOSTATIMG_CHECK, WxCasPrefs::OnAutoStatImgCheck )
+ EVT_CHECKBOX ( ID_FTP_UPDATE_CHECK, WxCasPrefs::OnFtpUpdateCheck )
+ END_EVENT_TABLE ()
+--- aMule/src/utils/wxCas/src/wxcasprefs.h.org 2006-12-17 22:17:39.017417250 +0100
++++ aMule/src/utils/wxCas/src/wxcasprefs.h 2006-12-17 22:18:17.611829250 +0100
+@@ -101,8 +101,7 @@
+ ID_AUTOSTATIMG_COMBO,
+ ID_AUTOSTATIMG_BROWSE_BUTTON,
+ ID_FTP_UPDATE_CHECK,
+- ID_VALIDATE_BUTTON,
+- ID_CANCEL_BUTTON
++ ID_VALIDATE_BUTTON
+ };
+
+ protected:
+--- aMule/src/MuleGifCtrl.cpp 2006-02-03 20:14:05.000000000 +0100
++++ aMule/src/MuleGifCtrl.cpp 2006-11-19 19:35:33.000000000 +0100
+@@ -24,7 +24,6 @@
+
+ #include <wx/mstream.h>
+ #include <wx/gifdecod.h>
+-#include <wx/window.h>
+ #include <wx/dcbuffer.h>
+
+ #include "MuleGifCtrl.h"
+@@ -35,6 +34,50 @@
+ EVT_ERASE_BACKGROUND(MuleGifCtrl::OnErase)
+ END_EVENT_TABLE()
+
++#if wxCHECK_VERSION(2, 7, 1)
++// Wrapper that emulates old wxGIFDecoder API
++
++class MuleGIFDecoder : public wxGIFDecoder {
++public:
++ MuleGIFDecoder(wxInputStream* stream, bool dummy) {
++ m_stream = stream;
++ dummy = dummy; // Unused.
++ m_nframe = 0;
++ }
++
++ ~MuleGIFDecoder() { /* don't delete the stream! */ }
++
++ wxGIFErrorCode ReadGIF() {
++ return LoadGIF(*m_stream);
++ }
++
++ void GoFirstFrame() { m_nframe = 0; }
++ void GoNextFrame(bool dummy) { m_nframe < GetFrameCount() ? m_nframe++ : m_nframe = 0; }
++ void GoLastFrame() { m_nframe = GetFrameCount(); }
++
++ void ConvertToImage(wxImage* image) { wxGIFDecoder::ConvertToImage(m_nframe, image); }
++
++ size_t GetLogicalScreenWidth() { return GetAnimationSize().GetWidth(); }
++ size_t GetLogicalScreenHeight() { return GetAnimationSize().GetHeight(); }
++
++ size_t GetLeft() { return 0; }
++ size_t GetTop() { return 0; }
++
++ long GetDelay() { return wxGIFDecoder::GetDelay(m_nframe); }
++
++private:
++ uint32_t m_nframe;
++ wxInputStream* m_stream;
++};
++
++#else
++class MuleGIFDecoder : public wxGIFDecoder {
++public:
++ MuleGIFDecoder(wxInputStream* stream, bool flag) : wxGIFDecoder(stream,flag) {};
++};
++#endif
++
++
+
+ MuleGifCtrl::MuleGifCtrl( wxWindow *parent, wxWindowID id, const wxPoint& pos,
+ const wxSize& size, long style, const wxValidator& validator,
+@@ -66,7 +109,7 @@
+ }
+
+ wxMemoryInputStream stream(data, size);
+- m_decoder = new wxGIFDecoder(&stream, TRUE);
++ m_decoder = new MuleGIFDecoder(&stream, TRUE);
+ if ( m_decoder->ReadGIF() != wxGIF_OK ) {
+ delete m_decoder;
+ m_decoder = NULL;
+@@ -137,3 +180,4 @@
+ dc.DrawBitmap( m_frame, x + m_decoder->GetLeft(), y + m_decoder->GetTop(), true);
+ }
+
++// File_checked_for_headers
+--- aMule/src/MuleGifCtrl.h 2006-01-01 06:17:25.000000000 +0100
++++ aMule/src/MuleGifCtrl.h 2006-11-18 05:01:22.000000000 +0100
+@@ -27,11 +27,10 @@
+
+ #include <wx/control.h>
+ #include <wx/timer.h>
+-#include <wx/bitmap.h>
+
+ const int GIFTIMERID = 271283;
+
+-class wxGIFDecoder;
++class MuleGIFDecoder;
+ class wxBitmap;
+
+ /**
+@@ -121,7 +120,7 @@
+ void OnErase( wxEraseEvent& WXUNUSED(event) ) {}
+
+ //! A pointer to the current gif-animation.
+- wxGIFDecoder* m_decoder;
++ MuleGIFDecoder* m_decoder;
+ //! Timer used for the delay between each frame.
+ wxTimer m_timer;
+ //! Current frame.
+@@ -133,3 +132,4 @@
+
+ #endif
+
++// File_checked_for_headers
+--- aMule-2.1.3/src/MuleTextCtrl.cpp~ 2006-12-17 20:55:37.157820250 +0100
++++ aMule-2.1.3/src/MuleTextCtrl.cpp 2006-12-17 20:56:21.328580750 +0100
+@@ -26,6 +26,7 @@
+ #include <wx/menu.h>
+ #include <wx/intl.h>
+ #include <wx/clipbrd.h>
++#include <wx/dataobj.h>
+
+ /**
+ * These are the IDs used to identify the different menu-items.
+--- amule/src/amule.cpp~ 2006-12-17 21:53:26.474639000 +0100
++++ amule/src/amule.cpp 2006-12-17 21:55:40.307003000 +0100
+@@ -96,6 +96,7 @@
+ #include <CoreFoundation/CFBundle.h>
+ #include <wx/mac/corefoundation/cfstring.h>
+ #endif
++ #include <wx/msgdlg.h>
+ #endif
+
+
diff --git a/net-p2p/amule/files/amuleweb.confd b/net-p2p/amule/files/amuleweb.confd
index 56e81a808505..3c398a92ca01 100644
--- a/net-p2p/amule/files/amuleweb.confd
+++ b/net-p2p/amule/files/amuleweb.confd
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.confd,v 1.2 2006/01/13 13:56:48 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.confd,v 1.3 2008/02/04 16:51:51 armin76 Exp $
# owner of amuleweb process (must be existing)
AMULEUSER="p2p"
@@ -24,5 +24,5 @@ AMULEHOST="localhost"
# aMule external connection port
AMULEPORT="4712"
-
-
+# aMuleweb template (default, php-default, chicane)
+TEMPLATE="default"
diff --git a/net-p2p/amule/files/amuleweb.initd b/net-p2p/amule/files/amuleweb.initd
index 4b0d6cd39e53..6f0e57cfffc9 100644
--- a/net-p2p/amule/files/amuleweb.initd
+++ b/net-p2p/amule/files/amuleweb.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.initd,v 1.6 2007/12/05 15:50:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/files/amuleweb.initd,v 1.7 2008/02/04 16:51:51 armin76 Exp $
depend() {
need net
@@ -23,7 +23,7 @@ start() {
rm /var/run/amuleweb.pid
fi
- OPTIONS="-h ${AMULEHOST} -p ${AMULEPORT} -P ${AMULEPWD} -A ${WEBPWD}"
+ OPTIONS="-h ${AMULEHOST} -p ${AMULEPORT} -P ${AMULEPWD} -A ${WEBPWD} -t ${TEMPLATE} -q"
ebegin "Starting aMule WebServer"
env HOME="${AMULEHOME}" start-stop-daemon --start \