summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-10-13 16:16:45 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-10-13 16:16:45 +0000
commit7325046d5c73335c36570f9435cb7b74b392dc3b (patch)
treed7c5f66059f8672d87e89e3637c64783939e0580 /net-p2p/amule
parentStable on ppc64; bug #193542 (diff)
downloadgentoo-2-7325046d5c73335c36570f9435cb7b74b392dc3b.tar.gz
gentoo-2-7325046d5c73335c36570f9435cb7b74b392dc3b.tar.bz2
gentoo-2-7325046d5c73335c36570f9435cb7b74b392dc3b.zip
Move need-wxwidgets into src_compile. Portage seems to be dropping the value
of WX_CONFIG gotten from wxwidgets.eclass between phases. Also fix variable quoting. (Portage version: 2.1.3.12)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog8
-rw-r--r--net-p2p/amule/amule-2.1.3.ebuild46
-rw-r--r--net-p2p/amule/amule-2.2.0_pre20070422.ebuild40
3 files changed, 50 insertions, 44 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 3782a0c706fc..e569f71da75e 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.93 2007/09/29 00:07:25 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.94 2007/10/13 16:16:45 dirtyepic Exp $
+
+ 13 Oct 2007; Ryan Hill <dirtyepic@gentoo.org> amule-2.1.3.ebuild,
+ amule-2.2.0_pre20070422.ebuild:
+ Move need-wxwidgets into src_compile. Portage seems to be dropping the value
+ of WX_CONFIG gotten from wxwidgets.eclass between phases. Also fix variable
+ quoting.
29 Sep 2007; Ryan Hill <dirtyepic@gentoo.org> amule-2.1.3.ebuild,
amule-2.2.0_pre20070422.ebuild:
diff --git a/net-p2p/amule/amule-2.1.3.ebuild b/net-p2p/amule/amule-2.1.3.ebuild
index 0becdbd0f541..1fa5d8592ddc 100644
--- a/net-p2p/amule/amule-2.1.3.ebuild
+++ b/net-p2p/amule/amule-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.1.3.ebuild,v 1.14 2007/09/29 00:07:25 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.1.3.ebuild,v 1.15 2007/10/13 16:16:45 dirtyepic Exp $
inherit eutils flag-o-matic wxwidgets
@@ -23,8 +23,6 @@ DEPEND="=x11-libs/wxGTK-2.6*
unicode? ( >=media-libs/gd-2.0.26 ) )"
pkg_setup() {
- export WX_GTK_VER="2.6"
-
if ! use gtk && ! use remote && ! use amuled; then
eerror ""
eerror "You have to specify at least one of gtk, remote or amuled"
@@ -33,20 +31,6 @@ pkg_setup() {
die "Invalid USE flag set"
fi
- if use unicode && use gtk; then
- einfo "wxGTK with gtk2 and unicode support will be used"
- need-wxwidgets unicode
- elif use gtk; then
- einfo "wxGTK with gtk2 support will be used"
- need-wxwidgets gtk2
- elif use unicode; then
- einfo "wxGTK with unicode and without X support will be used"
- need-wxwidgets base-unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base
- fi
-
if use stats && ! use gtk; then
einfo "Note: You would need both the gtk and stats USE flags"
einfo "to compile aMule Statistics GUI."
@@ -66,7 +50,23 @@ pkg_preinst() {
}
src_compile() {
- local myconf=""
+ local myconf
+
+ WX_GTK_VER="2.6"
+
+ if use unicode && use gtk; then
+ einfo "wxGTK with gtk2 and unicode support will be used"
+ need-wxwidgets unicode
+ elif use gtk; then
+ einfo "wxGTK with gtk2 support will be used"
+ need-wxwidgets gtk2
+ elif use unicode; then
+ einfo "wxGTK with unicode and without X support will be used"
+ need-wxwidgets base-unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base
+ fi
if use gtk ; then
use stats && myconf="${myconf}
@@ -102,15 +102,15 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
if use amuled; then
- newconfd ${FILESDIR}/amuled.confd amuled
- newinitd ${FILESDIR}/amuled.initd amuled
+ newconfd "${FILESDIR}"/amuled.confd amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
fi
if use remote; then
- newconfd ${FILESDIR}/amuleweb.confd amuleweb
- newinitd ${FILESDIR}/amuleweb.initd amuleweb
+ newconfd "${FILESDIR}"/amuleweb.confd amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
fi
}
diff --git a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild b/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
index 3335400e1515..dbca1e79f510 100644
--- a/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
+++ b/net-p2p/amule/amule-2.2.0_pre20070422.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.2 2007/09/29 00:07:25 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.2.0_pre20070422.ebuild,v 1.3 2007/10/13 16:16:45 dirtyepic Exp $
inherit eutils flag-o-matic wxwidgets
@@ -23,8 +23,6 @@ DEPEND="=x11-libs/wxGTK-2.6*
unicode? ( >=media-libs/gd-2.0.26 ) )"
pkg_setup() {
- export WX_GTK_VER="2.6"
-
if ! use gtk && ! use remote && ! use amuled; then
eerror ""
eerror "You have to specify at least one of gtk, remote or amuled"
@@ -33,17 +31,6 @@ pkg_setup() {
die "Invalid USE flag set"
fi
- if use gtk; then
- einfo "wxGTK with gtk2 and unicode support will be used"
- need-wxwidgets unicode
- elif use unicode; then
- einfo "wxGTK with unicode and without X support will be used"
- need-wxwidgets base-unicode
- else
- einfo "wxGTK without X support will be used"
- need-wxwidgets base
- fi
-
if use stats && ! use gtk; then
einfo "Note: You would need both the gtk and stats USE flags"
einfo "to compile aMule Statistics GUI."
@@ -63,7 +50,20 @@ pkg_preinst() {
}
src_compile() {
- local myconf=""
+ local myconf
+
+ WX_GTK_VER="2.6"
+
+ if use gtk; then
+ einfo "wxGTK with gtk2 and unicode support will be used"
+ need-wxwidgets unicode
+ elif use unicode; then
+ einfo "wxGTK with unicode and without X support will be used"
+ need-wxwidgets base-unicode
+ else
+ einfo "wxGTK without X support will be used"
+ need-wxwidgets base
+ fi
if use gtk ; then
use stats && myconf="${myconf}
@@ -99,15 +99,15 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die
if use amuled; then
- newconfd ${FILESDIR}/amuled.confd amuled
- newinitd ${FILESDIR}/amuled.initd amuled
+ newconfd "${FILESDIR}"/amuled.confd amuled
+ newinitd "${FILESDIR}"/amuled.initd amuled
fi
if use remote; then
- newconfd ${FILESDIR}/amuleweb.confd amuleweb
- newinitd ${FILESDIR}/amuleweb.initd amuleweb
+ newconfd "${FILESDIR}"/amuleweb.confd amuleweb
+ newinitd "${FILESDIR}"/amuleweb.initd amuleweb
fi
}