summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-05-31 21:26:01 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-05-31 21:26:01 +0000
commit510e9611449117995b4ac76b6d88e60d898f4005 (patch)
tree000302004cefdc2ba2116d6a6033b203a96ebcd7 /net-p2p/amule
parentRestricted dependency on pdflib to prevent problems with pdflib-6 (diff)
downloadgentoo-2-510e9611449117995b4ac76b6d88e60d898f4005.tar.gz
gentoo-2-510e9611449117995b4ac76b6d88e60d898f4005.tar.bz2
gentoo-2-510e9611449117995b4ac76b6d88e60d898f4005.zip
Fixed compile problems with wxgtk, bug #73007
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog6
-rw-r--r--net-p2p/amule/amule-2.0.0_rc7.ebuild11
-rw-r--r--net-p2p/amule/amule-2.0.1.ebuild2
-rw-r--r--net-p2p/amule/files/amule-2.0.0_rc7-wxgtk.patch24
4 files changed, 39 insertions, 4 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index deb3f1c42cb5..3da54ccc0ced 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.36 2005/05/31 20:47:07 sekretarz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.37 2005/05/31 21:26:01 sekretarz Exp $
+
+ 31 May 2005; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/amule-2.0.0_rc7-wxgtk.patch, amule-2.0.0_rc7.ebuild:
+ Fixed compile problems with wxgtk, bug #73007
*amule-2.0.1 (31 May 2005)
diff --git a/net-p2p/amule/amule-2.0.0_rc7.ebuild b/net-p2p/amule/amule-2.0.0_rc7.ebuild
index fb1b9c858674..7d5997d5b3c8 100644
--- a/net-p2p/amule/amule-2.0.0_rc7.ebuild
+++ b/net-p2p/amule/amule-2.0.0_rc7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc7.ebuild,v 1.2 2005/03/12 15:18:28 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc7.ebuild,v 1.3 2005/05/31 21:26:01 sekretarz Exp $
-inherit wxwidgets
+inherit wxwidgets eutils
MY_P=${P/m/M}
MY_P=${MY_P/_/}
@@ -52,6 +52,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-wxgtk.patch
+}
+
src_compile() {
econf \
--enable-optimise \
diff --git a/net-p2p/amule/amule-2.0.1.ebuild b/net-p2p/amule/amule-2.0.1.ebuild
index 420e4743258a..ec721d5c7793 100644
--- a/net-p2p/amule/amule-2.0.1.ebuild
+++ b/net-p2p/amule/amule-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header:
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.1.ebuild,v 1.2 2005/05/31 21:26:01 sekretarz Exp $
inherit eutils flag-o-matic wxwidgets
diff --git a/net-p2p/amule/files/amule-2.0.0_rc7-wxgtk.patch b/net-p2p/amule/files/amule-2.0.0_rc7-wxgtk.patch
new file mode 100644
index 000000000000..884b37540839
--- /dev/null
+++ b/net-p2p/amule/files/amule-2.0.0_rc7-wxgtk.patch
@@ -0,0 +1,24 @@
+diff -ur aMule-2.0.0rc7/src/utils/aLinkCreator/src/ed2khash.cpp aMule-2.0.0rc7-ar/src/utils/aLinkCreator/src/ed2khash.cpp
+--- aMule-2.0.0rc7/src/utils/aLinkCreator/src/ed2khash.cpp 2004-08-09 19:01:34.000000000 +0200
++++ aMule-2.0.0rc7-ar/src/utils/aLinkCreator/src/ed2khash.cpp 2004-12-01 00:43:15.061834816 +0100
+@@ -83,7 +83,7 @@
+ {
+ // Open file and let wxFFile destructor close the file
+ // Closing it explicitly may crash on Win32 ...
+- wxFFile file(filename.GetFullPath(), wxT("rbS"));
++ wxFFile file( (const wxChar*) filename.GetFullPath(), (const char*) wxT("rbS"));
+ if (! file.IsOpened())
+ {
+ wxLogError (_("Unable to open %s"),unicode2char(filename.GetFullPath()));
+diff -ur aMule-2.0.0rc7/src/utils/aLinkCreator/src/md4.cpp aMule-2.0.0rc7-ar/src/utils/aLinkCreator/src/md4.cpp
+--- aMule-2.0.0rc7/src/utils/aLinkCreator/src/md4.cpp 2004-08-30 00:27:04.000000000 +0200
++++ aMule-2.0.0rc7-ar/src/utils/aLinkCreator/src/md4.cpp 2004-12-01 00:43:15.037838464 +0100
+@@ -336,7 +336,7 @@
+
+ // Open file and let wxFFile destructor close the file
+ // Closing it explicitly may crash on Win32 ...
+- wxFFile file(filename, wxT("rbS"));
++ wxFFile file((const wxChar*) filename, (const char*) wxT("rbS"));
+ if (! file.IsOpened())
+ {
+ return wxEmptyString;