summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-19 22:21:01 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-19 22:21:01 +0000
commit478b95a90658e5071fa20280fec3c9cc054756b5 (patch)
treeb4cbe45bbdf85aab3f83a26cda0699e9b673a5de /net-p2p/amule
parentmake live-cvs support simple (diff)
downloadgentoo-2-478b95a90658e5071fa20280fec3c9cc054756b5.tar.gz
gentoo-2-478b95a90658e5071fa20280fec3c9cc054756b5.tar.bz2
gentoo-2-478b95a90658e5071fa20280fec3c9cc054756b5.zip
slightly updated ebuild
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/ChangeLog4
-rw-r--r--net-p2p/amule/amule-2.0.0_rc5.ebuild66
2 files changed, 28 insertions, 42 deletions
diff --git a/net-p2p/amule/ChangeLog b/net-p2p/amule/ChangeLog
index 85307b61298c..19f9ffa5ea21 100644
--- a/net-p2p/amule/ChangeLog
+++ b/net-p2p/amule/ChangeLog
@@ -1,12 +1,12 @@
# ChangeLog for net-p2p/amule
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.26 2004/07/19 14:20:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/ChangeLog,v 1.27 2004/07/19 22:21:01 squinky86 Exp $
*amule-2.0.0_rc5 (19 Jul 2004)
19 Jul 2004; Jon Hood <squinky86@gentoo.org> +amule-2.0.0_rc5.ebuild:
version bump, closes #57528, thanks to Giacomo Perale <ghepeu@virgilio.it> for
- the update
+ the updated ebuild
*amule-1.2.8 (14 Jul 2004)
diff --git a/net-p2p/amule/amule-2.0.0_rc5.ebuild b/net-p2p/amule/amule-2.0.0_rc5.ebuild
index 1951f6cb9618..3606bf1676e9 100644
--- a/net-p2p/amule/amule-2.0.0_rc5.ebuild
+++ b/net-p2p/amule/amule-2.0.0_rc5.ebuild
@@ -1,70 +1,56 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.1 2004/07/19 14:20:39 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/amule/amule-2.0.0_rc5.ebuild,v 1.2 2004/07/19 22:21:01 squinky86 Exp $
MY_P=${P/m/M}
MY_P=${MY_P/_/}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="aNOTHER wxWindows based eMule P2P Client"
+DESCRIPTION="aMule, the all-platform eMule p2p client"
HOMEPAGE="http://www.amule.org"
SRC_URI="http://download.berlios.de/${PN}/${MY_P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-# this is a release candidate- do not put in the stable tree yet
KEYWORDS="~x86 ~amd64"
-IUSE="debug nls stats remote"
-RESTRICT="nomirror"
-
+IUSE="debug nls remote stats"
EXTRA_ECONF="--disable-optimise"
-# optimizations disabled for better stability
-# new USE "noamulestats" disables aMule GUI statistics (wxCas) (require gd)
-# new USE "noamuleremote" disables remote control utilities: webserver,
-# web client, amulecmd text client
+# USE "stats" enables external utilities (statistics and other)
+# USE "remote" enables remote controlling utilities (webserver, text client)
-
-DEPEND=">=x11-libs/wxGTK-2.4.2
+DEPEND="remote? ( =x11-libs/wxGTK-2.4* ) : ( >=x11-libs/wxGTK-2.4.2-r1 )
>=net-misc/curl-7.11.0
- >=dev-libs/crypto++-5.1
+ >=dev-libs/crypto++-5.1-r1
>=sys-libs/zlib-1.2.1
- stats? ( >=media-libs/gd-2.0.22 )"
+ stats? ( >=media-libs/gd-2.0.23 )"
pkg_setup() {
- # GTK2 is unstable and not supported by aMule developers
- if wx-config --cppflags | grep gtk2 >& /dev/null; then
- einfo "Compiling ${PN} against wxGTK2 is not supported."
- die "wxGTK must be re-emerged with USE=-gtk2."
- fi
-
- # aMule doesn't compile against unicoded wxGTK at all.
- if wx-config --cppflags | grep gtk2u >& /dev/null; then
- einfo "${PN} will not build if wxGTK was compiled"
- einfo "with unicode support. If you are using a version of"
- einfo "wxGTK <= 2.4.2, you must set USE=-gtk2. In newer versions,"
- einfo "you must set USE=-unicode."
- die "wxGTK must be re-emerged without unicode suport"
+ # GTK2 is unstable on wxGTK 2.4 and not supported by aMule developers
+ if wx-config --version | grep 2.4 >& /dev/null \
+ && wx-config --cppflags | grep gtk2 >& /dev/null; then
+ einfo "Compiling ${PN} against wxGTK2 2.4.x is not supported."
+ einfo "wxGTK must be re-emerged with USE=\"-gtk2\" or you can upgrade"
+ einfo "to development snapshots 2.5.1, but this will break other"
+ einfo "applications and the webserver. Please note that gtk2 support"
+ einfo "is still experimental."
+ die "wxGTK 2.4 must be re-emerged with USE=\"-gtk2\"."
fi
}
src_compile() {
-
- use remote || EXTRA_ECONF="${EXTRA_ECONF} --disable-amulecmd \
- --disable-amulecmdgui \
- --disable-webserver \
- --disable-webservergui" \
- || EXTRA_ECONF="${EXTRA_ECONF} --enable-amulecmd \
- --enable-amulecmdgui \
- --enable-webserver \
- --enable-webservergui"
-
- #workaround for broken configure (doesn't recognize --enable-wxcas)
- use stats || EXTRA_ECONF="${EXTRA_ECONF} --disable-wxcas"
-
econf `use_enable nls` \
+ `use_enable remote amulecmd` \
+ `use_enable remote amulecmdgui` \
+ `use_enable remote webserver` \
+ `use_enable remote webservergui` \
+ `use_enable stats cas` \
+ `use_enable stats wxcas` \
+ `use_enable stats alc` \
+ `use_enable stats alcc` \
`use_enable debug` || die
emake -j1 || die