summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-02-14 18:39:41 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-02-14 18:39:41 +0000
commit7f5389b6d2b561988bdc365707f77c4d337004d5 (patch)
tree708c796c2bfbdceb1cb18b1f278a27a46eb3dce7 /net-nntp
parentold (diff)
downloadgentoo-2-7f5389b6d2b561988bdc365707f77c4d337004d5.tar.gz
gentoo-2-7f5389b6d2b561988bdc365707f77c4d337004d5.tar.bz2
gentoo-2-7f5389b6d2b561988bdc365707f77c4d337004d5.zip
Version bump (#456336). Rebundle cherrypy until 0.8.0 comes out (#450242, #456338 and see comments in ebuild). Remove default user/pass.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/sabnzbd/ChangeLog8
-rw-r--r--net-nntp/sabnzbd/files/sabnzbd.ini2
-rw-r--r--net-nntp/sabnzbd/sabnzbd-0.7.11.ebuild117
3 files changed, 124 insertions, 3 deletions
diff --git a/net-nntp/sabnzbd/ChangeLog b/net-nntp/sabnzbd/ChangeLog
index 9efcbd2384df..f5fd47a6969f 100644
--- a/net-nntp/sabnzbd/ChangeLog
+++ b/net-nntp/sabnzbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nntp/sabnzbd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/ChangeLog,v 1.7 2013/02/06 04:59:55 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/ChangeLog,v 1.8 2013/02/14 18:39:40 jsbronder Exp $
+
+*sabnzbd-0.7.11 (14 Feb 2013)
+
+ 14 Feb 2013; Justin Bronder <jsbronder@gentoo.org> +sabnzbd-0.7.11.ebuild:
+ Version bump (#456336). Rebundle cherrypy until 0.8.0 comes out (#450242,
+ #456338 and see comments in ebuild). Remove default user/pass from config.
*sabnzbd-0.7.10 (06 Feb 2013)
diff --git a/net-nntp/sabnzbd/files/sabnzbd.ini b/net-nntp/sabnzbd/files/sabnzbd.ini
index 113c71428f1e..cfb55613f8dd 100644
--- a/net-nntp/sabnzbd/files/sabnzbd.ini
+++ b/net-nntp/sabnzbd/files/sabnzbd.ini
@@ -10,5 +10,3 @@ nzb_backup_dir = /var/lib/sabnzbd/backup
auto_browser = 0
host = 0.0.0.0
port = 8080
-username = sabnzbd
-password = secret \ No newline at end of file
diff --git a/net-nntp/sabnzbd/sabnzbd-0.7.11.ebuild b/net-nntp/sabnzbd/sabnzbd-0.7.11.ebuild
new file mode 100644
index 000000000000..e5095cc486f7
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-0.7.11.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/sabnzbd-0.7.11.ebuild,v 1.1 2013/02/14 18:39:40 jsbronder Exp $
+
+EAPI="4"
+
+# Require python-2 with sqlite USE flag
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python user
+
+MY_P="${P/sab/SAB}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="http://www.sabnzbd.org/"
+SRC_URI="mirror://sourceforge/sabnzbdplus/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+rar +ssl unzip +yenc"
+
+# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
+# be in python's sitedir. See: http://wiki.sabnzbd.org/unix-packaging
+
+# TODO: still bundled but not in protage:
+# kronos, rarfile, rsslib, ssmtplib, listquote, json-py, msgfmt
+# pynewsleecher
+#
+# Also note that cherrypy is still bundled. It's near impossible to find
+# out where the bundled and heavily patched version came from (pulled from
+# cherrypy subversion, patched somewhere, then imported to sabnzbd and patched
+# further. Upstream is planning on making this easier with 0.8.0.
+# https://github.com/sabnzbd/sabnzbd/issues/47
+
+RDEPEND="
+ >=app-arch/par2cmdline-0.4
+ >=dev-python/cheetah-2.0.1
+ dev-python/configobj
+ dev-python/feedparser
+ dev-python/gntp
+ dev-python/pythonutils
+ net-misc/wget
+ rar? ( || ( app-arch/unrar app-arch/rar ) )
+ ssl? ( dev-python/pyopenssl )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+ yenc? ( dev-python/yenc )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ HOMEDIR="/var/lib/${PN}"
+ python_set_active_version 2
+ python_pkg_setup
+
+ # Create sabnzbd group
+ enewgroup ${PN}
+ # Create sabnzbd user, put in sabnzbd group
+ enewuser "${PN}" -1 -1 "${HOMEDIR}" "${PN}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-system-configobj-and-feedparser.patch
+
+ # remove bundled modules
+ rm -r sabnzbd/utils/{feedparser,configobj,gntp}.py
+ rm licenses/License-{feedparser,configobj,gntp,CherryPy}.txt
+}
+
+src_install() {
+ local d
+
+ dodir /usr/share/${PN}/sabnzbd
+ insinto /usr/share/${PN}/
+ doins SABnzbd.py
+ fperms +x /usr/share/${PN}/SABnzbd.py
+ dobin "${FILESDIR}"/sabnzbd
+
+ for d in cherrypy email icons interfaces locale po sabnzbd tools util; do
+ insinto /usr/share/${PN}/${d}
+ doins -r ${d}/*
+ done
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/"${PN}.logrotate ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ dodir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o ${PN} -g ${PN}
+ doins "${FILESDIR}/${PN}.ini"
+
+ dodoc {ABOUT,CHANGELOG,ISSUES,README}.txt Sample-PostProc.sh licenses/*
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+
+ einfo "Default directory: ${HOMEDIR}"
+ einfo ""
+ einfo "Run: gpasswd -a <user> sabnzbd"
+ einfo "to add an user to the sabnzbd group so it can edit sabnzbd files"
+ einfo ""
+ einfo "By default sabnzbd will listen on 127.0.0.1:8080"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}