summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-02-07 12:12:14 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-02-07 12:12:14 +0000
commit76427c1026d86eeff3a6f78b92b37ca9d590f861 (patch)
tree211792faa1f82619b3a3e8515a7cdf3e3f30ec11 /net-nntp
parentFix installing docs. (diff)
downloadgentoo-2-76427c1026d86eeff3a6f78b92b37ca9d590f861.tar.gz
gentoo-2-76427c1026d86eeff3a6f78b92b37ca9d590f861.tar.bz2
gentoo-2-76427c1026d86eeff3a6f78b92b37ca9d590f861.zip
Migrate to EAPI 5 and add a subslot dependency for dev-libs/icu wrt bug #455900.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/tin/ChangeLog9
-rw-r--r--net-nntp/tin/tin-2.0.1-r1.ebuild95
-rw-r--r--net-nntp/tin/tin-2.1.2.ebuild6
3 files changed, 106 insertions, 4 deletions
diff --git a/net-nntp/tin/ChangeLog b/net-nntp/tin/ChangeLog
index d05ffdbd0f23..bc6d5037a5f8 100644
--- a/net-nntp/tin/ChangeLog
+++ b/net-nntp/tin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nntp/tin
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.45 2013/01/22 17:33:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/ChangeLog,v 1.46 2013/02/07 12:12:14 kensington Exp $
+
+*tin-2.0.1-r1 (07 Feb 2013)
+
+ 07 Feb 2013; Michael Palimaka <kensington@gentoo.org> +tin-2.0.1-r1.ebuild,
+ tin-2.1.2.ebuild:
+ Migrate to EAPI 5 and add a subslot dependency for dev-libs/icu wrt bug
+ #455900.
22 Jan 2013; Agostino Sarubbo <ago@gentoo.org> tin-2.0.1.ebuild:
Stable for x86, wrt bug #450928
diff --git a/net-nntp/tin/tin-2.0.1-r1.ebuild b/net-nntp/tin/tin-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..5b4cd0890a22
--- /dev/null
+++ b/net-nntp/tin/tin-2.0.1-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.0.1-r1.ebuild,v 1.1 2013/02/07 12:12:14 kensington Exp $
+
+EAPI=5
+inherit autotools eutils toolchain-funcs versionator
+
+DESCRIPTION="A threaded NNTP and spool based UseNet newsreader"
+HOMEPAGE="http://www.tin.org/"
+SRC_URI="ftp://ftp.tin.org/pub/news/clients/tin/v$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cancel-locks debug doc +etiquette evil forgery gpg idn ipv6 mime nls sasl socks5 spell unicode"
+
+RDEPEND="
+ dev-libs/libpcre
+ dev-libs/uulib
+ gpg? ( app-crypt/gnupg )
+ idn? ( net-dns/libidn )
+ mime? ( net-mail/metamail )
+ net-misc/urlview
+ nls? ( sys-devel/gettext )
+ sasl? ( virtual/gsasl )
+ socks5? ( net-proxy/dante )
+ sys-libs/ncurses[unicode?]
+ unicode? ( dev-libs/icu:= )
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not strip
+ sed -i src/Makefile.in -e '388s|-s ||g' || die "sed src/Makefile.in failed"
+ sed -i configure.in -e '/CFLAGS/s|-g||g' || die
+ eautoreconf
+}
+
+src_configure() {
+ if use evil || use cancel-locks; then
+ sed -i -e"s/# -DEVIL_INSIDE/-DEVIL_INSIDE/" src/Makefile.in
+ fi
+
+ if use forgery
+ then
+ sed -i -e"s/^CPPFLAGS.*/& -DFORGERY/" src/Makefile.in
+ fi
+
+ local screen="ncurses"
+ use unicode && screen="ncursesw"
+
+ use etiquette || myconf="${myconf} --disable-etiquette"
+
+ tc-export AR CC RANLIB
+
+ econf \
+ $(use_enable cancel-locks) \
+ $(use_enable debug) \
+ $(use_enable gpg pgp-gpg) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_with mime metamail /usr) \
+ $(use_with socks5 socks) $(use_with socks5) \
+ $(use_with spell ispell /usr) \
+ --disable-mime-strict-charset \
+ --enable-echo \
+ --enable-nntp-only \
+ --enable-prototypes \
+ --with-coffee \
+ --with-nntp-default-server="${TIN_DEFAULT_SERVER:-${NNTPSERVER:-news.gmane.org}}" \
+ --with-pcre=/usr \
+ --with-screen=${screen} \
+ ${myconf}
+}
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ default
+
+ # File collision?
+ rm -f "${ED}"/usr/share/man/man5/{mbox,mmdf}.5
+
+ dodoc doc/{CHANGES{,.old},CREDITS,TODO,WHATSNEW}
+ use doc && dodoc doc/{*.sample,*.txt}
+
+ insinto /etc/tin
+ doins doc/tin.defaults
+}
diff --git a/net-nntp/tin/tin-2.1.2.ebuild b/net-nntp/tin/tin-2.1.2.ebuild
index d828612651c9..f2162e76a80f 100644
--- a/net-nntp/tin/tin-2.1.2.ebuild
+++ b/net-nntp/tin/tin-2.1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.1.2.ebuild,v 1.3 2013/01/11 15:35:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/tin/tin-2.1.2.ebuild,v 1.4 2013/02/07 12:12:14 kensington Exp $
-EAPI=4
+EAPI=5
inherit eutils toolchain-funcs versionator
TIN_PV=$(get_version_component_range 1-2)
@@ -26,7 +26,7 @@ RDEPEND="
sasl? ( virtual/gsasl )
socks5? ( net-proxy/dante )
sys-libs/ncurses[unicode?]
- unicode? ( dev-libs/icu )
+ unicode? ( dev-libs/icu:= )
"
DEPEND="