summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2013-06-24 23:20:03 +0000
committerJustin Bronder <jsbronder@gentoo.org>2013-06-24 23:20:03 +0000
commit67649ba0acc370599e9e1a65e33b6f2f23e6443e (patch)
treef866242dc22e9f4adb81871d11dec5b3f504c19c /net-nntp/sabnzbd
parentVersion bump, switch to EAPI5 and new tar ball (diff)
downloadgentoo-2-67649ba0acc370599e9e1a65e33b6f2f23e6443e.tar.gz
gentoo-2-67649ba0acc370599e9e1a65e33b6f2f23e6443e.tar.bz2
gentoo-2-67649ba0acc370599e9e1a65e33b6f2f23e6443e.zip
Support newer versions of dev-python/gntp, resolves #474540.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'net-nntp/sabnzbd')
-rw-r--r--net-nntp/sabnzbd/ChangeLog8
-rw-r--r--net-nntp/sabnzbd/files/growler-support-gntp-1.0.patch33
-rw-r--r--net-nntp/sabnzbd/sabnzbd-0.7.13-r1.ebuild119
3 files changed, 159 insertions, 1 deletions
diff --git a/net-nntp/sabnzbd/ChangeLog b/net-nntp/sabnzbd/ChangeLog
index 280c3b2c1d7c..218d813a4cec 100644
--- a/net-nntp/sabnzbd/ChangeLog
+++ b/net-nntp/sabnzbd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nntp/sabnzbd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/ChangeLog,v 1.13 2013/06/24 22:50:31 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/ChangeLog,v 1.14 2013/06/24 23:20:03 jsbronder Exp $
+
+*sabnzbd-0.7.13-r1 (24 Jun 2013)
+
+ 24 Jun 2013; Justin Bronder <jsbronder@gentoo.org> +sabnzbd-0.7.13-r1.ebuild,
+ +files/growler-support-gntp-1.0.patch:
+ Support newer versions of dev-python/gntp, resolves #474540.
24 Jun 2013; Justin Bronder <jsbronder@gentoo.org> -sabnzbd-0.7.10.ebuild,
-sabnzbd-0.7.11.ebuild, -sabnzbd-0.7.12.ebuild:
diff --git a/net-nntp/sabnzbd/files/growler-support-gntp-1.0.patch b/net-nntp/sabnzbd/files/growler-support-gntp-1.0.patch
new file mode 100644
index 000000000000..560b88a18d49
--- /dev/null
+++ b/net-nntp/sabnzbd/files/growler-support-gntp-1.0.patch
@@ -0,0 +1,33 @@
+From 96b4891d2323cb44f479bc94d1410348b1468298 Mon Sep 17 00:00:00 2001
+From: Justin Bronder <jsbronder@gmail.com>
+Date: Mon, 24 Jun 2013 19:03:17 -0400
+Subject: [PATCH] growler: support >=gntp-1.0
+
+Fixes Gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=474540
+---
+ sabnzbd/growler.py | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/sabnzbd/growler.py b/sabnzbd/growler.py
+index d250703..f39bb44 100644
+--- a/sabnzbd/growler.py
++++ b/sabnzbd/growler.py
+@@ -31,7 +31,14 @@ import sabnzbd
+ import sabnzbd.cfg
+ from sabnzbd.encoding import unicoder, latin1
+ from sabnzbd.constants import NOTIFY_KEYS
+-from gntp import GNTPRegister
++
++try:
++ # <= version 0.6
++ from gntp import GNTPRegister
++except ImportError:
++ # >= version 1.0
++ from gntp.core import GNTPRegister
++
+ from gntp.notifier import GrowlNotifier
+ try:
+ import Growl
+--
+1.8.1.5
+
diff --git a/net-nntp/sabnzbd/sabnzbd-0.7.13-r1.ebuild b/net-nntp/sabnzbd/sabnzbd-0.7.13-r1.ebuild
new file mode 100644
index 000000000000..75a6b9f16c12
--- /dev/null
+++ b/net-nntp/sabnzbd/sabnzbd-0.7.13-r1.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/sabnzbd/sabnzbd-0.7.13-r1.ebuild,v 1.1 2013/06/24 23:20:03 jsbronder Exp $
+
+EAPI="4"
+
+# Require python-2 with sqlite USE flag
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite"
+
+inherit eutils python user
+
+MY_P="${P/sab/SAB}"
+
+DESCRIPTION="Binary newsgrabber with web-interface"
+HOMEPAGE="http://www.sabnzbd.org/"
+SRC_URI="mirror://sourceforge/sabnzbdplus/${MY_P}-src.tar.gz"
+
+# Sabnzbd is GPL-2 but bundles software with the following licenses.
+LICENSE="GPL-2 BSD LGPL-2 MIT BSD-1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+rar +ssl unzip +yenc"
+
+# Sabnzbd is installed to /usr/share/ as upstream makes it clear they should not
+# be in python's sitedir. See: http://wiki.sabnzbd.org/unix-packaging
+
+# TODO: still bundled but not in protage:
+# kronos, rarfile, rsslib, ssmtplib, listquote, json-py, msgfmt
+# pynewsleecher
+#
+# Also note that cherrypy is still bundled. It's near impossible to find
+# out where the bundled and heavily patched version came from (pulled from
+# cherrypy subversion, patched somewhere, then imported to sabnzbd and patched
+# further. Upstream is planning on making this easier with 0.8.0.
+# https://github.com/sabnzbd/sabnzbd/issues/47
+
+RDEPEND="
+ >=app-arch/par2cmdline-0.4
+ >=dev-python/cheetah-2.0.1
+ dev-python/configobj
+ dev-python/feedparser
+ dev-python/gntp
+ dev-python/pythonutils
+ net-misc/wget
+ rar? ( || ( app-arch/unrar app-arch/rar ) )
+ ssl? ( dev-python/pyopenssl )
+ unzip? ( >=app-arch/unzip-5.5.2 )
+ yenc? ( dev-python/yenc )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ HOMEDIR="/var/lib/${PN}"
+ python_set_active_version 2
+ python_pkg_setup
+
+ # Create sabnzbd group
+ enewgroup ${PN}
+ # Create sabnzbd user, put in sabnzbd group
+ enewuser "${PN}" -1 -1 "${HOMEDIR}" "${PN}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-system-configobj-and-feedparser.patch
+ epatch "${FILESDIR}"/growler-support-gntp-1.0.patch
+
+ # remove bundled modules
+ rm -r sabnzbd/utils/{feedparser,configobj}.py || die
+ rm -r gntp || die
+ rm licenses/License-{feedparser,configobj,gntp}.txt || die
+}
+
+src_install() {
+ local d
+
+ dodir /usr/share/${PN}/sabnzbd
+ insinto /usr/share/${PN}/
+ doins SABnzbd.py
+ fperms +x /usr/share/${PN}/SABnzbd.py
+ dobin "${FILESDIR}"/sabnzbd
+
+ for d in cherrypy email icons interfaces locale po sabnzbd tools util; do
+ insinto /usr/share/${PN}/${d}
+ doins -r ${d}/*
+ done
+
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/"${PN}.logrotate ${PN}
+
+ diropts -o ${PN} -g ${PN}
+ dodir /etc/${PN}
+ dodir /var/log/${PN}
+
+ insinto "/etc/${PN}"
+ insopts -m 0600 -o ${PN} -g ${PN}
+ doins "${FILESDIR}/${PN}.ini"
+
+ dodoc {ABOUT,CHANGELOG,ISSUES,README}.txt Sample-PostProc.sh licenses/*
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/share/${PN}
+
+ einfo "Default directory: ${HOMEDIR}"
+ einfo ""
+ einfo "Run: gpasswd -a <user> sabnzbd"
+ einfo "to add an user to the sabnzbd group so it can edit sabnzbd files"
+ einfo ""
+ einfo "By default sabnzbd will listen on 127.0.0.1:8080"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}