summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-06 11:45:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-06 11:45:14 +0000
commitd2765a12ea9b2470d2f3dd515c246336a3fa6a52 (patch)
treed4357f66520744f8c10e350961c3c5610e2c3567 /net-nntp/newspost
parentVersion bump to 4.3.0 (diff)
downloadgentoo-2-d2765a12ea9b2470d2f3dd515c246336a3fa6a52.tar.gz
gentoo-2-d2765a12ea9b2470d2f3dd515c246336a3fa6a52.tar.bz2
gentoo-2-d2765a12ea9b2470d2f3dd515c246336a3fa6a52.zip
Fix building with GLIBC 2.10+ wrt #273987.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp/newspost')
-rw-r--r--net-nntp/newspost/ChangeLog8
-rw-r--r--net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch57
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r2.ebuild16
3 files changed, 71 insertions, 10 deletions
diff --git a/net-nntp/newspost/ChangeLog b/net-nntp/newspost/ChangeLog
index 6078b445a865..ea4360bdef04 100644
--- a/net-nntp/newspost/ChangeLog
+++ b/net-nntp/newspost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nntp/newspost
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/ChangeLog,v 1.10 2008/01/25 22:10:57 grobian Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/ChangeLog,v 1.11 2009/08/06 11:45:14 ssuominen Exp $
+
+ 06 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ newspost-2.1.1-r2.ebuild, +files/newspost-2.1.1-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #273987.
25 Jan 2008; Fabian Groffen <grobian@gentoo.org> newspost-2.1.1-r1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch b/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch
new file mode 100644
index 000000000000..fdaa78cbefb7
--- /dev/null
+++ b/net-nntp/newspost/files/newspost-2.1.1-glibc-2.10.patch
@@ -0,0 +1,57 @@
+diff -ur newspost-2.1.1.orig/base/newspost.c newspost-2.1.1/base/newspost.c
+--- newspost-2.1.1.orig/base/newspost.c 2003-04-23 18:33:23.000000000 +0300
++++ newspost-2.1.1/base/newspost.c 2009-08-06 14:46:41.000000000 +0300
+@@ -342,7 +342,7 @@
+ file = fopen(filename, "r");
+ if (file != NULL) {
+ while (!feof(file)) {
+- line = getline(line, file);
++ line = get_line(line, file);
+ if(line == NULL){
+ text_buffer = buff_add(text_buffer, "\r\n");
+ continue;
+diff -ur newspost-2.1.1.orig/base/utils.c newspost-2.1.1/base/utils.c
+--- newspost-2.1.1.orig/base/utils.c 2009-08-06 14:44:35.000000000 +0300
++++ newspost-2.1.1/base/utils.c 2009-08-06 14:45:20.000000000 +0300
+@@ -43,7 +43,7 @@
+ return NULL;
+ }
+
+-Buff * getline(Buff *buff, FILE *file){
++Buff * get_line(Buff *buff, FILE *file){
+ int c = fgetc(file);
+ buff = buff_free(buff);
+ while(TRUE){
+diff -ur newspost-2.1.1.orig/base/utils.h newspost-2.1.1/base/utils.h
+--- newspost-2.1.1.orig/base/utils.h 2003-02-08 17:09:41.000000000 +0200
++++ newspost-2.1.1/base/utils.h 2009-08-06 14:45:13.000000000 +0300
+@@ -26,7 +26,7 @@
+ file_entry * file_entry_alloc();
+ file_entry * file_entry_free(file_entry *fe);
+
+-Buff * getline(Buff *buff, FILE *file);
++Buff * get_line(Buff *buff, FILE *file);
+ Buff *buff_add(Buff *buff, char *data, ... );
+ Buff * buff_free(Buff *buff);
+ Buff *buff_create(Buff *buff, char *data, ... );
+diff -ur newspost-2.1.1.orig/ui/options.c newspost-2.1.1/ui/options.c
+--- newspost-2.1.1.orig/ui/options.c 2003-04-23 18:33:33.000000000 +0300
++++ newspost-2.1.1/ui/options.c 2009-08-06 14:46:31.000000000 +0300
+@@ -332,7 +332,7 @@
+ file = fopen(filename->data, "r");
+ if (file != NULL) {
+ while (!feof(file)) {
+- line = getline(line, file);
++ line = get_line(line, file);
+ linenum++;
+ if(line == NULL) continue;
+
+@@ -429,7 +429,7 @@
+ linenum = 0;
+ while (linenum < 8) {
+ linenum++;
+- line = getline(line, file);
++ line = get_line(line, file);
+ if(line == NULL) continue;
+
+ switch (linenum) {
diff --git a/net-nntp/newspost/newspost-2.1.1-r2.ebuild b/net-nntp/newspost/newspost-2.1.1-r2.ebuild
index 54e5d53c589c..292553584dc8 100644
--- a/net-nntp/newspost/newspost-2.1.1-r2.ebuild
+++ b/net-nntp/newspost/newspost-2.1.1-r2.ebuild
@@ -1,29 +1,29 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/newspost-2.1.1-r2.ebuild,v 1.1 2007/08/18 22:49:32 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/newspost-2.1.1-r2.ebuild,v 1.2 2009/08/06 11:45:14 ssuominen Exp $
inherit eutils
DESCRIPTION="a usenet binary autoposter for unix"
HOMEPAGE="http://newspost.unixcab.org/"
SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
-
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=""
DEPEND=">=sys-apps/sed-4"
-RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
-
- epatch "${FILESDIR}/CAN-2005-0101.patch"
+ epatch "${FILESDIR}"/CAN-2005-0101.patch
# Should fix some problems with unexpected server replies, cf. bug 185468
- epatch "${FILESDIR}/${P}-nntp.patch"
+ epatch "${FILESDIR}"/${P}-nntp.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
sed -i \
-e "s:OPT_FLAGS = :OPT_FLAGS = ${CFLAGS}#:" Makefile \