summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-01-20 13:25:15 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-01-20 13:25:15 +0000
commit8365e97b6289fad50fc8f9d1453aa182b1c20688 (patch)
tree65787efe8296ba3b18198531db3e652fd3182cd3 /net-nntp/newspost
parentStable for arm, wrt bug #451450 (diff)
downloadgentoo-2-8365e97b6289fad50fc8f9d1453aa182b1c20688.tar.gz
gentoo-2-8365e97b6289fad50fc8f9d1453aa182b1c20688.tar.bz2
gentoo-2-8365e97b6289fad50fc8f9d1453aa182b1c20688.zip
Migrate to EAPI 5. Respect LDFLAGS wrt bug #335512.
(Portage version: 2.1.11.43/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'net-nntp/newspost')
-rw-r--r--net-nntp/newspost/ChangeLog10
-rw-r--r--net-nntp/newspost/newspost-2.1.1-r3.ebuild35
2 files changed, 43 insertions, 2 deletions
diff --git a/net-nntp/newspost/ChangeLog b/net-nntp/newspost/ChangeLog
index e4edbb84bf10..a41d70eab557 100644
--- a/net-nntp/newspost/ChangeLog
+++ b/net-nntp/newspost/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nntp/newspost
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/ChangeLog,v 1.16 2010/01/07 15:52:16 fauli Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/ChangeLog,v 1.17 2013/01/20 13:25:15 kensington Exp $
+
+*newspost-2.1.1-r3 (20 Jan 2013)
+
+ 20 Jan 2013; Michael Palimaka <kensington@gentoo.org>
+ +newspost-2.1.1-r3.ebuild:
+ Migrate to EAPI 5. Respect LDFLAGS wrt bug #335512.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
newspost-2.1.1-r2.ebuild:
diff --git a/net-nntp/newspost/newspost-2.1.1-r3.ebuild b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
new file mode 100644
index 000000000000..09d95ab06135
--- /dev/null
+++ b/net-nntp/newspost/newspost-2.1.1-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/newspost/newspost-2.1.1-r3.ebuild,v 1.1 2013/01/20 13:25:15 kensington Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A usenet binary autoposter for unix"
+HOMEPAGE="http://newspost.unixcab.org/"
+SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+src_prepare() {
+ # Should fix some problems with unexpected server replies, cf. bug 185468
+ epatch "${FILESDIR}"/${P}-nntp.patch
+ epatch "${FILESDIR}"/CAN-2005-0101.patch
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+
+ sed -e "/-strip newspost/d" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LIBS="${LDFLAGS}" main
+}
+
+src_install () {
+ dobin newspost
+ doman man/man1/newspost.1
+ dodoc CHANGES README
+}