summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-04-17 23:02:29 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-04-17 23:02:29 +0000
commit570ceb1cdd840b0067de90d05836f6c7b4652074 (patch)
tree67d3ecbe7939d90f9c1c5b95b1aa9d6b7ea8298e /net-nntp/inn/files
parentStable for HPPA (bug #174807). (diff)
downloadgentoo-2-570ceb1cdd840b0067de90d05836f6c7b4652074.tar.gz
gentoo-2-570ceb1cdd840b0067de90d05836f6c7b4652074.tar.bz2
gentoo-2-570ceb1cdd840b0067de90d05836f6c7b4652074.zip
Fixed compatibility problems with sys-libs/db-4.4 and 4.5, fixes bug 174680.
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-nntp/inn/files')
-rw-r--r--net-nntp/inn/files/inn-2.4.3-berkdb45.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-nntp/inn/files/inn-2.4.3-berkdb45.patch b/net-nntp/inn/files/inn-2.4.3-berkdb45.patch
new file mode 100644
index 000000000000..6d649931a01e
--- /dev/null
+++ b/net-nntp/inn/files/inn-2.4.3-berkdb45.patch
@@ -0,0 +1,62 @@
+Index: frontends/ovdb_stat.c
+--- frontends/ovdb_stat.c.orig 2006-03-20 05:14:57 +0100
++++ frontends/ovdb_stat.c 2006-09-29 07:17:19 +0200
+@@ -266,13 +266,17 @@
+ { INT32, F(st_nobjects), -1, -1, "Current objects" },
+ { INT32, F(st_maxnobjects), -1, -1, "Maximum objects" },
+ #endif
++#if !(DB_VERSION_MAJOR >= 4 && DB_VERSION_MINOR >= 4)
+ { INT32, F(st_nconflicts), -1, -1, "Lock conflicts" },
++#endif
+ { INT32, F(st_nrequests), -1, -1, "Lock requests" },
+ { INT32, F(st_nreleases), -1, -1, "Lock releases" },
+ { DIFF32, F(st_nrequests), F(st_nreleases), F(st_ndeadlocks), "Outstanding locks" },
+ #if DB_VERSION_MAJOR >= 4 || (DB_VERSION_MAJOR == 3 && DB_VERSION_MINOR > 0)
++#if !(DB_VERSION_MAJOR >= 4 && DB_VERSION_MINOR >= 4)
+ { INT32, F(st_nnowaits), -1, -1, "Lock requests that would have waited" },
+ #endif
++#endif
+ { INT32, F(st_ndeadlocks), -1, -1, "Deadlocks" },
+ #if DB_VERSION_MAJOR >= 4
+ { INT32, F(st_nlocktimeouts), -1, -1, "Lock timeouts" },
+Index: scripts/innwatch.in
+--- scripts/innwatch.in.orig 2006-03-20 05:14:57 +0100
++++ scripts/innwatch.in 2006-09-29 07:17:19 +0200
+@@ -126,7 +126,12 @@
+ NEXTSLEEP=1
+ HASEXITED=false
+
+-while { sleep ${NEXTSLEEP} & wait; } ; : ; do
++SLEEPTINY=4
++while { sleep ${SLEEPTINY} & wait; } ; : ; do
++ NEXTSLEEP=`expr ${NEXTSLEEP} - ${SLEEPTINY}`
++ if [ $NEXTSLEEP -gt 0 ]; then
++ continue;
++ fi
+ NEXTSLEEP=${INNWATCHSLEEPTIME}
+
+ ## If news.daily is running, idle: we don't want to change the
+Index: site/Makefile
+--- site/Makefile.orig 2006-03-20 05:14:57 +0100
++++ site/Makefile 2006-09-29 07:17:19 +0200
+@@ -137,7 +137,6 @@
+ chmod $(FILEMODE) $@
+ $D$(PATH_HISTORY):
+ touch $@
+- $(PATHBIN)/makedbz -i -o
+
+ ## Remove files that are unchanged from the release version.
+ clean:
+Index: storage/ovdb/ovdb.c
+--- storage/ovdb/ovdb.c.orig 2006-03-20 05:14:57 +0100
++++ storage/ovdb/ovdb.c 2006-09-29 07:55:00 +0200
+@@ -1526,7 +1526,9 @@
+
+ OVDBenv->set_errcall(OVDBenv, OVDBerror);
+ OVDBenv->set_cachesize(OVDBenv, 0, ovdb_conf.cachesize, 1);
++#if DB_VERSION_MAJOR < 4 || (DB_VERSION_MAJOR == 4 && DB_VERSION_MINOR < 5)
+ OVDBenv->set_lk_max(OVDBenv, ovdb_conf.maxlocks);
++#endif
+
+ #if DB_VERSION_MAJOR >= 4 || (DB_VERSION_MAJOR == 3 && DB_VERSION_MINOR >= 2)
+ if(ovdb_conf.txn_nosync)