summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-09-08 15:13:07 +0000
committerAron Griffis <agriffis@gentoo.org>2001-09-08 15:13:07 +0000
commitce625dbc30bd69b72d426a8999f094aeb6d886a8 (patch)
tree61ce88f68c373667ef902beba0c2ee86671a71ed /net-news
parentFirst commit of magicfilter ebuild. Note that files/StylusColor* and (diff)
downloadgentoo-2-ce625dbc30bd69b72d426a8999f094aeb6d886a8.tar.gz
gentoo-2-ce625dbc30bd69b72d426a8999f094aeb6d886a8.tar.bz2
gentoo-2-ce625dbc30bd69b72d426a8999f094aeb6d886a8.zip
Update to 0.10.0. The source has moved in the ftp tree, so the
ebuilds for 0.9.x don't actually work any more.
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/files/digest-pan-0.10.01
-rw-r--r--net-news/pan/pan-0.10.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-news/pan/files/digest-pan-0.10.0 b/net-news/pan/files/digest-pan-0.10.0
new file mode 100644
index 000000000000..b96591c4908d
--- /dev/null
+++ b/net-news/pan/files/digest-pan-0.10.0
@@ -0,0 +1 @@
+MD5 157889e9cd9a4e3b619076adf84b53e1 pan-0.10.0.tar.bz2
diff --git a/net-news/pan/pan-0.10.0.ebuild b/net-news/pan/pan-0.10.0.ebuild
new file mode 100644
index 000000000000..92040d0068d0
--- /dev/null
+++ b/net-news/pan/pan-0.10.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Erik Van Reeth <erik@vanreeth.org>
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.10.0.ebuild,v 1.1 2001/09/08 15:13:07 agriffis Exp $
+
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="A newsreader for GNOME."
+SRC_URI="http://pan.rebelbase.com/download/${PV}/SOURCE/${A}"
+HOMEPAGE="http://pan.rebelbase.com/"
+
+DEPEND="virtual/x11
+ nls? ( sys-devel/gettext )
+ >=gnome-base/gnome-libs-1.0.16
+ gtkhtml? ( >=gnome-base/gtkhtml-0.8.3 )"
+
+src_compile() {
+ local myconf
+ use nls || myconf=--disable-nls
+ use gtkhtml && myconf="$myconf --enable-html"
+ ./configure --prefix=/opt/gnome $myconf || die
+ # Doesn't work with -j 4 (hallski)
+ make || die
+}
+
+src_install () {
+ make prefix=${D}/opt/gnome install
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}