summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2006-07-24 22:21:38 +0000
committerDaniel Drake <dsd@gentoo.org>2006-07-24 22:21:38 +0000
commitc3750a57366692b56bac4f65ec61a1b6c0a024d0 (patch)
tree450ad7c1039497473ec42cd3d6e8987506986577 /net-news
parentSnapshot update. Added useflags "fifo" and "pulseaudio". (diff)
downloadgentoo-2-c3750a57366692b56bac4f65ec61a1b6c0a024d0.tar.gz
gentoo-2-c3750a57366692b56bac4f65ec61a1b6c0a024d0.tar.bz2
gentoo-2-c3750a57366692b56bac4f65ec61a1b6c0a024d0.zip
Allow compilation/operation against seamonkey rather than mozilla
(Portage version: 2.1.1_pre3-r4)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/blam/ChangeLog8
-rw-r--r--net-news/blam/blam-1.8.2-r1.ebuild8
-rw-r--r--net-news/blam/files/blam-1.8.2-seamonkey.patch72
-rw-r--r--net-news/blam/files/digest-blam-1.8.22
-rw-r--r--net-news/blam/files/digest-blam-1.8.2-r12
5 files changed, 88 insertions, 4 deletions
diff --git a/net-news/blam/ChangeLog b/net-news/blam/ChangeLog
index e853010246e2..d3e0c9466286 100644
--- a/net-news/blam/ChangeLog
+++ b/net-news/blam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-news/blam
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/blam/ChangeLog,v 1.29 2005/12/05 15:15:02 herbs Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/ChangeLog,v 1.30 2006/07/24 22:21:38 dsd Exp $
+
+ 24 Jul 2006; Daniel Drake <dsd@gentoo.org>
+ +files/blam-1.8.2-seamonkey.patch, blam-1.8.2-r1.ebuild:
+ Allow compilation/operation against seamonkey rather than mozilla
*blam-1.8.2-r1 (05 Dec 2005)
diff --git a/net-news/blam/blam-1.8.2-r1.ebuild b/net-news/blam/blam-1.8.2-r1.ebuild
index 7b1a043d8869..fe0a3d784982 100644
--- a/net-news/blam/blam-1.8.2-r1.ebuild
+++ b/net-news/blam/blam-1.8.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/blam/blam-1.8.2-r1.ebuild,v 1.1 2005/12/05 15:15:02 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/blam/blam-1.8.2-r1.ebuild,v 1.2 2006/07/24 22:21:38 dsd Exp $
inherit mono eutils
@@ -28,8 +28,12 @@ src_unpack() {
-e "s:@prefix@/lib:@prefix@/$(get_libdir):" \
${S}/{,lib,libblam,src}/Makefile.{in,am} ${S}/blam.in || die
fi
+
# Fix for bug 94524, bad int definition
epatch ${FILESDIR}/${P}-64-bit-int.diff
+
+ # build against seamonkey
+ epatch ${FILESDIR}/${P}-seamonkey.patch
}
src_compile() {
diff --git a/net-news/blam/files/blam-1.8.2-seamonkey.patch b/net-news/blam/files/blam-1.8.2-seamonkey.patch
new file mode 100644
index 000000000000..841eaaef6adf
--- /dev/null
+++ b/net-news/blam/files/blam-1.8.2-seamonkey.patch
@@ -0,0 +1,72 @@
+From: Daniel Drake <dsd@gentoo.org>
+
+http://bugzilla.gnome.org/show_bug.cgi?id=346566
+
+Index: blam-1.8.2/configure.in
+===================================================================
+--- blam-1.8.2.orig/configure.in
++++ blam-1.8.2/configure.in
+@@ -70,7 +70,7 @@ AC_MSG_CHECKING([which mozilla to use])
+
+ MOZILLA=
+ AC_ARG_WITH([mozilla],
+- AC_HELP_STRING([--with-mozilla@<:@=mozilla|firefox|thunderbird@:>@],
++ AC_HELP_STRING([--with-mozilla@<:@=mozilla|seamonkey|firefox|thunderbird@:>@],
+ [Whether to use mozilla, firefox or thunderbird gtkmozembed (default: mozilla)]),
+ [MOZILLA="$withval"])
+
+@@ -78,6 +78,8 @@ dnl try to autodetect: if mozilla exists
+ if test "x$MOZILLA" = "x"; then
+ if pkg-config --exists mozilla-gtkmozembed; then
+ MOZILLA=mozilla
++ elif pkg-config --exists seamonkey-gtkmozembed; then
++ MOZILLA=seamonkey
+ elif pkg-config --exists firefox-gtkmozembed; then
+ MOZILLA=firefox
+ elif pkg-config --exists thunderbird-gtkmozembed; then
+@@ -85,7 +87,7 @@ if test "x$MOZILLA" = "x"; then
+ else
+ AC_MSG_ERROR([no mozilla installation found])
+ fi
+-elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xthunderbird"; then
++elif test "x$with_mozilla" != "xmozilla" -a "x$with_mozilla" != "xfirefox" -a "x$with_mozilla" != "xthunderbird" -a "x$with_mozilla" != "xseamonkey"; then
+ AC_MSG_ERROR([unknown mozilla name ($MOZILLA)])
+ fi
+
+@@ -95,6 +97,7 @@ AC_MSG_RESULT([$MOZILLA])
+
+ case "$MOZILLA" in
+ mozilla) min_version=1.7 flavour=mozilla ;;
++seamonkey) min_version=1.0 flavour=mozilla ;;
+ firefox) min_version=0.10 flavour=toolkit ;;
+ thunderbird) min_version=0.8 flavour=toolkit ;;
+ esac
+@@ -205,6 +208,12 @@ dnl changed from nsIXULChromeRegistry in
+ AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/chrome/nsIChromeRegistrySea.h],
+ [AC_DEFINE([HAVE_CHROME_NSICHROMEREGISTRYSEA_H], [1], [Define if nsIChromeRegistrySea.h exists])])
+
++
++dnl do_GetService moved here in recent mozilla code
++
++AC_CHECK_FILE([$MOZILLA_INCLUDE_ROOT/xpcom/nsServiceManagerUtils.h],
++ [AC_DEFINE([HAVE_XPCOM_NSSERVICEMANAGERUTILS_H], [1], [Define if nsServiceManagerUtils.h exists])])
++
+ MOZILLA_WARN_CXXFLAGS="-Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor"
+ AC_SUBST(MOZILLA_WARN_CXXFLAGS)
+
+Index: blam-1.8.2/libblam/blam-gecko-utils.cpp
+===================================================================
+--- blam-1.8.2.orig/libblam/blam-gecko-utils.cpp
++++ blam-1.8.2/libblam/blam-gecko-utils.cpp
+@@ -29,6 +29,11 @@
+ #include <nsEmbedString.h>
+ #include <nsIPrefService.h>
+ #include <nsIServiceManager.h>
++#include <nsCOMPtr.h>
++
++#if defined(HAVE_XPCOM_NSSERVICEMANAGERUTILS_H)
++#include <nsServiceManagerUtils.h>
++#endif
+
+ #if defined (HAVE_CHROME_NSICHROMEREGISTRYSEA_H)
+ #include <chrome/nsIChromeRegistrySea.h>
diff --git a/net-news/blam/files/digest-blam-1.8.2 b/net-news/blam/files/digest-blam-1.8.2
index 424cdf949505..9d8b10b99d84 100644
--- a/net-news/blam/files/digest-blam-1.8.2
+++ b/net-news/blam/files/digest-blam-1.8.2
@@ -1 +1,3 @@
MD5 8cb05faedf60d895d94a5ecf9d10eb8f blam-1.8.2.tar.gz 597408
+RMD160 9bd3def31f431dae58ba707566b6e1156caed0ac blam-1.8.2.tar.gz 597408
+SHA256 ba97fb9d9a11b629b2be00d143b3239794e48a1ac12c382e3d7565970345f1c5 blam-1.8.2.tar.gz 597408
diff --git a/net-news/blam/files/digest-blam-1.8.2-r1 b/net-news/blam/files/digest-blam-1.8.2-r1
index 424cdf949505..9d8b10b99d84 100644
--- a/net-news/blam/files/digest-blam-1.8.2-r1
+++ b/net-news/blam/files/digest-blam-1.8.2-r1
@@ -1 +1,3 @@
MD5 8cb05faedf60d895d94a5ecf9d10eb8f blam-1.8.2.tar.gz 597408
+RMD160 9bd3def31f431dae58ba707566b6e1156caed0ac blam-1.8.2.tar.gz 597408
+SHA256 ba97fb9d9a11b629b2be00d143b3239794e48a1ac12c382e3d7565970345f1c5 blam-1.8.2.tar.gz 597408