summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-02-26 16:40:55 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-02-26 16:40:55 +0000
commit99a701d797e1243787a6b889ed3c0f04290413d3 (patch)
tree096a1a3d0ad7c600d35aa49010d8da39e95d3281 /net-news
parentStable on ppc; bug #168320. (diff)
downloadgentoo-2-99a701d797e1243787a6b889ed3c0f04290413d3.tar.gz
gentoo-2-99a701d797e1243787a6b889ed3c0f04290413d3.tar.bz2
gentoo-2-99a701d797e1243787a6b889ed3c0f04290413d3.zip
Bump to 0.26
- Autoloading of feed content on feed selection. - DBus support (Subscribe to feed) - More usable find dialog. - Clipboard copy and text magnification content view. - Feed sorting in the feed list view. - Marking all feeds as read. (Portage version: 2.1.2-r11)
Diffstat (limited to 'net-news')
-rw-r--r--net-news/straw/ChangeLog13
-rw-r--r--net-news/straw/files/digest-straw-0.263
-rw-r--r--net-news/straw/straw-0.26.ebuild78
3 files changed, 93 insertions, 1 deletions
diff --git a/net-news/straw/ChangeLog b/net-news/straw/ChangeLog
index 482ad6f57fb9..728f3172578d 100644
--- a/net-news/straw/ChangeLog
+++ b/net-news/straw/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-news/straw
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/straw/ChangeLog,v 1.6 2007/02/09 08:14:54 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/straw/ChangeLog,v 1.7 2007/02/26 16:40:55 dang Exp $
+
+*straw-0.26 (26 Feb 2007)
+
+ 26 Feb 2007; Daniel Gryniewicz <dang@gentoo.org> +straw-0.26.ebuild:
+ Bump to 0.26
+ - Autoloading of feed content on feed selection.
+ - DBus support (Subscribe to feed)
+ - More usable find dialog.
+ - Clipboard copy and text magnification content view.
+ - Feed sorting in the feed list view.
+ - Marking all feeds as read.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/net-news/straw/files/digest-straw-0.26 b/net-news/straw/files/digest-straw-0.26
new file mode 100644
index 000000000000..7fa4fc7025f6
--- /dev/null
+++ b/net-news/straw/files/digest-straw-0.26
@@ -0,0 +1,3 @@
+MD5 ab8ef5c2447935dfc235ad69cdf6c5e4 straw-0.26.tar.bz2 246860
+RMD160 2c021e7cd32d264e5aefce55cd8e001cda843cb6 straw-0.26.tar.bz2 246860
+SHA256 c4c7e017a49854ac94b8084dd0c0d6f6cc75e89978f62294ea2eae06c73518cf straw-0.26.tar.bz2 246860
diff --git a/net-news/straw/straw-0.26.ebuild b/net-news/straw/straw-0.26.ebuild
new file mode 100644
index 000000000000..e89df6410dec
--- /dev/null
+++ b/net-news/straw/straw-0.26.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/straw/straw-0.26.ebuild,v 1.1 2007/02/26 16:40:55 dang Exp $
+
+inherit gnome2 python distutils virtualx
+
+DESCRIPTION="RSS/RDF News Aggregator"
+HOMEPAGE="http://www.gnome.org/projects/straw/"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/python-2.4"
+
+RDEPEND="${DEPEND}
+ gnome-base/gconf
+ >=gnome-base/libglade-2.4
+ >=gnome-base/libgnome-2.0.1
+ >=dev-python/gnome-python-1.99.13
+ >=dev-python/pygtk-2.6
+ >=dev-python/bsddb3-3.4.0
+ >=dev-python/egenix-mx-base-2
+ dev-python/gnome-python-extras
+ dev-python/dbus-python
+ !ppc? ( >=dev-python/adns-python-1.0.0 )"
+
+# REMIND : egenix-mx-base is only needed for the conversion of
+# pre 0.22 straw databases. It should be removed at some point.
+# foser <foser@gentoo.org> 18 Feb 2004
+
+pkg_setup() {
+ export maketype="python"
+ if ! echo "import gtkhtml2" | virtualmake; then
+ eerror "The gnome-python-extras gtkhtml2 module was not found."
+ eerror "Try unmerging gnome-python and gnome-python-extras"
+ eerror "And then try emerging straw again."
+ die "missing gtkhtml2 python module"
+ fi
+}
+
+# This about of virtualmake in src_compile and src_install are
+# pretty horrible.. why can't I compile gtk base modules in
+# distutils without that (ps. I'm the upstream guy to blame)
+# Olivier Crete <tester@gentoo.org>
+
+src_compile() {
+ export maketype="distutils_src_compile"
+ virtualmake || die "compilation failed"
+}
+
+src_install() {
+ # work around bug in straw's install script
+ export maketype="distutils_src_install"
+ virtualmake \
+ --prefix=/usr \
+ --sysconfdir=${D}/etc \
+ --disable-schemas-install
+}
+
+pkg_postinst() {
+
+ distutils_pkg_postinst
+ gnome2_pkg_postinst # need this for gconf schemas
+
+ echo
+ einfo "Consult the README if you have database conversion problems on startup."
+ echo
+
+}
+
+pkg_postrm() {
+
+ distutils_pkg_postrm
+ gnome2_pkg_postrm
+
+}