summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-08-04 09:15:47 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-08-04 09:15:47 +0000
commit1a99a4d147f1e71ae52f2853dff4a9c2c5087e82 (patch)
tree0b9b1d4271e26a0c87e971424c7179b5dde829c8 /net-news
parentFixed messed up econf line (diff)
downloadgentoo-2-1a99a4d147f1e71ae52f2853dff4a9c2c5087e82.tar.gz
gentoo-2-1a99a4d147f1e71ae52f2853dff4a9c2c5087e82.tar.bz2
gentoo-2-1a99a4d147f1e71ae52f2853dff4a9c2c5087e82.zip
Added missing dependency
Diffstat (limited to 'net-news')
-rw-r--r--net-news/pan/ChangeLog7
-rw-r--r--net-news/pan/pan-0.12.92-r1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/net-news/pan/ChangeLog b/net-news/pan/ChangeLog
index 88675b38803e..c394589f4eb1 100644
--- a/net-news/pan/ChangeLog
+++ b/net-news/pan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-news/pan
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.15 2002/08/01 14:37:25 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/ChangeLog,v 1.16 2002/08/04 09:15:47 leonardop Exp $
+
+*pan-0.12.92-r1 (4 Aug 2002)
+
+ 4 Aug 2002; Leonardo Boshell <leonardop@gentoo.org> pan-0.12.92-r1.ebuild:
+ Dependencies corrections. libunicode was missing. Closes bug #5879.
*pan-0.12.92 (1 Aug 2002)
diff --git a/net-news/pan/pan-0.12.92-r1.ebuild b/net-news/pan/pan-0.12.92-r1.ebuild
new file mode 100644
index 000000000000..d73fc2e16e79
--- /dev/null
+++ b/net-news/pan/pan-0.12.92-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.12.92-r1.ebuild,v 1.1 2002/08/04 09:15:47 leonardop Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=dev-libs/libxml2-2.4.22
+ dev-libs/libunicode
+ spell? ( >=app-text/gtkspell-2.0.0 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use spell || myconf="$myconf --disable-gtkspell"
+
+ econf --enable-debug=yes $myconf || die "Configure failure"
+
+ emake || die "Compilation failure"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}