summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-09 18:11:07 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-09 18:11:07 +0000
commit57a7ee28fd7bb96ddff8a279c05c26e6792fa739 (patch)
tree623d29e2e6ca41acf1865ee4b2e178d3db193817 /net-news/liferea
parentversion bump (diff)
downloadgentoo-2-57a7ee28fd7bb96ddff8a279c05c26e6792fa739.tar.gz
gentoo-2-57a7ee28fd7bb96ddff8a279c05c26e6792fa739.tar.bz2
gentoo-2-57a7ee28fd7bb96ddff8a279c05c26e6792fa739.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #357691 by Jouni Rinne.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'net-news/liferea')
-rw-r--r--net-news/liferea/ChangeLog6
-rw-r--r--net-news/liferea/files/liferea-1.7.4-libnotify-0.7.patch66
-rw-r--r--net-news/liferea/liferea-1.7.4.ebuild18
3 files changed, 83 insertions, 7 deletions
diff --git a/net-news/liferea/ChangeLog b/net-news/liferea/ChangeLog
index 98cc638f3c08..5fecf85bcfc4 100644
--- a/net-news/liferea/ChangeLog
+++ b/net-news/liferea/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-news/liferea
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.200 2011/02/26 10:26:52 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/ChangeLog,v 1.201 2011/03/09 18:11:07 ssuominen Exp $
+
+ 09 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> liferea-1.7.4.ebuild,
+ +files/liferea-1.7.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #357691 by Jouni Rinne.
26 Feb 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> liferea-1.6.5.ebuild:
x86 stable wrt bug #355345
diff --git a/net-news/liferea/files/liferea-1.7.4-libnotify-0.7.patch b/net-news/liferea/files/liferea-1.7.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..0cc11769b64b
--- /dev/null
+++ b/net-news/liferea/files/liferea-1.7.4-libnotify-0.7.patch
@@ -0,0 +1,66 @@
+--- src/notification/libnotify.c
++++ src/notification/libnotify.c
+@@ -28,6 +28,10 @@
+
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ #include "common.h"
+ #include "conf.h"
+ #include "debug.h"
+@@ -158,7 +162,12 @@
+ // notify_notification_update ( n, node_get_title(node_p), labelText_now_p, NULL);
+ // notify_notification_clear_actions(n);
+
+- n = notify_notification_new (node_get_title (node_p), labelText_now_p, NULL, NULL);
++ n = notify_notification_new (node_get_title (node_p), labelText_now_p, NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+
+ notify_notification_set_icon_from_pixbuf (n, node_get_icon (node_p));
+ notify_notification_set_category (n, "feed");
+@@ -172,8 +181,11 @@
+ (NotifyActionCallback)notif_libnotify_callback_mark_read,
+ node_p->id, NULL);
+ }
+-
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon was removed */
++#else
+ notify_notification_attach_to_status_icon (n, ui_tray_get_status_icon ());
++#endif
+
+ if (!notify_notification_show (n, NULL)) {
+ g_warning ("libnotify.c - failed to update notification via libnotify\n");
+@@ -249,7 +261,12 @@
+
+ labelSummary_p = g_strdup_printf (ngettext ("%s has %d new / updated headline\n", "%s has %d new / updated headlines\n", item_count),
+ node_get_title (node), item_count);
+- n = notify_notification_new (_("Feed Update"), labelSummary_p, "liferea", NULL);
++ n = notify_notification_new (_("Feed Update"), labelSummary_p, "liferea"
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , NULL);
++#endif
+ g_free (labelSummary_p);
+
+ if (supports_append) {
+@@ -272,7 +289,11 @@
+ }
+ notify_notification_set_category (n, "feed");
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon was removed */
++#else
+ notify_notification_attach_to_status_icon (n, ui_tray_get_status_icon ());
++#endif
+
+ if (!notify_notification_show (n, NULL))
+ g_warning ("notif_libnotify.c - failed to send notification via libnotify");
diff --git a/net-news/liferea/liferea-1.7.4.ebuild b/net-news/liferea/liferea-1.7.4.ebuild
index 5aad45c0d76c..552c1847bb06 100644
--- a/net-news/liferea/liferea-1.7.4.ebuild
+++ b/net-news/liferea/liferea-1.7.4.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.7.4.ebuild,v 1.2 2011/01/04 17:35:35 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-news/liferea/liferea-1.7.4.ebuild,v 1.3 2011/03/09 18:11:07 ssuominen Exp $
-EAPI="2"
+EAPI=2
-inherit gnome2 pax-utils
-GCONF_DEBUG="no"
+GCONF_DEBUG=no
-MY_P="${P/_/-}"
+inherit eutils gnome2 pax-utils
+
+MY_P=${P/_/-}
DESCRIPTION="News Aggregator for RDF/RSS/CDF/Atom/Echo/etc feeds"
HOMEPAGE="http://liferea.sourceforge.net/"
@@ -36,7 +37,7 @@ DEPEND="${RDEPEND}
DOCS="AUTHORS ChangeLog README"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
pkg_setup() {
G2CONF="${G2CONF}
@@ -47,6 +48,11 @@ pkg_setup() {
$(use_enable libnotify)"
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install
# bug #338213