summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-06-13 17:17:53 +0000
committerPreston A. Elder <prez@gentoo.org>2002-06-13 17:17:53 +0000
commitf69956960d36dc5edc4ae7c68f943bcc0ba677af (patch)
tree8f972ce0158347646630c6fbd7c0b948f2c358ae /net-news/inn
parentnew version of devel version (diff)
downloadgentoo-2-f69956960d36dc5edc4ae7c68f943bcc0ba677af.tar.gz
gentoo-2-f69956960d36dc5edc4ae7c68f943bcc0ba677af.tar.bz2
gentoo-2-f69956960d36dc5edc4ae7c68f943bcc0ba677af.zip
Added INN
Diffstat (limited to 'net-news/inn')
-rw-r--r--net-news/inn/ChangeLog10
-rw-r--r--net-news/inn/files/digest-inn-2.3.31
-rw-r--r--net-news/inn/files/innd20
-rw-r--r--net-news/inn/inn-2.3.3.ebuild70
4 files changed, 101 insertions, 0 deletions
diff --git a/net-news/inn/ChangeLog b/net-news/inn/ChangeLog
new file mode 100644
index 000000000000..8496a4d7bad8
--- /dev/null
+++ b/net-news/inn/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-news/inn
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-news/inn/ChangeLog,v 1.1 2002/06/13 17:17:53 prez Exp $
+
+*inn-2.3.3 (13 Jun 2002)
+
+ 13 Jun 2002; Preston A. Elder <prez@gentoo.org> inn-2.3.3.ebuild,
+ files/digest-inn-2.3.3, files/innd, ChangeLog :
+
+ - Added for the first time
diff --git a/net-news/inn/files/digest-inn-2.3.3 b/net-news/inn/files/digest-inn-2.3.3
new file mode 100644
index 000000000000..cf98e1894daf
--- /dev/null
+++ b/net-news/inn/files/digest-inn-2.3.3
@@ -0,0 +1 @@
+MD5 97080ce1dcdc5fe8f3dacd230c9d4a0a inn-2.3.3.tar.gz 1413433
diff --git a/net-news/inn/files/innd b/net-news/inn/files/innd
new file mode 100644
index 000000000000..e6d8c6af7de1
--- /dev/null
+++ b/net-news/inn/files/innd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/net-misc/bind/files/named.rc6,v 1.4 2002/06/01 16:31:07 nitro Exp
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting innd"
+ start-stop-daemon --start --quiet --chuid news:news --exec /usr/lib/news/bin/innd
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping innd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/innd.pid
+ eend $?
+}
diff --git a/net-news/inn/inn-2.3.3.ebuild b/net-news/inn/inn-2.3.3.ebuild
new file mode 100644
index 000000000000..8a7b7e5a1184
--- /dev/null
+++ b/net-news/inn/inn-2.3.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/sys-apps/gawk/gawk-3.1.0-r1.ebuild,v 1.1 2002/03/12 13:42:56 seemant Exp
+
+DESCRIPTION="The Internet News daemon, fully featured NNTP server"
+SRC_URI="ftp://ftp.isc.org/isc/inn/inn-${PV}.tar.gz"
+HOMEPAGE="http://www.isc.org/products/INN"
+
+DEPEND="virtual/glibc
+ app-crypt/gnupg
+ tcltk? ( dev-lang/tcl )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ local myconf
+ use tcltk && myconf="${myconf} --with-tcl"
+ use ssl && myconf="${myconf} --with-openssl"
+
+ ./configure --prefix=/usr/lib/news \
+ --libexecdir=/usr/lib/awk \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-etc-dir=/etc/news \
+ --with-db-dir=/var/spool/news \
+ --with-spool-dir=/var/spool/news \
+ --with-log-dir=/var/log/news \
+ --with-run-dir=/var/run \
+ --with-tmp-path=/tmp \
+ --host=${CHOST} \
+ --enable-libtool \
+ --enable-tagged-hash \
+ --with-gnu-ld \
+ --with-perl --with-python \
+ ${myconf} || die
+
+ OLD_P=${P}
+ unset P
+ emake || die
+ P=${OLD_P}
+}
+
+src_install() {
+ OLD_P=${P}
+ unset P
+ make prefix=${D}/usr/lib/news \
+ PATHETC=${D}/etc/news \
+ PATHMAN=${D}/usr/share/man \
+ PATHLIB=${D}/usr/lib/news/lib \
+ PATHCONTROL=${D}/usr/lib/news/bin/control \
+ PATHFILTER=${D}/usr/lib/news/bin/filter \
+ PATHRUN=${D}/var/run \
+ PATHLOG=${D}/var/log/news \
+ PATHDB=${D}/var/spool/news \
+ PATHSPOOL=${D}/var/spool/news \
+ PATHTMP=${D}/tmp \
+ MAN1=${D}/usr/share/man/man1 \
+ MAN3=${D}/usr/share/man/man3 \
+ MAN5=${D}/usr/share/man/man5 \
+ MAN8=${D}/usr/share/man/man8 \
+ install || die
+ P=${OLD_P}
+
+ dodoc CONTRIBUTORS ChangeLog HACKING HISTORY INSTALL LICENSE
+ dodoc MANIFEST NEWS README*
+ dodoc doc/control-messages doc/sample-control
+
+ dodir /etc/init.d
+ cp ${FILESDIR}/innd ${D}/etc/init.d
+}