summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2010-08-23 08:57:09 +0000
committerTiziano Müller <dev-zero@gentoo.org>2010-08-23 08:57:09 +0000
commitcd2658c29dbd1d567dcca1743d7ce6642d1c4f42 (patch)
treee40d54d63a5eccfcb0120fa91cbe9429cfa722f6 /net-nds
parentVersion bump. (diff)
downloadgentoo-2-cd2658c29dbd1d567dcca1743d7ce6642d1c4f42.tar.gz
gentoo-2-cd2658c29dbd1d567dcca1743d7ce6642d1c4f42.tar.bz2
gentoo-2-cd2658c29dbd1d567dcca1743d7ce6642d1c4f42.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/gosa-core/ChangeLog8
-rw-r--r--net-nds/gosa-core/gosa-core-2.6.11.ebuild108
-rw-r--r--net-nds/gosa-core/metadata.xml20
3 files changed, 127 insertions, 9 deletions
diff --git a/net-nds/gosa-core/ChangeLog b/net-nds/gosa-core/ChangeLog
index fb8cb24ea040..98d41fade267 100644
--- a/net-nds/gosa-core/ChangeLog
+++ b/net-nds/gosa-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/gosa-core
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-core/ChangeLog,v 1.2 2010/07/29 14:38:39 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-core/ChangeLog,v 1.3 2010/08/23 08:57:09 dev-zero Exp $
+
+*gosa-core-2.6.11 (23 Aug 2010)
+
+ 23 Aug 2010; Tiziano Müller <dev-zero@gentoo.org>
+ +gosa-core-2.6.11.ebuild, metadata.xml:
+ Version bump.
29 Jul 2010; Tiziano Müller <dev-zero@gentoo.org>
gosa-core-2.6.10.ebuild:
diff --git a/net-nds/gosa-core/gosa-core-2.6.11.ebuild b/net-nds/gosa-core/gosa-core-2.6.11.ebuild
new file mode 100644
index 000000000000..dece6dff4993
--- /dev/null
+++ b/net-nds/gosa-core/gosa-core-2.6.11.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/gosa-core/gosa-core-2.6.11.ebuild,v 1.1 2010/08/23 08:57:09 dev-zero Exp $
+
+EAPI=3
+
+inherit eutils
+
+DESCRIPTION="LDAP administration frontend for user administration."
+HOMEPAGE="https://oss.gonicus.de/labs/gosa/wiki/WikiStart."
+SRC_URI="ftp://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/${P}.tar.bz2
+ ftp://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2
+ http://oss.gonicus.de/pub/gosa/archive/${P}.tar.bz2 "
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="mail samba"
+
+DEPEND="dev-lang/php[iconv,imap,ldap,mysql,session,zip]
+ sys-devel/gettext"
+RDEPEND="${DEPEND}
+ virtual/httpd-php
+ dev-perl/Crypt-SmbHash
+ media-gfx/imagemagick"
+PDEPEND="mail? ( ~net-nds/gosa-plugin-mail-${PV} )
+ samba? ( ~net-nds/gosa-plugin-samba-${PV} )"
+
+src_prepare() {
+ epatch \
+ "${S}/redhat/02_fix_class_mapping.patch" \
+ "${S}/redhat/03_fix_locale_location.patch" \
+ "${S}/redhat/04_fix_online_help_location.patch"
+ sed -i \
+ -e 's|../contrib|/usr/share/gosa/template|' \
+ include/functions.inc || die "sed failed"
+}
+
+src_install() {
+ insinto /usr/share/gosa
+ doins -r doc html ihtml include locale plugins setup
+
+ insinto /usr/share/gosa/template
+ doins contrib/gosa.conf
+
+ dosbin \
+ update-gosa \
+ bin/gosa-encrypt-passwords
+
+ dobin \
+ update-locale \
+ update-online-help \
+ update-pdf-help \
+ dh-make-gosa \
+ contrib/gosa
+
+ insinto /etc/gosa
+ doins \
+ contrib/shells \
+ contrib/encodings \
+ contrib/desktoprc
+ touch "${D}/etc/gosa/gosa.secrets"
+
+ doicon debian/*.xpm
+ domenu debian/gosa-desktop.desktop
+
+ doman *.1 contrib/*.1 contrib/*.5
+
+ dodoc contrib/openldap/slapd.conf
+ insinto /etc/openldap/schema/gosa
+ doins contrib/openldap/*.schema
+
+ insinto /etc/apache2/vhosts.d
+ doins "${FILESDIR}/gosa.include"
+
+ dodoc AUTHORS Changelog FAQ README README.safemode
+
+ keepdir /etc/gosa
+ keepdir /var/spool/gosa
+ keepdir /var/cache/gosa
+}
+
+pkg_prerm() {
+ ebegin "Flushing the class and locale cache"
+ rm -r "${EROOT}"var/cache/gosa/*
+ eend $?
+ ebegin "Clearing the spool directory"
+ rm -r "${EROOT}"var/spool/gosa/*
+ eend $?
+}
+
+pkg_postinst() {
+ ebegin "Generating class cache and locales"
+ "${EROOT}"usr/sbin/update-gosa
+ eend $?
+
+ elog "Please make sure that the web server you are going to use has"
+ elog "read-write access to ${EROOT}var/spool/gosa"
+
+ elog "For Apache there is the gosa.include file in ${EROOT}etc/apache/vhosts.d."
+ elog "You can either use it as a template for your configuration or directly"
+ elog "include it in your apache configuration."
+
+ elog "GOsa requires some objectclasses and attributes to be present in the"
+ elog "directory. A sample configuration for slapd.conf can be found here:"
+ elog " ${EROOR}usr/share/doc/${PF}/slapd.conf[.gz]"
+}
diff --git a/net-nds/gosa-core/metadata.xml b/net-nds/gosa-core/metadata.xml
index 0c6ccc026e3b..2aed4d53f500 100644
--- a/net-nds/gosa-core/metadata.xml
+++ b/net-nds/gosa-core/metadata.xml
@@ -1,12 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
- <maintainer>
- <email>dev-zero@gentoo.org</email>
- <name>Tiziano Müller</name>
- </maintainer>
- <upstream>
- <changelog>http://oss.gonicus.de/pub/gosa/Changelog</changelog>
- </upstream>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <use>
+ <flag name='mail'>Manage mail accounts and servers with gosa.</flag>
+ <flag name='samba'>Manage samba accounts with gosa.</flag>
+ </use>
+ <upstream>
+ <changelog>http://oss.gonicus.de/pub/gosa/Changelog</changelog>
+ </upstream>
</pkgmetadata>