summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-11-11 12:36:03 +0000
committerAchim Gottinger <achim@gentoo.org>2001-11-11 12:36:03 +0000
commita8f94f5663d1678f8baf7b678933919ab02a9fd8 (patch)
treea68fb89c622db4889f0bc910bc186e9a6fd19ef2 /net-nds
parentUpdate (diff)
downloadgentoo-2-a8f94f5663d1678f8baf7b678933919ab02a9fd8.tar.gz
gentoo-2-a8f94f5663d1678f8baf7b678933919ab02a9fd8.tar.bz2
gentoo-2-a8f94f5663d1678f8baf7b678933919ab02a9fd8.zip
Update
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/openldap/files/digest-openldap-1.2.13-r61
-rw-r--r--net-nds/openldap/openldap-1.2.13-r6.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-nds/openldap/files/digest-openldap-1.2.13-r6 b/net-nds/openldap/files/digest-openldap-1.2.13-r6
new file mode 100644
index 000000000000..ebc2fe7e4ea5
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-1.2.13-r6
@@ -0,0 +1 @@
+MD5 9613c1f8211c058e0b13788355b0e580 openldap-1.2.13.tgz 1036288
diff --git a/net-nds/openldap/openldap-1.2.13-r6.ebuild b/net-nds/openldap/openldap-1.2.13-r6.ebuild
new file mode 100644
index 000000000000..b3b0fdfe7fdf
--- /dev/null
+++ b/net-nds/openldap/openldap-1.2.13-r6.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-1.2.13-r6.ebuild,v 1.1 2001/11/11 12:36:03 achim Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+DEPEND="virtual/glibc
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+ use tcpd && myconf="${myconf} --enable-wrappers"
+ use gdbm && myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ use gdbm || myconf="${myconf} --disable-ldbm"
+
+ ./configure --host=${CHOST} --enable-passwd --enable-shell --enable-shared \
+ --enable-static --prefix=/usr --sysconfdir=/etc --localstatedir=/var/lib \
+ --mandir=/usr/share/man --libexecdir=/usr/lib/openldap ${myconf}
+ assert "bad configure"
+
+ make depend || die
+ make || die "compile problem"
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc/openldap localstatedir=${D}/var/lib \
+ mandir=${D}/usr/share/man libexecdir=${D}/usr/lib/openldap install
+ assert "install problem"
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ cp $i $i.orig
+ sed -e "s:${D}::" $i.orig > $i
+ rm $i.orig
+ done
+}