summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-12-22 10:41:38 +0000
committerPacho Ramos <pacho@gentoo.org>2013-12-22 10:41:38 +0000
commit8622d669920b66e1ff234fd6e7f512143e9f3cc2 (patch)
treeffcdc96cea4d1804a0d37da4db7cba2e9dd52ca8 /net-nds
parentamd64/x86 stable wrt bug #492092 (diff)
downloadgentoo-2-8622d669920b66e1ff234fd6e7f512143e9f3cc2.tar.gz
gentoo-2-8622d669920b66e1ff234fd6e7f512143e9f3cc2.tar.bz2
gentoo-2-8622d669920b66e1ff234fd6e7f512143e9f3cc2.zip
Version bump, add systemd support (#493776)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ypbind/ChangeLog8
-rw-r--r--net-nds/ypbind/files/ypbind.service11
-rw-r--r--net-nds/ypbind/ypbind-1.37.1.ebuild65
3 files changed, 83 insertions, 1 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index 255ac082d2c1..bea5c96b8157 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/ypbind
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.76 2013/09/08 13:56:26 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.77 2013/12/22 10:41:38 pacho Exp $
+
+*ypbind-1.37.1 (22 Dec 2013)
+
+ 22 Dec 2013; Pacho Ramos <pacho@gentoo.org> +files/ypbind.service,
+ +ypbind-1.37.1.ebuild:
+ Version bump, add systemd support (#493776)
08 Sep 2013; Markus Meier <maekke@gentoo.org> ypbind-1.33.ebuild:
add ~arm, bug #372871
diff --git a/net-nds/ypbind/files/ypbind.service b/net-nds/ypbind/files/ypbind.service
new file mode 100644
index 000000000000..a04ed71fe0d0
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=YP Bind
+Requires=rpcbind.service domainname.service
+After=rpcbind.service domainname.service network.target
+Before=systemd-user-sessions.service
+
+[Service]
+ExecStart=/usr/sbin/ypbind -foreground
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-nds/ypbind/ypbind-1.37.1.ebuild b/net-nds/ypbind/ypbind-1.37.1.ebuild
new file mode 100644
index 000000000000..2de5a95767c5
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.37.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.37.1.ebuild,v 1.1 2013/12/22 10:41:38 pacho Exp $
+
+EAPI=5
+inherit readme.gentoo systemd
+
+MY_P=${PN}-mt-${PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="http://www.linux-nis.org/download/ypbind-mt/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug dbus nls slp systemd"
+
+RDEPEND="
+ debug? ( dev-libs/dmalloc )
+ dbus? ( dev-libs/dbus-glib )
+ slp? ( net-libs/openslp )
+ systemd? (
+ net-nds/rpcbind
+ >=net-nds/yp-tools-2.12-r1
+ sys-apps/systemd )
+ !systemd? (
+ net-nds/yp-tools
+ || ( net-nds/portmap net-nds/rpcbind ) )
+"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+DOC_CONTENTS="
+ If you are using dhcpcd, be sure to add the -Y option to
+ dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering
+ /etc/yp.conf.
+"
+
+src_prepare() {
+ ! use systemd && export ac_cv_header_systemd_sd_daemon_h=no
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable slp) \
+ $(use_with debug dmalloc) \
+ $(use_enable dbus dbus-nm)
+}
+
+src_install() {
+ default
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
+ newconfd "${FILESDIR}/ypbind.confd-r1" ypbind
+ newinitd "${FILESDIR}/ypbind.initd" ypbind
+ use systemd && systemd_dounit "${FILESDIR}/ypbind.service"
+
+ readme.gentoo_create_doc
+}