summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2012-02-07 14:24:52 +0000
committerTony Vroon <chainsaw@gentoo.org>2012-02-07 14:24:52 +0000
commit14bc3844ea2458092c1bd747f19602be792e31a6 (patch)
tree4d11b93264bca45156fc47afff5ceeb40f029055 /net-nds
parentcleanup, minor fixes (diff)
downloadgentoo-2-14bc3844ea2458092c1bd747f19602be792e31a6.tar.gz
gentoo-2-14bc3844ea2458092c1bd747f19602be792e31a6.tar.bz2
gentoo-2-14bc3844ea2458092c1bd747f19602be792e31a6.zip
Revision bump. Add sys-libs/pam to RDEPEND and remove spurious libtool archive when static-libs is not enabled. Stop specifying deprecated opts variable in init script. Closes bugs #402503 & #402505 by Agostino "ago" Sarubbo.
(Portage version: 2.1.10.45/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/tac_plus/ChangeLog13
-rw-r--r--net-nds/tac_plus/files/tac_plus.init221
-rw-r--r--net-nds/tac_plus/tac_plus-4.0.4.19-r3.ebuild56
3 files changed, 88 insertions, 2 deletions
diff --git a/net-nds/tac_plus/ChangeLog b/net-nds/tac_plus/ChangeLog
index 94ede2ea9e54..4de7d86fe0fe 100644
--- a/net-nds/tac_plus/ChangeLog
+++ b/net-nds/tac_plus/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-nds/tac_plus
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/ChangeLog,v 1.8 2011/06/16 16:00:43 chainsaw Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/ChangeLog,v 1.9 2012/02/07 14:24:52 chainsaw Exp $
+
+*tac_plus-4.0.4.19-r3 (07 Feb 2012)
+
+ 07 Feb 2012; Tony Vroon <chainsaw@gentoo.org> +tac_plus-4.0.4.19-r3.ebuild,
+ +files/tac_plus.init2:
+ Revision bump. Add sys-libs/pam to RDEPEND and remove spurious libtool
+ archive when static-libs is not enabled. Stop specifying deprecated opts
+ variable in init script. Closes bugs #402503 & #402505 by Agostino "ago"
+ Sarubbo.
*tac_plus-4.0.4.19-r2 (16 Jun 2011)
diff --git a/net-nds/tac_plus/files/tac_plus.init2 b/net-nds/tac_plus/files/tac_plus.init2
new file mode 100644
index 000000000000..8262cf8e090f
--- /dev/null
+++ b/net-nds/tac_plus/files/tac_plus.init2
@@ -0,0 +1,21 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/files/tac_plus.init2,v 1.1 2012/02/07 14:24:52 chainsaw Exp $
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting tac_plus"
+ start-stop-daemon --start --quiet --exec /usr/bin/tac_plus \
+ -- -C /etc/tac_plus/tac_plus.conf ${TAC_PLUS_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tac_plus"
+ start-stop-daemon --stop --quiet --pidfile /var/run/tac_plus.pid
+ eend $?
+}
diff --git a/net-nds/tac_plus/tac_plus-4.0.4.19-r3.ebuild b/net-nds/tac_plus/tac_plus-4.0.4.19-r3.ebuild
new file mode 100644
index 000000000000..6cf44dc115d0
--- /dev/null
+++ b/net-nds/tac_plus/tac_plus-4.0.4.19-r3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/tac_plus/tac_plus-4.0.4.19-r3.ebuild,v 1.1 2012/02/07 14:24:52 chainsaw Exp $
+
+EAPI=4
+
+inherit autotools base libtool
+
+MY_P="tacacs+-F${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="An updated version of Cisco's TACACS+ server"
+HOMEPAGE="http://www.shrubbery.net/tac_plus/"
+SRC_URI="ftp://ftp.shrubbery.net/pub/tac_plus/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="debug finger maxsess tcpd skey static-libs"
+
+DEPEND="skey? ( >=sys-auth/skey-1.1.5-r1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-parallelmake.patch" )
+
+src_prepare() {
+ base_src_prepare
+ AT_M4DIR="." eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_with skey) \
+ $(use_with tcpd libwrap) \
+ $(use_enable debug) \
+ $(use_enable finger) \
+ $(use_enable maxsess) \
+ $(use_enable static-libs static) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ use static-libs || find "${D}" -name '*.la' -delete || die "Unable to remove spurious libtool archive"
+ dodoc CHANGES FAQ
+
+ newinitd "${FILESDIR}/tac_plus.init2" tac_plus
+ newconfd "${FILESDIR}/tac_plus.confd2" tac_plus
+
+ insinto /etc/tac_plus
+ newins "${FILESDIR}/tac_plus.conf2" tac_plus.conf
+}