summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
committerMike Frysinger <vapier@gentoo.org>2004-10-31 05:40:05 +0000
commita342a54e99667fdfc24d59a77f7fa382aff495fa (patch)
tree91af6250880e43fb3e789642e34d7d910b67251e /net-nds/ypbind
parentClosing bug25551 (Manifest recommit) (diff)
downloadgentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.tar.gz
gentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.tar.bz2
gentoo-2-a342a54e99667fdfc24d59a77f7fa382aff495fa.zip
ia64 stable for #66786
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/ypbind-1.17.2-r1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
index c81eb255d932..e6f7a8a90921 100644
--- a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
+++ b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.6 2004/10/08 18:01:16 hansmi Exp $
-
-IUSE="nls slp"
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.7 2004/10/31 05:38:08 vapier Exp $
MY_P=${PN}-mt-${PV}
S="${WORKDIR}/${MY_P}"
@@ -13,19 +11,21 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 sparc alpha ppc amd64 ~ia64 ~ppc64"
-
-DEPEND="slp? ( net-libs/openslp )"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE="nls slp"
-RDEPEND="${DEPEND}
+RDEPEND="slp? ( net-libs/openslp )
net-nds/yp-tools
net-nds/portmap"
-
-DEPEND="${DEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-apps/portage-2.0.51"
src_compile() {
- econf `use_enable nls` `use_enable slp` || die
+ econf \
+ $(use_enable nls) \
+ $(use_enable slp) \
+ || die
emake || die "emake failed"
}
@@ -33,8 +33,8 @@ src_install() {
einstall || die
dodoc AUTHORS ChangeLog README THANKS TODO
insinto /etc ; doins etc/yp.conf
- insinto /etc/conf.d ; newins ${FILESDIR}/ypbind.confd-r1 ypbind
- exeinto /etc/init.d ; newexe ${FILESDIR}/ypbind.initd ypbind
+ newconfd ${FILESDIR}/ypbind.confd-r1 ypbind
+ newinitd ${FILESDIR}/ypbind.initd ypbind
}
pkg_postinst() {