summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-08-24 23:23:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-08-24 23:23:27 +0000
commit0d822049cbf75e0945915562152b0ac04543b72e (patch)
tree4cb6c47b46ab69ec5165737e3780f38b8f2fdd7a /net-nds/ypbind
parentinitial commit of ipkg-utils. ebuild written by tigger@g.o (Manifest recommit) (diff)
downloadgentoo-2-0d822049cbf75e0945915562152b0ac04543b72e.tar.gz
gentoo-2-0d822049cbf75e0945915562152b0ac04543b72e.tar.bz2
gentoo-2-0d822049cbf75e0945915562152b0ac04543b72e.zip
1.17.2-r1 stable on x86, sparc, and amd64. Added slp USE flag support.
Diffstat (limited to 'net-nds/ypbind')
-rw-r--r--net-nds/ypbind/ChangeLog7
-rw-r--r--net-nds/ypbind/ypbind-1.11-r1.ebuild10
-rw-r--r--net-nds/ypbind/ypbind-1.12.ebuild10
-rw-r--r--net-nds/ypbind/ypbind-1.17.2-r1.ebuild11
-rw-r--r--net-nds/ypbind/ypbind-1.17.2.ebuild9
5 files changed, 25 insertions, 22 deletions
diff --git a/net-nds/ypbind/ChangeLog b/net-nds/ypbind/ChangeLog
index b83b48aab5b8..df6e8a15cd8a 100644
--- a/net-nds/ypbind/ChangeLog
+++ b/net-nds/ypbind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-nds/ypbind
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.20 2004/08/23 21:50:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ChangeLog,v 1.21 2004/08/24 23:23:27 eradicator Exp $
+
+ 24 Aug 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ ypbind-1.11-r1.ebuild, ypbind-1.12.ebuild, ypbind-1.17.2-r1.ebuild,
+ ypbind-1.17.2.ebuild:
+ 1.17.2-r1 stable on x86, sparc, and amd64. Added slp USE flag support.
23 Aug 2004; Jeremy Huddleston <eradicator@gentoo.org>
ypbind-1.11-r1.ebuild, ypbind-1.12.ebuild, ypbind-1.17.2-r1.ebuild,
diff --git a/net-nds/ypbind/ypbind-1.11-r1.ebuild b/net-nds/ypbind/ypbind-1.11-r1.ebuild
index fa4d06b5ef64..4edb9910efe9 100644
--- a/net-nds/ypbind/ypbind-1.11-r1.ebuild
+++ b/net-nds/ypbind/ypbind-1.11-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.11-r1.ebuild,v 1.15 2004/08/23 21:50:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.11-r1.ebuild,v 1.16 2004/08/24 23:23:27 eradicator Exp $
-IUSE="nls"
+IUSE="nls slp"
MY_P=${PN}-mt-${PV}
S=${WORKDIR}/${MY_P}
@@ -15,15 +15,13 @@ LICENSE="GPL-2"
KEYWORDS="x86 sparc alpha ia64"
DEPEND="net-nds/yp-tools
- net-libs/openslp
+ slp? ( net-libs/openslp )
net-nds/portmap"
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- econf ${myconf} || die
+ econf `use_enable nls` `use_enable slp` || die
make || die
}
diff --git a/net-nds/ypbind/ypbind-1.12.ebuild b/net-nds/ypbind/ypbind-1.12.ebuild
index 645603823c9c..3a2b91b2b1ef 100644
--- a/net-nds/ypbind/ypbind-1.12.ebuild
+++ b/net-nds/ypbind/ypbind-1.12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.12.ebuild,v 1.6 2004/08/23 21:50:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.12.ebuild,v 1.7 2004/08/24 23:23:27 eradicator Exp $
-IUSE="nls"
+IUSE="nls slp"
MY_P=${PN}-mt-${PV}
S=${WORKDIR}/${MY_P}
@@ -15,14 +15,12 @@ LICENSE="GPL-2"
KEYWORDS="~x86 ~sparc ~alpha ~ppc ppc64"
DEPEND="net-nds/yp-tools
- net-libs/openslp
+ slp? ( net-libs/openslp )
net-nds/portmap"
RDEPEND="nls? ( sys-devel/gettext )"
src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- econf ${myconf} || die
+ econf `use_enable nls` `use_enable slp` || die
make || die
}
diff --git a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
index bb9b81b719c2..ec76b66ff96a 100644
--- a/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
+++ b/net-nds/ypbind/ypbind-1.17.2-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.2 2004/08/23 21:50:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2-r1.ebuild,v 1.3 2004/08/24 23:23:27 eradicator Exp $
+
+IUSE="nls slp"
MY_P=${PN}-mt-${PV}
DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
@@ -9,11 +11,10 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~alpha ~ppc ~amd64 ~ia64 ~ppc64"
-IUSE="nls"
+KEYWORDS="x86 sparc ~alpha ~ppc amd64 ~ia64 ~ppc64"
DEPEND="net-nds/yp-tools
- net-libs/openslp
+ slp? ( net-libs/openslp )
net-nds/portmap"
RDEPEND="nls? ( sys-devel/gettext )"
@@ -21,7 +22,7 @@ RDEPEND="nls? ( sys-devel/gettext )"
S="${WORKDIR}/${MY_P}"
src_compile() {
- econf $(use_enable nls) || die
+ econf `use_enable nls` `use_enable slp` || die
emake || die "emake failed"
}
diff --git a/net-nds/ypbind/ypbind-1.17.2.ebuild b/net-nds/ypbind/ypbind-1.17.2.ebuild
index 9b4fd5d41601..6af50f58351e 100644
--- a/net-nds/ypbind/ypbind-1.17.2.ebuild
+++ b/net-nds/ypbind/ypbind-1.17.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2.ebuild,v 1.7 2004/08/23 21:50:50 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.17.2.ebuild,v 1.8 2004/08/24 23:23:27 eradicator Exp $
+
+IUSE="nls slp"
MY_P=${PN}-mt-${PV}
DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
@@ -10,17 +12,16 @@ SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86 sparc alpha ~ppc amd64"
-IUSE="nls"
DEPEND="net-nds/yp-tools
- net-libs/openslp
+ slp? ( net-libs/openslp )
net-nds/portmap"
RDEPEND="nls? ( sys-devel/gettext )"
S="${WORKDIR}/${MY_P}"
src_compile() {
- econf $(use_enable nls) || die
+ econf `use_enable nls` `use_enable slp` || die
emake || die "emake failed"
}