summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-08-15 19:30:22 +0000
committerNick Hadaway <raker@gentoo.org>2002-08-15 19:30:22 +0000
commit13c86ea668b5b985cc8743dbb79f896c1932b79c (patch)
tree8e3d9ef28a380d5e32ef7adcca23264b2e1f7e35 /net-nds/openldap
parentremask qt-3.0.5-r1 now that 3.0.5 is back (diff)
downloadgentoo-2-13c86ea668b5b985cc8743dbb79f896c1932b79c.tar.gz
gentoo-2-13c86ea668b5b985cc8743dbb79f896c1932b79c.tar.bz2
gentoo-2-13c86ea668b5b985cc8743dbb79f896c1932b79c.zip
More intelligent ldbm api choosing. Thanks to Eric Renfro for the
suggestion.
Diffstat (limited to 'net-nds/openldap')
-rw-r--r--net-nds/openldap/ChangeLog9
-rw-r--r--net-nds/openldap/files/digest-openldap-2.0.25-r21
-rw-r--r--net-nds/openldap/openldap-2.0.25-r2.ebuild95
3 files changed, 104 insertions, 1 deletions
diff --git a/net-nds/openldap/ChangeLog b/net-nds/openldap/ChangeLog
index dfffa609e1fe..e0335c95b0e9 100644
--- a/net-nds/openldap/ChangeLog
+++ b/net-nds/openldap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nds/openldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.8 2002/08/13 01:49:24 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/ChangeLog,v 1.9 2002/08/15 19:30:22 raker Exp $
+
+*openldap-2.0.25-r2 (15 Aug 2002)
+
+ 15 Aug 2002; Nick Hadaway <raker@gentoo.org>
+ openldap-2.0.25-r2.ebuild, files/digest-openldap-2.0.25-r2 :
+ Updated ebuild based on suggestions by Eric Renfro via bug report
+ #6488
*openldap-2.0.25-r1 (29 Jul 2002)
diff --git a/net-nds/openldap/files/digest-openldap-2.0.25-r2 b/net-nds/openldap/files/digest-openldap-2.0.25-r2
new file mode 100644
index 000000000000..8f386fb0e4ef
--- /dev/null
+++ b/net-nds/openldap/files/digest-openldap-2.0.25-r2
@@ -0,0 +1 @@
+MD5 57ed9ea3d872595076d6eab7b93337bd openldap-2.0.25.tgz 1304098
diff --git a/net-nds/openldap/openldap-2.0.25-r2.ebuild b/net-nds/openldap/openldap-2.0.25-r2.ebuild
new file mode 100644
index 000000000000..b7604d32c67a
--- /dev/null
+++ b/net-nds/openldap/openldap-2.0.25-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.0.25-r2.ebuild,v 1.1 2002/08/15 19:30:22 raker Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="LDAP suite of application and development tools"
+SRC_URI="ftp://ftp.OpenLDAP.org/pub/OpenLDAP/openldap-release/${P}.tgz"
+HOMEPAGE="http://www.OpenLDAP.org/"
+
+SLOT="0"
+KEYWORDS="x86 ppc"
+LICENSE="OPENLDAP"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ sasl? ( >=dev-libs/cyrus-sasl-1.5.27 )
+ ldap-berkdb? ( >=sys-libs/db-3.2.9 )
+ ldap-gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ ldap-gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+ local myconf
+
+ use tcpd && myconf="${myconf} --enable-wrappers" \
+ || myconf="${myconf} --disable-wrappers"
+ use ssl && myconf="${myconf} --with-tls" \
+ || myconf="${myconf} --without-tls"
+ use readline && myconf="${myconf} --with-readline" \
+ || myconf="${myconf} --without-readline"
+ if use ldap-berkdb; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=berkeley"
+ elif use ldap-gdbm; then
+ myconf="${myconf} --enable-ldbm --with-ldbm-api=gdbm"
+ elif use ldap-none; then
+ myconf="${myconf} --disable-ldbm"
+ else
+ myconf="${myconf} --enable-ldbm --with-ldbmi-api=auto"
+ fi
+ use ipv6 && myconf="${myconf} --enable-ipv6" \
+ || myconf="${myconf} --disable-ipv6"
+ use sasl && myconf="${myconf} --enable-cyrus-sasl" \
+ || myconf="${myconf} --disable-cyrus-sasl"
+
+
+ ./configure --host=${CHOST} \
+ --enable-passwd \
+ --enable-shell \
+ --enable-shared \
+ --enable-static \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/state/openldap \
+ --mandir=/usr/share/man \
+ --libexecdir=/usr/lib/openldap \
+ ${myconf} || die "bad configure"
+
+ make depend || die
+ make || die
+ cd tests ; make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc/openldap \
+ localstatedir=${D}/var/state/openldap \
+ mandir=${D}/usr/share/man \
+ libexecdir=${D}/usr/lib/openldap \
+ install || die "install problem"
+
+ #fix ${D} in manpages
+ cd ${S}/doc/man
+ make DESTDIR=${D} clean all install || die "install doc problem"
+ cd ${S}
+
+ dodoc ANNOUNCEMENT CHANGES COPYRIGHT README LICENSE
+ docinto rfc ; dodoc doc/rfc/*.txt
+ docinto devel ; dodoc doc/devel/*
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/slapd.rc6 slapd
+ newexe ${FILESDIR}/slurpd.rc6 slurpd
+
+ cd ${D}/etc/openldap
+ for i in *
+ do
+ dosed $i
+ done
+}
+