summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-02-12 00:54:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-02-12 00:54:14 +0000
commit1144cf2cc9e3d791d2bc7206c3be57775b3fc502 (patch)
tree630a5436ab3ebbf610d2bd65b595fe7c2ff42578 /net-nds/openldap/openldap-2.4.25.ebuild
parentMarked stable on PPC64 as requested by Diego Elio "Flameeyes" Petteno in bug ... (diff)
downloadgentoo-2-1144cf2cc9e3d791d2bc7206c3be57775b3fc502.tar.gz
gentoo-2-1144cf2cc9e3d791d2bc7206c3be57775b3fc502.tar.bz2
gentoo-2-1144cf2cc9e3d791d2bc7206c3be57775b3fc502.zip
Bug #337504: compile-fix for gnutls linked with gcrypt. Relies on WANT_AUTOMAKE=none eautoreconf support added to autotools.eclass as openldap configure.in uses AM_INIT_AUTOMAKE but there are no Makefile.am (all Makefile.in are hand-written).
(Portage version: 2.2.0_alpha85/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/openldap/openldap-2.4.25.ebuild')
-rw-r--r--net-nds/openldap/openldap-2.4.25.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-nds/openldap/openldap-2.4.25.ebuild b/net-nds/openldap/openldap-2.4.25.ebuild
index 39a91d81452e..044fae90a335 100644
--- a/net-nds/openldap/openldap-2.4.25.ebuild
+++ b/net-nds/openldap/openldap-2.4.25.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.25.ebuild,v 1.3 2012/02/10 18:10:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/openldap/openldap-2.4.25.ebuild,v 1.4 2012/02/12 00:54:14 robbat2 Exp $
EAPI="2"
-inherit db-use eutils flag-o-matic multilib ssl-cert versionator toolchain-funcs
+WANT_AUTOMAKE=none
+inherit db-use eutils flag-o-matic multilib ssl-cert versionator toolchain-funcs autotools
DESCRIPTION="LDAP suite of application and development tools"
HOMEPAGE="http://www.OpenLDAP.org/"
@@ -237,6 +238,9 @@ src_prepare() {
# bug #233633
epatch "${FILESDIR}"/${PN}-2.4.17-fix-lmpasswd-gnutls-symbols.patch
+ # bug #281495
+ epatch "${FILESDIR}"/${PN}-2.4.28-gnutls-gcrypt.patch
+
cd "${S}"/build
einfo "Making sure upstream build strip does not do stripping too early"
sed -i.orig \
@@ -247,6 +251,11 @@ src_prepare() {
sed -i \
-e 's|/bin/sh|/bin/bash|g' \
"${S}"/tests/scripts/* || die "sed failed"
+
+ cd "${S}"
+ #sed '/AM_INIT_AUTOMAKE/s,^,#,g' -i configure.in || die "sed failed"
+ eautoreconf
+ #sed '/AM_INIT_AUTOMAKE/s,^#,,g' -i configure.in || die "sed failed"
}
build_contrib_module() {