summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-01-13 10:22:40 +0000
committerJeroen Roovers <jer@gentoo.org>2015-01-13 10:22:40 +0000
commitfea45509d3eb770303fbb7c57d65252e3196e894 (patch)
tree6d6f44da5496381edf3990a97d66218f3e2a0b5c /net-misc
parentStable for sparc, wrt bug #535774 (diff)
downloadgentoo-2-fea45509d3eb770303fbb7c57d65252e3196e894.tar.gz
gentoo-2-fea45509d3eb770303fbb7c57d65252e3196e894.tar.bz2
gentoo-2-fea45509d3eb770303fbb7c57d65252e3196e894.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/iperf/ChangeLog9
-rw-r--r--net-misc/iperf/iperf-3.0.11.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
index f6c9bda994fb..217419a2c9d0 100644
--- a/net-misc/iperf/ChangeLog
+++ b/net-misc/iperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iperf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.67 2014/12/18 09:57:48 jer Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.68 2015/01/13 10:22:40 jer Exp $
+
+*iperf-3.0.11 (13 Jan 2015)
+
+ 13 Jan 2015; Jeroen Roovers <jer@gentoo.org> +iperf-3.0.11.ebuild:
+ Version bump.
*iperf-3.0.10 (18 Dec 2014)
diff --git a/net-misc/iperf/iperf-3.0.11.ebuild b/net-misc/iperf/iperf-3.0.11.ebuild
new file mode 100644
index 000000000000..2eaf50b03a40
--- /dev/null
+++ b/net-misc/iperf/iperf-3.0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-3.0.11.ebuild,v 1.1 2015/01/13 10:22:40 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+LICENSE="BSD"
+SLOT="3"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.5-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}