summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-03 08:47:42 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-03 08:47:42 +0000
commitf42a7f4a468ea7aeab26cbfd92c66aad61ea189a (patch)
tree0b378298a3da17fbf1be1c6e3137a215c56a845c /net-misc
parentarm/s390/sh stable (diff)
downloadgentoo-2-f42a7f4a468ea7aeab26cbfd92c66aad61ea189a.tar.gz
gentoo-2-f42a7f4a468ea7aeab26cbfd92c66aad61ea189a.tar.bz2
gentoo-2-f42a7f4a468ea7aeab26cbfd92c66aad61ea189a.zip
Fix some issues with printing of banners #244222 by Michał Górny.
(Portage version: 2.2_rc13/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog9
-rw-r--r--net-misc/openssh/files/openssh-5.1_p1-escaped-banner.patch18
-rw-r--r--net-misc/openssh/files/openssh-5.1_p1-null-banner.patch35
-rw-r--r--net-misc/openssh/openssh-5.1_p1-r2.ebuild171
4 files changed, 232 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 45bf415a2cd3..5f2426469173 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.321 2008/11/01 10:36:37 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.322 2008/11/03 08:47:42 vapier Exp $
+
+*openssh-5.1_p1-r2 (03 Nov 2008)
+
+ 03 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-5.1_p1-escaped-banner.patch,
+ +files/openssh-5.1_p1-null-banner.patch, +openssh-5.1_p1-r2.ebuild:
+ Fix some issues with printing of banners #244222 by Michał Górny.
01 Nov 2008; Robin H. Johnson <robbat2@gentoo.org> openssh-5.1_p1.ebuild,
openssh-5.1_p1-r1.ebuild:
diff --git a/net-misc/openssh/files/openssh-5.1_p1-escaped-banner.patch b/net-misc/openssh/files/openssh-5.1_p1-escaped-banner.patch
new file mode 100644
index 000000000000..440772245d6f
--- /dev/null
+++ b/net-misc/openssh/files/openssh-5.1_p1-escaped-banner.patch
@@ -0,0 +1,18 @@
+don't escape the banner output
+
+http://bugs.gentoo.org/244222
+https://bugzilla.mindrot.org/show_bug.cgi?id=1533
+
+fix by Michał Górny <mgorny.3ehbo@mailnull.com>
+
+--- sshconnect2.c
++++ sshconnect2.c
+@@ -415,7 +415,7 @@ input_userauth_banner(int type, u_int32_t seq, void *ctxt)
+ if (len > 65536)
+ len = 65536;
+ msg = xmalloc(len * 4 + 1); /* max expansion from strnvis() */
+- strnvis(msg, raw, len * 4 + 1, VIS_SAFE|VIS_OCTAL);
++ strnvis(msg, raw, len * 4 + 1, VIS_SAFE|VIS_OCTAL|VIS_NOSLASH);
+ fprintf(stderr, "%s", msg);
+ xfree(msg);
+ }
diff --git a/net-misc/openssh/files/openssh-5.1_p1-null-banner.patch b/net-misc/openssh/files/openssh-5.1_p1-null-banner.patch
new file mode 100644
index 000000000000..79e5a6c26476
--- /dev/null
+++ b/net-misc/openssh/files/openssh-5.1_p1-null-banner.patch
@@ -0,0 +1,35 @@
+apply fixes from upstream for empty banner
+
+https://bugzilla.mindrot.org/show_bug.cgi?id=1496
+http://bugs.gentoo.org/244222
+
+----------------------------
+revision 1.168
+date: 2008/10/03 23:56:28; author: deraadt; state: Exp; lines: +3 -3
+Repair strnvis() buffersize of 4*n+1, with termination gauranteed by the
+function.
+spotted by des@freebsd, who commited an incorrect fix to the freebsd tree
+and (as is fairly typical) did not report the problem to us. But this fix
+is correct.
+ok djm
+----------------------------
+revision 1.167
+date: 2008/07/31 14:48:28; author: markus; state: Exp; lines: +2 -2
+don't allocate space for empty banners; report t8m at centrum.cz; ok deraadt
+--- src/usr.bin/ssh/sshconnect2.c 2008/07/17 09:48:00 1.166
++++ src/usr.bin/ssh/sshconnect2.c 2008/10/04 00:56:28 1.168
+@@ -377,11 +377,11 @@ input_userauth_banner(int type, u_int32_t seq, void *c
+ debug3("input_userauth_banner");
+ raw = packet_get_string(&len);
+ lang = packet_get_string(NULL);
+- if (options.log_level >= SYSLOG_LEVEL_INFO) {
++ if (len > 0 && options.log_level >= SYSLOG_LEVEL_INFO) {
+ if (len > 65536)
+ len = 65536;
+- msg = xmalloc(len * 4); /* max expansion from strnvis() */
+- strnvis(msg, raw, len * 4, VIS_SAFE|VIS_OCTAL);
++ msg = xmalloc(len * 4 + 1); /* max expansion from strnvis() */
++ strnvis(msg, raw, len * 4 + 1, VIS_SAFE|VIS_OCTAL);
+ fprintf(stderr, "%s", msg);
+ xfree(msg);
+ }
diff --git a/net-misc/openssh/openssh-5.1_p1-r2.ebuild b/net-misc/openssh/openssh-5.1_p1-r2.ebuild
new file mode 100644
index 000000000000..46320dc993cd
--- /dev/null
+++ b/net-misc/openssh/openssh-5.1_p1-r2.ebuild
@@ -0,0 +1,171 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.1_p1-r2.ebuild,v 1.1 2008/11/03 08:47:42 vapier Exp $
+
+inherit eutils flag-o-matic ccc multilib autotools pam
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+X509_PATCH="${PARCH}+x509-6.1.1.diff.gz"
+LDAP_PATCH="${PARCH/openssh/openssh-lpk}-0.3.10.patch.gz"
+HPN_PATCH="${PARCH}-hpn13v5.diff.gz"
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.org/"
+SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
+ http://www.sxw.org.uk/computing/patches/openssh-5.0p1-gsskex-20080404.patch
+ ${LDAP_PATCH:+ldap? ( mirror://gentoo/${LDAP_PATCH} )}
+ ${X509_PATCH:+X509? ( http://roumenpetrov.info/openssh/x509-6.1.1/${X509_PATCH} )}
+ ${HPN_PATCH:+hpn? ( http://www.psc.edu/networking/projects/hpn-ssh/${HPN_PATCH} )}"
+ #${LDAP_PATCH:+ldap? ( http://dev.inversepath.com/openssh-lpk/${LDAP_PATCH} )}
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="static pam tcpd kerberos skey selinux X509 ldap smartcard hpn libedit X"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( >=sys-libs/libselinux-1.28 )
+ skey? ( >=sys-auth/skey-1.1.5-r1 )
+ ldap? ( net-nds/openldap )
+ libedit? ( dev-libs/libedit )
+ >=dev-libs/openssl-0.9.6d
+ >=sys-libs/zlib-1.2.3
+ smartcard? ( dev-libs/opensc )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ X? ( x11-apps/xauth )
+ userland_GNU? ( sys-apps/shadow )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ virtual/os-headers
+ sys-devel/autoconf"
+RDEPEND="${RDEPEND}
+ pam? ( sys-auth/pambase )"
+PROVIDE="virtual/ssh"
+
+S=${WORKDIR}/${PARCH}
+
+pkg_setup() {
+ # this sucks, but i'd rather have people unable to `emerge -u openssh`
+ # than not be able to log in to their server any more
+ maybe_fail() { [[ -z ${!2} ]] && use ${1} && echo ${1} ; }
+ local fail="
+ $(maybe_fail X509 X509_PATCH)
+ $(maybe_fail ldap LDAP_PATCH)
+ "
+ fail=$(echo ${fail})
+ if [[ -n ${fail} ]] ; then
+ eerror "Sorry, but this version does not yet support features"
+ eerror "that you requested: ${fail}"
+ eerror "Please mask ${PF} for now and check back later:"
+ eerror " # echo '=${CATEGORY}/${PF}' >> /etc/portage/package.mask"
+ die "booooo"
+ fi
+}
+
+src_unpack() {
+ unpack ${PARCH}.tar.gz
+ cd "${S}"
+
+ sed -i \
+ -e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
+ pathnames.h || die
+
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH} "${FILESDIR}"/${PN}-5.1_p1-x509-hpn-glue.patch
+ use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch
+ if ! use X509 ; then
+ if [[ -n ${LDAP_PATCH} ]] && use ldap ; then
+ # The patch for bug 210110 64-bit stuff is now included.
+ epatch "${DISTDIR}"/${LDAP_PATCH}
+ epatch "${FILESDIR}"/${PN}-5.1_p1-ldap-hpn-glue.patch
+ fi
+ #epatch "${DISTDIR}"/openssh-5.0p1-gsskex-20080404.patch #115553 #216932
+ else
+ use ldap && ewarn "Sorry, X509 and ldap don't get along, disabling ldap"
+ fi
+ epatch "${FILESDIR}"/${PN}-4.7_p1-GSSAPI-dns.patch #165444 integrated into gsskex
+ [[ -n ${HPN_PATCH} ]] && use hpn && epatch "${DISTDIR}"/${HPN_PATCH}
+ epatch "${FILESDIR}"/${PN}-4.7p1-selinux.diff #191665
+
+ sed -i "s:-lcrypto:$(pkg-config --libs openssl):" configure{,.ac} || die
+
+ epatch "${FILESDIR}"/${P}-null-banner.patch #244222
+ epatch "${FILESDIR}"/${P}-escaped-banner.patch #244222
+
+ eautoreconf
+}
+
+src_compile() {
+ addwrite /dev/ptmx
+ addpredict /etc/skey/skeykeys #skey configure code triggers this
+
+ local myconf=""
+ if use static ; then
+ append-ldflags -static
+ use pam && ewarn "Disabling pam support becuse of static flag"
+ myconf="${myconf} --without-pam"
+ else
+ myconf="${myconf} $(use_with pam)"
+ fi
+
+ econf \
+ --with-ldflags="${LDFLAGS}" \
+ --disable-strip \
+ --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/$(get_libdir)/misc \
+ --datadir=/usr/share/openssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ --with-ssl-engine \
+ $(use ldap && [ -n "${LDAP_PATCH}" ] && use_with ldap) \
+ $(use_with libedit) \
+ $(use_with kerberos kerberos5 /usr) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with selinux) \
+ $(use_with skey) \
+ $(use_with smartcard opensc) \
+ ${myconf} \
+ || die "bad configure"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install-nokeys DESTDIR="${D}" || die
+ fperms 600 /etc/ssh/sshd_config
+ dobin contrib/ssh-copy-id
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
+ newconfd "${FILESDIR}"/sshd.confd sshd
+ keepdir /var/empty
+
+ newpamd "${FILESDIR}"/sshd.pam_include.2 sshd
+ use pam \
+ && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
+ && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
+
+ doman contrib/ssh-copy-id.1
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+
+ diropts -m 0700
+ dodir /etc/skel/.ssh
+}
+
+pkg_postinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 -1 /var/empty sshd
+
+ # help fix broken perms caused by older ebuilds.
+ # can probably cut this after the next stage release.
+ chmod u+x "${ROOT}"/etc/skel/.ssh >& /dev/null
+
+ ewarn "Remember to merge your config files in /etc/ssh/ and then"
+ ewarn "restart sshd: '/etc/init.d/sshd restart'."
+ if use pam ; then
+ echo
+ ewarn "Please be aware users need a valid shell in /etc/passwd"
+ ewarn "in order to be allowed to login."
+ fi
+}