summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-05-05 07:28:20 +0000
committerMike Frysinger <vapier@gentoo.org>2007-05-05 07:28:20 +0000
commitf0b3d5c6109ee520ff00aac56add1d6aec1187b7 (patch)
tree80c88b12c5d90c6a1e148f0e2fb864c902278aec /net-misc
parentVersion bump (diff)
downloadgentoo-2-f0b3d5c6109ee520ff00aac56add1d6aec1187b7.tar.gz
gentoo-2-f0b3d5c6109ee520ff00aac56add1d6aec1187b7.tar.bz2
gentoo-2-f0b3d5c6109ee520ff00aac56add1d6aec1187b7.zip
Version bump #175853 by Raul Porcel.
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntp/ChangeLog7
-rw-r--r--net-misc/ntp/files/digest-ntp-4.2.4_p06
-rw-r--r--net-misc/ntp/ntp-4.2.4_p0.ebuild136
3 files changed, 148 insertions, 1 deletions
diff --git a/net-misc/ntp/ChangeLog b/net-misc/ntp/ChangeLog
index cad6badb47d5..50e268a5d724 100644
--- a/net-misc/ntp/ChangeLog
+++ b/net-misc/ntp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/ntp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.100 2007/03/14 19:44:25 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ChangeLog,v 1.101 2007/05/05 07:28:20 vapier Exp $
+
+*ntp-4.2.4_p0 (05 May 2007)
+
+ 05 May 2007; Mike Frysinger <vapier@gentoo.org> +ntp-4.2.4_p0.ebuild:
+ Version bump #175853 by Raul Porcel.
14 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org> ntp-4.2.4-r1.ebuild:
Stable on alpha wrt bug #169078.
diff --git a/net-misc/ntp/files/digest-ntp-4.2.4_p0 b/net-misc/ntp/files/digest-ntp-4.2.4_p0
new file mode 100644
index 000000000000..517d8401e1cd
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.2.4_p0
@@ -0,0 +1,6 @@
+MD5 3da9d6093041f4e7d1064cd9e01b9577 ntp-4.2.4p0-manpages.tar.bz2 49066
+RMD160 a8e9bd77560b4876496f0685b3db6acc56ad8139 ntp-4.2.4p0-manpages.tar.bz2 49066
+SHA256 2a6c4bad4ce1d35b3497eb4f177cb71eaa76ff8812dfdb36c48c41a12132e8fa ntp-4.2.4p0-manpages.tar.bz2 49066
+MD5 6f381e3764eac481bed9cf7e4d508952 ntp-4.2.4p0.tar.gz 3421642
+RMD160 ecda7d3a7734017bd40fede8abed69edddbf64a8 ntp-4.2.4p0.tar.gz 3421642
+SHA256 ec53b60ec345db194ce2c7629fc4b78b1793c4b22d1bdb86be9c8b40e7c204c8 ntp-4.2.4p0.tar.gz 3421642
diff --git a/net-misc/ntp/ntp-4.2.4_p0.ebuild b/net-misc/ntp/ntp-4.2.4_p0.ebuild
new file mode 100644
index 000000000000..10578271685d
--- /dev/null
+++ b/net-misc/ntp/ntp-4.2.4_p0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.2.4_p0.ebuild,v 1.1 2007/05/05 07:28:20 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_p/p}
+DESCRIPTION="Network Time Protocol suite/programs"
+HOMEPAGE="http://www.ntp.org/"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-${PV:0:3}/${MY_P}.tar.gz
+ mirror://gentoo/${MY_P}-manpages.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="parse-clocks caps selinux ssl ipv6 debug openntpd"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1
+ kernel_linux? ( caps? ( sys-libs/libcap ) )
+ !openntpd? ( !net-misc/openntpd )
+ ssl? ( dev-libs/openssl )
+ selinux? ( sec-policy/selinux-ntp )"
+PDEPEND="openntpd? ( net-misc/openntpd )"
+
+S=${WORKDIR}/${MY_P}
+
+hax_bitkeeper() {
+ # the makefiles have support for bk ...
+ # basically we have to do this or bk will try to write
+ # to files in /opt/bitkeeper causing sandbox violations ;(
+ mkdir -p "${T}"/fakebin
+ echo "#!/bin/sh"$'\n'"exit 1" > "${T}"/fakebin/bk
+ chmod a+x "${T}"/fakebin/bk
+ export PATH="${T}/fakebin:${PATH}"
+}
+
+pkg_setup() {
+ enewgroup ntp 123
+ enewuser ntp 123 -1 /dev/null ntp
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Needs to be ported ...
+ #epatch "${FILESDIR}"/4.2.0.20040617-hostname.patch
+
+ sed -i \
+ -e 's:md5\.h:touch_not_my_md5:g' \
+ -e 's:-lelf:-la_doe_a_deer_a_female_deer:g' \
+ -e 's:-lmd5:-li_dont_want_no_stinkin_md5:g' \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ hax_bitkeeper
+ econf \
+ $(use_enable caps linuxcaps) \
+ $(use_enable parse-clocks) \
+ $(use_enable ipv6) \
+ $(use_enable debug debugging) \
+ $(use_with ssl crypto) \
+ || die
+ emake || die
+}
+
+src_install() {
+ hax_bitkeeper
+ emake install DESTDIR="${D}" || die "install failed"
+ # move ntpd/ntpdate to sbin #66671
+ dodir /usr/sbin
+ mv "${D}"/usr/bin/{ntpd,ntpdate} "${D}"/usr/sbin/ || die "move to sbin"
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ doman "${WORKDIR}"/man/*.[58]
+ dohtml -r html/*
+
+ insinto /usr/share/ntp
+ doins "${FILESDIR}"/ntp.conf
+ cp -r scripts/* "${D}"/usr/share/ntp/
+ chmod -R go-w "${D}"/usr/share/ntp
+ find "${D}"/usr/share/ntp \
+ '(' \
+ -name '*.in' -o \
+ -name 'Makefile*' -o \
+ -name 'rc[12]' -o \
+ -name support \
+ ')' \
+ -exec rm -r {} \;
+
+ insinto /etc
+ doins "${FILESDIR}"/ntp.conf
+ newinitd "${FILESDIR}"/ntpd.rc ntpd
+ newconfd "${FILESDIR}"/ntpd.confd ntpd
+ newinitd "${FILESDIR}"/ntp-client.rc ntp-client
+ newconfd "${FILESDIR}"/ntp-client.confd ntp-client
+ use caps || dosed "s|-u ntp:ntp||" /etc/conf.d/ntpd
+ dosed "s:/usr/bin:/usr/sbin:" /etc/init.d/ntpd
+
+ keepdir /var/lib/ntp
+ fowners ntp:ntp /var/lib/ntp
+
+ if use openntpd ; then
+ cd "${D}"
+ rm usr/sbin/ntpd || die
+ rm -r var/lib
+ rm etc/{conf,init}.d/ntpd
+ rm usr/share/man/*/ntpd.8 || die
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/ntp.conf ]] ; then
+ rm -f "${D}"/etc/ntp.conf
+ fi
+}
+
+pkg_postinst() {
+ ewarn "You can find an example /etc/ntp.conf in /usr/share/ntp/"
+ ewarn "Review /etc/ntp.conf to setup server info."
+ ewarn "Review /etc/conf.d/ntpd to setup init.d info."
+ echo
+ einfo "The way ntp sets and maintains your system time has changed."
+ einfo "Now you can use /etc/init.d/ntp-client to set your time at"
+ einfo "boot while you can use /etc/init.d/ntpd to maintain your time"
+ einfo "while your machine runs"
+ if [[ -n $(egrep '^[^#].*notrust' "${ROOT}"/etc/ntp.conf) ]] ; then
+ echo
+ eerror "The notrust option was found in your /etc/ntp.conf!"
+ ewarn "If your ntpd starts sending out weird responses,"
+ ewarn "then make sure you have keys properly setup and see"
+ ewarn "http://bugs.gentoo.org/41827"
+ fi
+}