summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-10 22:45:30 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-10 22:45:30 +0000
commitead892aee79a487a1a3b2bea876c18a50382c548 (patch)
treeaf35f8a89e8162fee6ad15f08d179df771eeb0b4 /net-misc
parentupdated for Tk vulnerability and QA fixes (see bug #208464) (diff)
downloadgentoo-2-ead892aee79a487a1a3b2bea876c18a50382c548.tar.gz
gentoo-2-ead892aee79a487a1a3b2bea876c18a50382c548.tar.bz2
gentoo-2-ead892aee79a487a1a3b2bea876c18a50382c548.zip
Fix building with USE='X509 hpn' #209479 by Jose daLuz.
(Portage version: 2.1.4.1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog6
-rw-r--r--net-misc/openssh/files/openssh-4.7_p1-x509-hpn-glue.patch92
-rw-r--r--net-misc/openssh/openssh-4.7_p1-r4.ebuild4
3 files changed, 99 insertions, 3 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 0c285ac3647c..dc326b929119 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.275 2008/02/10 09:17:41 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.276 2008/02/10 22:45:29 vapier Exp $
+
+ 10 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/openssh-4.7_p1-x509-hpn-glue.patch, openssh-4.7_p1-r4.ebuild:
+ Fix building with USE='X509 hpn' #209479 by Jose daLuz.
10 Feb 2008; Tobias Scherbaum <dertobi123@gentoo.org>
openssh-4.7_p1-r3.ebuild:
diff --git a/net-misc/openssh/files/openssh-4.7_p1-x509-hpn-glue.patch b/net-misc/openssh/files/openssh-4.7_p1-x509-hpn-glue.patch
new file mode 100644
index 000000000000..974d6e1bd1f9
--- /dev/null
+++ b/net-misc/openssh/files/openssh-4.7_p1-x509-hpn-glue.patch
@@ -0,0 +1,92 @@
+move things around so hpn applies cleanly when using X509
+
+--- servconf.c
++++ servconf.c
+@@ -106,6 +106,18 @@
+ options->log_level = SYSLOG_LEVEL_NOT_SET;
+ options->rhosts_rsa_authentication = -1;
+ options->hostbased_authentication = -1;
++
++ options->hostbased_algorithms = NULL;
++ options->pubkey_algorithms = NULL;
++ ssh_x509flags_initialize(&options->x509flags, 1);
++#ifndef SSH_X509STORE_DISABLED
++ ssh_x509store_initialize(&options->ca);
++#endif /*ndef SSH_X509STORE_DISABLED*/
++#ifdef SSH_OCSP_ENABLED
++ options->va.type = -1;
++ options->va.certificate_file = NULL;
++ options->va.responder_url = NULL;
++#endif /*def SSH_OCSP_ENABLED*/
+ options->hostbased_uses_name_from_packet_only = -1;
+ options->rsa_authentication = -1;
+ options->pubkey_authentication = -1;
+@@ -146,18 +158,6 @@
+ options->permit_tun = -1;
+ options->num_permitted_opens = -1;
+ options->adm_forced_command = NULL;
+-
+- options->hostbased_algorithms = NULL;
+- options->pubkey_algorithms = NULL;
+- ssh_x509flags_initialize(&options->x509flags, 1);
+-#ifndef SSH_X509STORE_DISABLED
+- ssh_x509store_initialize(&options->ca);
+-#endif /*ndef SSH_X509STORE_DISABLED*/
+-#ifdef SSH_OCSP_ENABLED
+- options->va.type = -1;
+- options->va.certificate_file = NULL;
+- options->va.responder_url = NULL;
+-#endif /*def SSH_OCSP_ENABLED*/
+ }
+
+ void
+@@ -329,6 +329,16 @@
+ /* Portable-specific options */
+ sUsePAM,
+ /* Standard Options */
++ sHostbasedAlgorithms,
++ sPubkeyAlgorithms,
++ sX509KeyAlgorithm,
++ sAllowedClientCertPurpose,
++ sKeyAllowSelfIssued, sMandatoryCRL,
++ sCACertificateFile, sCACertificatePath,
++ sCARevocationFile, sCARevocationPath,
++ sCAldapVersion, sCAldapURL,
++ sVAType, sVACertificateFile,
++ sVAOCSPResponderURL,
+ sPort, sHostKeyFile, sServerKeyBits, sLoginGraceTime, sKeyRegenerationTime,
+ sPermitRootLogin, sLogFacility, sLogLevel,
+ sRhostsRSAAuthentication, sRSAAuthentication,
+@@ -351,16 +361,6 @@
+ sGssAuthentication, sGssCleanupCreds, sAcceptEnv, sPermitTunnel,
+ sMatch, sPermitOpen, sForceCommand,
+ sUsePrivilegeSeparation,
+- sHostbasedAlgorithms,
+- sPubkeyAlgorithms,
+- sX509KeyAlgorithm,
+- sAllowedClientCertPurpose,
+- sKeyAllowSelfIssued, sMandatoryCRL,
+- sCACertificateFile, sCACertificatePath,
+- sCARevocationFile, sCARevocationPath,
+- sCAldapVersion, sCAldapURL,
+- sVAType, sVACertificateFile,
+- sVAOCSPResponderURL,
+ sDeprecated, sUnsupported
+ } ServerOpCodes;
+
+--- Makefile.in
+++ Makefile.in
+@@ -44,11 +44,12 @@
+ CC=@CC@
+ LD=@LD@
+ CFLAGS=@CFLAGS@
+-CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ @LDAP_CPPFLAGS@ $(PATHS) @DEFS@
++CPPFLAGS=-I. -I$(srcdir) @CPPFLAGS@ $(PATHS) @DEFS@
+ LIBS=@LIBS@
+ SSHDLIBS=@SSHDLIBS@
+ LIBEDIT=@LIBEDIT@
+ LIBLDAP=@LDAP_LDFLAGS@ @LDAP_LIBS@
++CPPFLAGS += @LDAP_CPPFLAGS@
+ AR=@AR@
+ AWK=@AWK@
+ RANLIB=@RANLIB@
diff --git a/net-misc/openssh/openssh-4.7_p1-r4.ebuild b/net-misc/openssh/openssh-4.7_p1-r4.ebuild
index c9b65189f6bd..ef03cb999a2f 100644
--- a/net-misc/openssh/openssh-4.7_p1-r4.ebuild
+++ b/net-misc/openssh/openssh-4.7_p1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.7_p1-r4.ebuild,v 1.1 2008/02/09 20:21:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.7_p1-r4.ebuild,v 1.2 2008/02/10 22:45:29 vapier Exp $
inherit eutils flag-o-matic ccc multilib autotools pam
@@ -70,7 +70,7 @@ src_unpack() {
-e '/_PATH_XAUTH/s:/usr/X11R6/bin/xauth:/usr/bin/xauth:' \
pathnames.h || die
- use X509 && epatch "${DISTDIR}"/${X509_PATCH} "${FILESDIR}"/${PN}-4.4_p1-x509-hpn-glue.patch
+ use X509 && epatch "${DISTDIR}"/${X509_PATCH} "${FILESDIR}"/${PN}-4.7_p1-x509-hpn-glue.patch
use chroot && epatch "${FILESDIR}"/openssh-4.3_p1-chroot.patch
use smartcard && epatch "${FILESDIR}"/openssh-3.9_p1-opensc.patch
if ! use X509 ; then