summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-26 20:26:06 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-26 20:26:06 +0000
commite9ffe975291f6a52f27a76c19ea7896b020464bd (patch)
treee43507536e8854a98e7404e6953abf85d3c06e4e /net-misc
parentold (diff)
downloadgentoo-2-e9ffe975291f6a52f27a76c19ea7896b020464bd.tar.gz
gentoo-2-e9ffe975291f6a52f27a76c19ea7896b020464bd.tar.bz2
gentoo-2-e9ffe975291f6a52f27a76c19ea7896b020464bd.zip
Version bump #317097 by Francois Chenier.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/ChangeLog9
-rw-r--r--net-misc/whois/whois-5.0.2.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index cf7c71e91f12..14220a9411fc 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.134 2009/11/17 19:49:49 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.135 2010/04/26 20:26:06 vapier Exp $
+
+*whois-5.0.2 (26 Apr 2010)
+
+ 26 Apr 2010; Mike Frysinger <vapier@gentoo.org> +whois-5.0.2.ebuild:
+ Version bump #317097 by Francois Chenier.
17 Nov 2009; Brent Baude <ranger@gentoo.org> whois-4.7.36.ebuild:
Marking whois-4.7.36 ppc64 for bug 291095
diff --git a/net-misc/whois/whois-5.0.2.ebuild b/net-misc/whois/whois-5.0.2.ebuild
new file mode 100644
index 000000000000..082b83f17d23
--- /dev/null
+++ b/net-misc/whois/whois-5.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.2.ebuild,v 1.1 2010/04/26 20:26:06 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ fi
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ emake BASEDIR="${D}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${D}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${D}"/usr/bin/{whois,mdwhois}
+ fi
+}