summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-07-05 15:40:48 +0000
committerJeroen Roovers <jer@gentoo.org>2011-07-05 15:40:48 +0000
commite97ed4c3e69435b253a943b7876584c48630e53c (patch)
tree89c621b04db659ecdd8de376bd69236c3441445f /net-misc
parentx86 stable per bug 372983 (diff)
downloadgentoo-2-e97ed4c3e69435b253a943b7876584c48630e53c.tar.gz
gentoo-2-e97ed4c3e69435b253a943b7876584c48630e53c.tar.bz2
gentoo-2-e97ed4c3e69435b253a943b7876584c48630e53c.zip
Version bump.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/chrony/ChangeLog7
-rw-r--r--net-misc/chrony/chrony-1.26_pre1.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/net-misc/chrony/ChangeLog b/net-misc/chrony/ChangeLog
index a71a63e855c6..281c0ee70981 100644
--- a/net-misc/chrony/ChangeLog
+++ b/net-misc/chrony/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/chrony
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.77 2011/06/25 18:56:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/ChangeLog,v 1.78 2011/07/05 15:40:48 jer Exp $
+
+*chrony-1.26_pre1 (05 Jul 2011)
+
+ 05 Jul 2011; Jeroen Roovers <jer@gentoo.org> +chrony-1.26_pre1.ebuild:
+ Version bump.
25 Jun 2011; Raúl Porcel <armin76@gentoo.org> chrony-1.25.ebuild:
sparc stable wrt #370485
diff --git a/net-misc/chrony/chrony-1.26_pre1.ebuild b/net-misc/chrony/chrony-1.26_pre1.ebuild
new file mode 100644
index 000000000000..d679c69eba98
--- /dev/null
+++ b/net-misc/chrony/chrony-1.26_pre1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/chrony/chrony-1.26_pre1.ebuild,v 1.1 2011/07/05 15:40:48 jer Exp $
+
+EAPI=2
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_/-}
+
+DESCRIPTION="NTP client and server programs"
+HOMEPAGE="http://chrony.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="caps readline"
+
+RDEPEND="
+ readline? ( >=sys-libs/readline-4.1-r4 )
+ caps? ( sys-libs/libcap )
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ sed -i "s:/etc/chrony\.:/etc/chrony/chrony.:g" \
+ examples/* chrony*.{1,5,8} faq.txt chrony.texi || die "sed failed"
+}
+
+src_configure() {
+ tc-export CC
+ local myconf
+ use readline || myconf+=" --disable-readline"
+ #use ipv6 || myconf+=" --disable-ipv6"
+ use caps || myconf+=" --disable-linuxcaps"
+ # selfwritten configure
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc/chrony \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --docdir=/usr/share/doc/${PF} \
+ ${myconf} ${EXTRA_ECONF} || die "configure failed"
+}
+
+src_compile() {
+ emake all || die "make failed"
+ emake docs || die "make docs failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm "${D}"/usr/share/doc/${PF}/COPYING || die
+ dodoc examples/chrony.{conf,keys}.example || die
+ doinfo chrony.info* || die
+
+ newinitd "${FILESDIR}"/chronyd.rc chronyd || die
+ newconfd "${FILESDIR}"/chronyd.conf chronyd || die
+
+ keepdir /var/{lib,log}/chrony /etc/chrony
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/chrony.logrotate chrony
+}