summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-03-21 21:52:20 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-03-21 21:52:20 +0000
commite932eb47e0336bcb5947c9d88e53fc6a4665b9c1 (patch)
tree153cb223d1ea93849ed6e79c72d583c542748ac2 /net-misc
parentRemove old versions. (diff)
downloadgentoo-2-e932eb47e0336bcb5947c9d88e53fc6a4665b9c1.tar.gz
gentoo-2-e932eb47e0336bcb5947c9d88e53fc6a4665b9c1.tar.bz2
gentoo-2-e932eb47e0336bcb5947c9d88e53fc6a4665b9c1.zip
Version bump (bug #261572).
(Portage version: 13139-svn/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/neon/ChangeLog10
-rw-r--r--net-misc/neon/metadata.xml5
-rw-r--r--net-misc/neon/neon-0.28.4.ebuild112
3 files changed, 124 insertions, 3 deletions
diff --git a/net-misc/neon/ChangeLog b/net-misc/neon/ChangeLog
index 15bdcc50695a..41d92ee358c9 100644
--- a/net-misc/neon/ChangeLog
+++ b/net-misc/neon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/neon
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.118 2008/11/12 05:50:58 pva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/ChangeLog,v 1.119 2009/03/21 21:52:20 arfrever Exp $
+
+*neon-0.28.4 (21 Mar 2009)
+
+ 21 Mar 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ metadata.xml, +neon-0.28.4.ebuild:
+ Version bump (bug #261572).
12 Nov 2008; Peter Volkov <pva@gentoo.org> neon-0.28.3.ebuild:
~mips keyword back, bug #212056.
diff --git a/net-misc/neon/metadata.xml b/net-misc/neon/metadata.xml
index b9a90faa246f..bafb83449e30 100644
--- a/net-misc/neon/metadata.xml
+++ b/net-misc/neon/metadata.xml
@@ -1,7 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>apache</herd>
+ <maintainer>
+ <email>arfrever@gentoo.org</email>
+ <name>Arfrever Frehtes Taifersar Arahesis</name>
+ </maintainer>
<longdescription>
neon is an HTTP and WebDAV client library for Unix
systems, with a C language API. It provides high-level interfaces to
diff --git a/net-misc/neon/neon-0.28.4.ebuild b/net-misc/neon/neon-0.28.4.ebuild
new file mode 100644
index 000000000000..11fa5753ff53
--- /dev/null
+++ b/net-misc/neon/neon-0.28.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.28.4.ebuild,v 1.1 2009/03/21 21:52:20 arfrever Exp $
+
+inherit autotools eutils libtool versionator
+
+RESTRICT="test"
+
+DESCRIPTION="HTTP and WebDAV client library"
+HOMEPAGE="http://www.webdav.org/neon/"
+SRC_URI="http://www.webdav.org/neon/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc expat gnutls kerberos nls pkcs11 socks5 ssl zlib"
+IUSE_LINGUAS="cs de fr ja nn pl ru tr zh_CN"
+for lingua in ${IUSE_LINGUAS}; do
+ IUSE="${IUSE} linguas_${lingua}"
+done
+
+RDEPEND="expat? ( dev-libs/expat )
+ !expat? ( dev-libs/libxml2 )
+ gnutls? (
+ >=net-libs/gnutls-2.0
+ pkcs11? ( dev-libs/pakchois )
+ )
+ !gnutls? ( ssl? (
+ >=dev-libs/openssl-0.9.6f
+ pkcs11? ( dev-libs/pakchois )
+ ) )
+ kerberos? ( virtual/krb5 )
+ nls? ( virtual/libintl )
+ socks5? ( net-proxy/dante )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ local lingua linguas
+ for lingua in ${IUSE_LINGUAS}; do
+ use linguas_${lingua} && linguas="${linguas} ${lingua}"
+ done
+ sed -i -e "s/ALL_LINGUAS=.*/ALL_LINGUAS=\"${linguas}\"/g" configure.in
+ sed -i -e "s/socks5/socks/g" macros/neon.m4
+
+ AT_M4DIR="macros" eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ if has_version sys-libs/glibc; then
+ if built_with_use --missing true sys-libs/glibc nptlonly \
+ || built_with_use --missing true sys-libs/glibc nptl; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf="${myconf} --enable-threadsafe-ssl=posix"
+ fi
+ fi
+
+ if use expat; then
+ myconf="${myconf} --with-expat"
+ else
+ myconf="${myconf} --with-libxml2"
+ fi
+
+ if use gnutls; then
+ myconf="${myconf} --with-ssl=gnutls"
+ elif use ssl; then
+ myconf="${myconf} --with-ssl=openssl"
+ fi
+
+ econf \
+ --enable-static \
+ --enable-shared \
+ $(use_with kerberos gssapi) \
+ $(use_enable nls) \
+ $(use_with pkcs11 pakchois) \
+ $(use_with socks5 socks) \
+ $(use_with zlib) \
+ ${myconf}
+ emake || die "emake failed"
+}
+
+src_test() {
+ emake check || die "Trying make check without success."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install-lib install-headers install-config install-nls || die "emake install failed"
+
+ if use doc; then
+ emake DESTDIR="${D}" install-docs || die "emake install-docs failed"
+ fi
+
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
+ doman doc/man/*.[1-8]
+}
+
+pkg_postinst() {
+ ewarn "Neon has a policy of breaking API across minor versions, this means"
+ ewarn "that any package that links against neon may be broken after"
+ ewarn "updating. They will remain broken until they are ported to the"
+ ewarn "new API. You can downgrade neon to the previous version by doing:"
+ ewarn
+ ewarn " emerge --oneshot '<net-misc/neon-$(get_version_component_range 1-2 ${PV})'"
+ ewarn
+ ewarn "You may also have to downgrade any package that has already been"
+ ewarn "ported to the new API."
+}