summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-09-02 05:16:27 +0000
committerTim Harder <radhermit@gentoo.org>2011-09-02 05:16:27 +0000
commitdaf81cd477d6a6d7a6deaa519b421f6671295f0c (patch)
treeadb6032bddba1524919be9aaf30729fae03b19e6 /net-misc
parentVersion bump. Add static-libs USE flag. (diff)
downloadgentoo-2-daf81cd477d6a6d7a6deaa519b421f6671295f0c.tar.gz
gentoo-2-daf81cd477d6a6d7a6deaa519b421f6671295f0c.tar.bz2
gentoo-2-daf81cd477d6a6d7a6deaa519b421f6671295f0c.zip
Revision bump. Add gnutls USE flag and fix ssl issues (bugs #381441 and #381513).
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget/ChangeLog8
-rw-r--r--net-misc/wget/wget-1.13.3-r2.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index 2f2e714e9217..b76741e29551 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.142 2011/09/01 18:33:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.143 2011/09/02 05:16:27 radhermit Exp $
+
+*wget-1.13.3-r2 (02 Sep 2011)
+
+ 02 Sep 2011; Tim Harder <radhermit@gentoo.org> +wget-1.13.3-r2.ebuild:
+ Revision bump. Add gnutls USE flag and fix ssl issues (bugs #381441 and
+ #381513).
01 Sep 2011; Fabian Groffen <grobian@gentoo.org> wget-1.13.3-r1.ebuild:
Fix compilation on Solaris
diff --git a/net-misc/wget/wget-1.13.3-r2.ebuild b/net-misc/wget/wget-1.13.3-r2.ebuild
new file mode 100644
index 000000000000..0d141d5a261d
--- /dev/null
+++ b/net-misc/wget/wget-1.13.3-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.3-r2.ebuild,v 1.1 2011/09/02 05:16:27 radhermit Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Network utility to retrieve files from the WWW"
+HOMEPAGE="http://www.gnu.org/software/wget/"
+SRC_URI="mirror://gnu/wget/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug gnutls idn ipv6 nls ntlm +ssl static"
+
+RDEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6b ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+REQUIRED_USE="ntlm? ( !gnutls ssl )"
+
+DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.13-static-link-libz.patch
+}
+
+src_configure() {
+ # openssl-0.9.8 now builds with -pthread on the BSD's
+ use elibc_FreeBSD && use ssl && append-ldflags -pthread
+ # fix compilation on Solaris, we need filio.h for FIONBIO as used in
+ # the included gnutls -- force ioctl.h to include this header
+ [[ ${CHOST} == *-solaris* ]] && append-flags -DBSD_COMP=1
+
+ local myconf
+ if use gnutls ; then
+ myconf+=" --with-ssl=gnutls"
+ elif use ssl ; then
+ myconf+=" --with-ssl=openssl"
+ else
+ myconf+=" --without-ssl"
+ fi
+
+ if use gnutls || use ssl ; then
+ myconf+=" --enable-opie --enable-digest"
+ else
+ myconf+=" --disable-opie --disable-digest"
+ fi
+
+ use static && append-ldflags -static
+ econf \
+ --disable-rpath \
+ $(use_enable idn iri) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable ntlm) \
+ $(use_enable debug) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ use ipv6 && cat "${FILESDIR}"/wgetrc-ipv6 >> "${ED}"/etc/wgetrc
+
+ sed -i \
+ -e "s:/usr/local/etc:${EPREFIX}/etc:g" \
+ "${ED}"/etc/wgetrc \
+ "${ED}"/usr/share/man/man1/wget.1 \
+ "${ED}"/usr/share/info/wget.info
+}