summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-05 23:13:51 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-05 23:13:51 +0000
commitd56aa40346f651552a5fa08b7d87ad753d459ed3 (patch)
tree65039b3a3cc449b303139d81d1975b90281e2967 /net-misc
parentimlib to /usr (diff)
downloadgentoo-2-d56aa40346f651552a5fa08b7d87ad753d459ed3.tar.gz
gentoo-2-d56aa40346f651552a5fa08b7d87ad753d459ed3.tar.bz2
gentoo-2-d56aa40346f651552a5fa08b7d87ad753d459ed3.zip
new version submitted to ebuild list
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/ntp/files/digest-ntp-4.1.711
-rw-r--r--net-misc/ntp/ntp-4.1.71.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/ntp/files/digest-ntp-4.1.71 b/net-misc/ntp/files/digest-ntp-4.1.71
new file mode 100644
index 000000000000..8cc30fb0df0f
--- /dev/null
+++ b/net-misc/ntp/files/digest-ntp-4.1.71
@@ -0,0 +1 @@
+MD5 d7598b507bd201b69163f7a76bbf6e48 ntp-4.1.71.tar.gz
diff --git a/net-misc/ntp/ntp-4.1.71.ebuild b/net-misc/ntp/ntp-4.1.71.ebuild
new file mode 100644
index 000000000000..483a0ca42137
--- /dev/null
+++ b/net-misc/ntp/ntp-4.1.71.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Terry Chan <tchan@enteract.com>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ntp/ntp-4.1.71.ebuild,v 1.1 2001/10/05 23:13:51 woodchip Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Time Protocol suite/programs"
+SRC_URI="http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/${P}.tar.gz"
+HOMEPAGE="http://www.ntp.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/readline-4.1"
+
+src_compile() {
+ cp configure configure.orig
+ sed -e "s:-Wpointer-arith::" configure.orig > configure
+ LDFLAGS="$LDFLAGS -lncurses"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man \
+ --host=${CHOST} --build=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ dodoc ChangeLog INSTALL NEWS README TODO WHERE-TO-START
+ docinto html ; dodoc html/*.htm
+ docinto html/hints ; dodoc html/hints/*
+ docinto html/pic ; dodoc html/pic/*
+
+ insinto /usr/share/ntp
+ doins scripts/*
+}