summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-10-04 09:10:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-10-04 09:10:43 +0000
commitd2b1026807a8f5b73980a083a535c645fa395812 (patch)
tree359894688d4febd56d4a44d68da1621760d706b4 /net-misc
parentRepacked again. (diff)
downloadgentoo-2-d2b1026807a8f5b73980a083a535c645fa395812.tar.gz
gentoo-2-d2b1026807a8f5b73980a083a535c645fa395812.tar.bz2
gentoo-2-d2b1026807a8f5b73980a083a535c645fa395812.zip
Version bump.
(Portage version: 2.2.0_alpha60/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/memcached/ChangeLog7
-rw-r--r--net-misc/memcached/memcached-1.4.8.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/memcached/ChangeLog b/net-misc/memcached/ChangeLog
index 64e143e4a463..fa71e8d651f2 100644
--- a/net-misc/memcached/ChangeLog
+++ b/net-misc/memcached/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/memcached
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/ChangeLog,v 1.115 2011/08/17 06:43:20 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/ChangeLog,v 1.116 2011/10/04 09:10:43 robbat2 Exp $
+
+*memcached-1.4.8 (04 Oct 2011)
+
+ 04 Oct 2011; Robin H. Johnson <robbat2@gentoo.org> +memcached-1.4.8.ebuild:
+ Version bump.
*memcached-1.4.7 (17 Aug 2011)
diff --git a/net-misc/memcached/memcached-1.4.8.ebuild b/net-misc/memcached/memcached-1.4.8.ebuild
new file mode 100644
index 000000000000..1d6bec5d4208
--- /dev/null
+++ b/net-misc/memcached/memcached-1.4.8.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/memcached/memcached-1.4.8.ebuild,v 1.1 2011/10/04 09:10:43 robbat2 Exp $
+
+EAPI=2
+inherit eutils autotools flag-o-matic
+
+MY_PV="${PV/_rc/-rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="High-performance, distributed memory object caching system"
+HOMEPAGE="http://code.google.com/p/memcached/"
+SRC_URI="http://memcached.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test slabs-reassign debug sasl" # hugetlbfs later
+
+RDEPEND=">=dev-libs/libevent-1.4
+ dev-lang/perl
+ sasl? ( dev-libs/cyrus-sasl )"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Harness >=dev-perl/Cache-Memcached-1.24 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-1.2.2-fbsd.patch"
+ # Handled different upstream
+ #epatch "${FILESDIR}/${PN}-1.3.3-gcc4-slab-fixup.patch"
+ epatch "${FILESDIR}/${PN}-1.4.0-fix-as-needed-linking.patch"
+ epatch "${FILESDIR}/${PN}-1.4.4-as-needed.patch"
+ sed -i -e 's,-Werror,,g' configure.ac || die "sed failed"
+ eautoreconf
+ use slabs-reassign && append-flags -DALLOW_SLABS_REASSIGN
+}
+
+src_configure() {
+ econf \
+ --disable-docs \
+ $(use_enable sasl)
+ # The xml2rfc tool to build the additional docs requires TCL :-(
+ # `use_enable doc docs`
+}
+
+src_compile() {
+ # There is a heavy degree of per-object compile flags
+ # Users do NOT know better than upstream. Trying to compile the testapp and
+ # the -debug version with -DNDEBUG _WILL_ fail.
+ append-flags -UNDEBUG
+ emake testapp memcached-debug CFLAGS="${CFLAGS}" || die "emake of testapp and memcached-debug failed."
+ filter-flags -UNDEBUG
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dobin scripts/memcached-tool
+ use debug && dobin memcached-debug
+
+ dodoc AUTHORS ChangeLog NEWS README doc/{CONTRIBUTORS,*.txt}
+
+ newconfd "${FILESDIR}"/1.3.3/conf memcached
+ newinitd "${FILESDIR}"/1.3.3/init memcached
+}
+
+pkg_postinst() {
+ enewuser memcached -1 -1 /dev/null daemon
+
+ elog "With this version of Memcached Gentoo now supports multiple instances."
+ elog "To enable this you should create a symlink in /etc/init.d/ for each instance"
+ elog "to /etc/init.d/memcached and create the matching conf files in /etc/conf.d/"
+ elog "Please see Gentoo bug #122246 for more info"
+}
+
+src_test() {
+ emake -j1 test || die "Failed testing"
+}